SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2014-03-19 00:51:53

WheatThins
Member
From: Chicago
Registered: 2013-11-04
Posts: 41
Website

Wireless Not Working

Model: HP ENVY Touchsmart k012dx

Hello, I am currently able to connect via ethernet on fully updated Crunchbang 11, but not via WiFi.

Output of terminal commands from http://crunchbang.org/forums/viewtopic.php?id=27628 is below.

http://tny.cz/14bd1aeb

wheatthins@WheatThins:~$ sudo rfkill list
0: hp-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: hp-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
wheatthins@WheatThins:~$

Offline

Be excellent to each other!

#2 2014-03-19 16:25:08

zazen23
#! Member
Registered: 2011-07-10
Posts: 72

Re: Wireless Not Working

Lspci output would be helpful.

Offline

#3 2014-03-19 18:17:26

WheatThins
Member
From: Chicago
Registered: 2013-11-04
Posts: 41
Website

Re: Wireless Not Working

zazen23 wrote:

Lspci output would be helpful.

I included it in that tinypaste link.

WheatThins wrote:

Last edited by WheatThins (2014-03-19 18:18:58)

Offline

#4 2014-03-20 03:57:41

zazen23
#! Member
Registered: 2011-07-10
Posts: 72

Re: Wireless Not Working

What I suspected Network controller: Ralink corp. Device 3290
How to enable WiFi in Debian Wheezy.

    Add wheezy-backports to /etc/apt/sources.list.

    To install the current backported kernel and RT3290 firmware:

    # aptitude -t wheezy-backports install linux-image-`uname -r|sed 's,[^-]*-[^-]*-,,'` firmware-ralink

    Restart the system to use the newly installed Linux kernel.
   P.S. My Old eyes did not see all your original post.  yikes

Last edited by zazen23 (2014-03-20 04:00:37)

Offline

#5 2014-03-22 07:47:52

WheatThins
Member
From: Chicago
Registered: 2013-11-04
Posts: 41
Website

Re: Wireless Not Working

zazen23 wrote:

What I suspected Network controller: Ralink corp. Device 3290
How to enable WiFi in Debian Wheezy.

    Add wheezy-backports to /etc/apt/sources.list.

    To install the current backported kernel and RT3290 firmware:

    # aptitude -t wheezy-backports install linux-image-`uname -r|sed 's,[^-]*-[^-]*-,,'` firmware-ralink

    Restart the system to use the newly installed Linux kernel.
   P.S. My Old eyes did not see all your original post.  yikes

I get the error
E: The value 'wheezy-backports' is invalid for APT::Default-Release as such a release is not available in the sources

Last edited by WheatThins (2014-03-22 18:31:18)

Offline

#6 2014-03-23 06:38:35

zazen23
#! Member
Registered: 2011-07-10
Posts: 72

Offline

#7 2014-03-24 18:50:55

WheatThins
Member
From: Chicago
Registered: 2013-11-04
Posts: 41
Website

Re: Wireless Not Working

So I got the below errors on installing from aptitude, but the network manager seems to at least recognize that I have wireless now.

It displays this error: device not ready (firmware missing) underneath wireless networks, whereas it once displayed nothing.

Get: 1 http://ftp.debian.org/debian/ wheezy-backports/main initramfs-tools all 0.115~bpo70+1 [92.6 kB]
Get: 2 http://ftp.debian.org/debian/ wheezy-backports/main linux-image-3.13-0.bpo.1-amd64 amd64 3.13.5-1~bpo70+1 [30.4 MB]
Get: 3 http://ftp.debian.org/debian/ wheezy-backports/main linux-image-amd64 amd64 3.13+56~bpo70+1 [6,018 B]
Fetched 30.5 MB in 1min 19s (382 kB/s)                                         
Preconfiguring packages ...
(Reading database ... 109712 files and directories currently installed.)
Removing libdirac-decoder0:amd64 ...
Removing xulrunner-20.0 ...
Removing libmozjs20d ...
Removing libxcb-xfixes0:amd64 ...
Processing triggers for man-db ...
(Reading database ... 109654 files and directories currently installed.)
Preparing to replace initramfs-tools 0.109.1 (using .../initramfs-tools_0.115~bpo70+1_all.deb) ...
Unpacking replacement initramfs-tools ...
Selecting previously unselected package linux-image-3.13-0.bpo.1-amd64.
Unpacking linux-image-3.13-0.bpo.1-amd64 (from .../linux-image-3.13-0.bpo.1-amd64_3.13.5-1~bpo70+1_amd64.deb) ...
/etc/kernel/preinst.d/intel-microcode:
libkmod: ERROR ../libkmod/libkmod-config.c:686 kmod_config_parse: /etc/modprobe.d/fbdev-blacklist.conf line 6: ignoring bad line starting with 'fb'
libkmod: ERROR ../libkmod/libkmod-config.c:686 kmod_config_parse: /etc/modprobe.d/fbdev-blacklist.conf line 6: ignoring bad line starting with 'fb'
Preparing to replace linux-image-amd64 3.2+46 (using .../linux-image-amd64_3.13+56~bpo70+1_amd64.deb) ...
Unpacking replacement linux-image-amd64 ...
Processing triggers for man-db ...
Setting up initramfs-tools (0.115~bpo70+1) ...
update-initramfs: deferring update (trigger activated)
Setting up linux-image-3.13-0.bpo.1-amd64 (3.13.5-1~bpo70+1) ...
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-3.13-0.bpo.1-amd64
libkmod: ERROR ../libkmod/libkmod-config.c:686 kmod_config_parse: /etc/modprobe.d/fbdev-blacklist.conf line 6: ignoring bad line starting with 'fb'
libkmod: ERROR ../libkmod/libkmod-config.c:686 kmod_config_parse: /etc/modprobe.d/fbdev-blacklist.conf line 6: ignoring bad line starting with 'fb'
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-3.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8402-1.fw for module r8169
libkmod: ERROR ../libkmod/libkmod-config.c:686 kmod_config_parse: /etc/modprobe.d/fbdev-blacklist.conf line 6: ignoring bad line starting with 'fb'
libkmod: ERROR ../libkmod/libkmod-config.c:686 kmod_config_parse: /etc/modprobe.d/fbdev-blacklist.conf line 6: ignoring bad line starting with 'fb'
libkmod: ERROR ../libkmod/libkmod-config.c:686 kmod_config_parse: /etc/modprobe.d/fbdev-blacklist.conf line 6: ignoring bad line starting with 'fb'
libkmod: ERROR ../libkmod/libkmod-config.c:686 kmod_config_parse: /etc/modprobe.d/fbdev-blacklist.conf line 6: ignoring bad line starting with 'fb'
libkmod: ERROR ../libkmod/libkmod-config.c:686 kmod_config_parse: /etc/modprobe.d/fbdev-blacklist.conf line 6: ignoring bad line starting with 'fb'
libkmod: ERROR ../libkmod/libkmod-config.c:686 kmod_config_parse: /etc/modprobe.d/fbdev-blacklist.conf line 6: ignoring bad line starting with 'fb'
libkmod: ERROR ../libkmod/libkmod-config.c:686 kmod_config_parse: /etc/modprobe.d/fbdev-blacklist.conf line 6: ignoring bad line starting with 'fb'
libkmod: ERROR ../libkmod/libkmod-config.c:686 kmod_config_parse: /etc/modprobe.d/fbdev-blacklist.conf line 6: ignoring bad line starting with 'fb'
libkmod: ERROR ../libkmod/libkmod-config.c:686 kmod_config_parse: /etc/modprobe.d/fbdev-blacklist.conf line 6: ignoring bad line starting with 'fb'
libkmod: ERROR ../libkmod/libkmod-config.c:686 kmod_config_parse: /etc/modprobe.d/fbdev-blacklist.conf line 6: ignoring bad line starting with 'fb'
libkmod: ERROR ../libkmod/libkmod-config.c:686 kmod_config_parse: /etc/modprobe.d/fbdev-blacklist.conf line 6: ignoring bad line starting with 'fb'
libkmod: ERROR ../libkmod/libkmod-config.c:686 kmod_config_parse: /etc/modprobe.d/fbdev-blacklist.conf line 6: ignoring bad line starting with 'fb'
/etc/kernel/postinst.d/zz-update-grub:
Generating grub.cfg ...
Found background image: /usr/share/images/desktop-base/grub-splash-crunchbang.png
Found linux image: /boot/vmlinuz-3.13-0.bpo.1-amd64
Found initrd image: /boot/initrd.img-3.13-0.bpo.1-amd64
Found linux image: /boot/vmlinuz-3.2.0-4-amd64
Found initrd image: /boot/initrd.img-3.2.0-4-amd64
Found Windows 7 (loader) on /dev/sda1
done
Setting up linux-image-amd64 (3.13+56~bpo70+1) ...
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.13-0.bpo.1-amd64
libkmod: ERROR ../libkmod/libkmod-config.c:686 kmod_config_parse: /etc/modprobe.d/fbdev-blacklist.conf line 6: ignoring bad line starting with 'fb'
libkmod: ERROR ../libkmod/libkmod-config.c:686 kmod_config_parse: /etc/modprobe.d/fbdev-blacklist.conf line 6: ignoring bad line starting with 'fb'
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-3.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8402-1.fw for module r8169
libkmod: ERROR ../libkmod/libkmod-config.c:686 kmod_config_parse: /etc/modprobe.d/fbdev-blacklist.conf line 6: ignoring bad line starting with 'fb'
libkmod: ERROR ../libkmod/libkmod-config.c:686 kmod_config_parse: /etc/modprobe.d/fbdev-blacklist.conf line 6: ignoring bad line starting with 'fb'
libkmod: ERROR ../libkmod/libkmod-config.c:686 kmod_config_parse: /etc/modprobe.d/fbdev-blacklist.conf line 6: ignoring bad line starting with 'fb'
libkmod: ERROR ../libkmod/libkmod-config.c:686 kmod_config_parse: /etc/modprobe.d/fbdev-blacklist.conf line 6: ignoring bad line starting with 'fb'
libkmod: ERROR ../libkmod/libkmod-config.c:686 kmod_config_parse: /etc/modprobe.d/fbdev-blacklist.conf line 6: ignoring bad line starting with 'fb'
libkmod: ERROR ../libkmod/libkmod-config.c:686 kmod_config_parse: /etc/modprobe.d/fbdev-blacklist.conf line 6: ignoring bad line starting with 'fb'
libkmod: ERROR ../libkmod/libkmod-config.c:686 kmod_config_parse: /etc/modprobe.d/fbdev-blacklist.conf line 6: ignoring bad line starting with 'fb'
libkmod: ERROR ../libkmod/libkmod-config.c:686 kmod_config_parse: /etc/modprobe.d/fbdev-blacklist.conf line 6: ignoring bad line starting with 'fb'
libkmod: ERROR ../libkmod/libkmod-config.c:686 kmod_config_parse: /etc/modprobe.d/fbdev-blacklist.conf line 6: ignoring bad line starting with 'fb'
libkmod: ERROR ../libkmod/libkmod-config.c:686 kmod_config_parse: /etc/modprobe.d/fbdev-blacklist.conf line 6: ignoring bad line starting with 'fb'
libkmod: ERROR ../libkmod/libkmod-config.c:686 kmod_config_parse: /etc/modprobe.d/fbdev-blacklist.conf line 6: ignoring bad line starting with 'fb'
libkmod: ERROR ../libkmod/libkmod-config.c:686 kmod_config_parse: /etc/modprobe.d/fbdev-blacklist.conf line 6: ignoring bad line starting with 'fb'
                                         
Current status: 88 updates [-2].

===============================================================================================
I repeated the commands from post 1:

0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

For the longer commands:
http://tny.cz/fda559e8
===============================================================================================
Also, oddly enough my touchscreen started working, sort of. The cursor/left click works but nothing else.

Last edited by WheatThins (2014-03-25 03:13:10)

Offline

#8 2014-03-27 06:05:29

WheatThins
Member
From: Chicago
Registered: 2013-11-04
Posts: 41
Website

Re: Wireless Not Working

Do you have any ideas?  neutral

Offline

#9 2014-03-27 21:10:10

zazen23
#! Member
Registered: 2011-07-10
Posts: 72

Re: Wireless Not Working

Headers maybe the issue.Try a live boot of a recent LinuxBBQ respin to see if the wireless works.The only other thing to try is dump the wheezy backport repo and pkgs then apt pin the Kali Repos and try that kernel Kali repo how to do..The Kali APT pinning helped with a amd apu & realtek wireless firmware on my late model HP Pavilion Laptop.   wink

Offline

#10 2014-04-04 20:19:12

WheatThins
Member
From: Chicago
Registered: 2013-11-04
Posts: 41
Website

Re: Wireless Not Working

Well the respin of linux bbq I tried did have working wireless, though it didn't seem like much else worked.  yikes It seemed really weird, I couldn't even get a browser to launch. Something probably happened while I wrote it to usb.

Now I'm going to attempt to follow the other instructions you left me, will edit afterward.

==============================================================================
Output of sudo airmon-ng start wlan0


Interface    Chipset        Driver

wlan0        Unknown     rt2800pci - [phy0]SIOCSIFFLAGS: No such file or directory
==============================================================================
wheatthins@WheatThins:~$ dmesg | tail
[   23.451891] rt2800pci 0000:02:00.0: Direct firmware load failed with error -2
[   23.451896] rt2800pci 0000:02:00.0: Falling back to user helper
[   56.418971] type=1006 audit(1396713464.218:2): pid=2483 uid=0 old auid=4294967295 new auid=1000 old ses=4294967295 new ses=1 res=1
[   61.361598] fuse init (API version 7.22)
[  936.500814] ieee80211 phy0: rt2x00lib_request_firmware: Info - Loading firmware file 'rt3290.bin'
[  936.500842] rt2800pci 0000:02:00.0: firmware: failed to load rt3290.bin (-2)
[  936.500849] rt2800pci 0000:02:00.0: Direct firmware load failed with error -2
[  936.500853] rt2800pci 0000:02:00.0: Falling back to user helper
[ 1016.207492] r8169 0000:01:00.0 eth0: link up
[ 1016.207510] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
==============================================================================
Attempted this fix, no luck
https://bugs.launchpad.net/ubuntu/+sour … comments/8

Last edited by WheatThins (2014-04-05 21:32:32)

Offline

#11 2014-04-05 21:50:44

WheatThins
Member
From: Chicago
Registered: 2013-11-04
Posts: 41
Website

Re: Wireless Not Working

git clone git://git.kernel.org/pub/scm/linux/kernel/git/dwmw2/linux-firmware.git
sudo cp rt3290.bin /lib/firmware

Did the trick just fine! Thank you for your help!

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo