SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2014-02-01 11:41:06

luisroncero
Member
Registered: 2013-10-15
Posts: 16

[SOLVED] Dropbox at autostart displays "absent folder"

Hi everybody

I have Dropbox installed on Crunchbang 11 Waldorf and added to autostart.sh. Everytime that Openbox starts, I get a dropbox screen saying that my folder is absent. I have the Dropbox folder in a NTFS partition named "vajra"; it is not in the main linux partition due to its size. What I need to do to have Dropbox start normally is to open Thunar, click on the NTFS volume (vajra) and wait until it is mounted. I usually get this message the first time I click on it:

Fail to mount "vajra"
DBus error org.gtk.Private.RemoteVolumeMonitor.Failed: An operation is already pending

I click on Vajra again and then the folders display. Only then I can open Dropbox normally. My line for Dropbox in autostart is as follows. It is the last one of the list:

# Lanza el Dropbox
(sleep 5s && ~/.dropbox-dist/dropboxd) &

Any ideas will be appreciated.

Luis

Last edited by luisroncero (2014-02-05 19:37:28)

Offline

Be excellent to each other!

#2 2014-02-01 12:34:34

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 3,928

Re: [SOLVED] Dropbox at autostart displays "absent folder"

Have you tried increasing the wait time? My autostart has

# Autostart the Dropbox daemon
(sleep 20s && ~/.dropbox-dist/dropboxd) &

Artwork at deviantArt;  Iceweasel Personas;  SLiM #! Themes;  Openbox themes

Offline

#3 2014-02-03 08:12:27

luisroncero
Member
Registered: 2013-10-15
Posts: 16

Re: [SOLVED] Dropbox at autostart displays "absent folder"

I changed the wait time to 40 seconds but the problem persists It seems that the only way for my NTFS partition to be properly mounted is by opening a file explorer like Thunar. I do what I said in the first post: click on the NTFS label twice and wait until it is mounted correctly. Only then I can open Dropbox again and I can use it.

Is there any way to solve this?

Offline

#4 2014-02-03 12:47:44

VDP76
#! Bean Roaster
Registered: 2012-04-12
Posts: 838

Re: [SOLVED] Dropbox at autostart displays "absent folder"

have you added an entry for your partition in /etc/fstab!?
this might help...
https://wiki.debian.org/NTFS


#!#!#! Forum etiquette #!#!#!
Are you a new member!? Have you introduced yourself?!
CLI basics | LVM | smxi | chrooting | multiarch

Offline

#5 2014-02-04 14:14:55

luisroncero
Member
Registered: 2013-10-15
Posts: 16

Re: [SOLVED] Dropbox at autostart displays "absent folder"

have you added an entry for your partition in /etc/fstab!?
this might help...
https://wiki.debian.org/NTFS


Sorry, I do not know how to do that. I am an illiterate user. Besides, I do not have etc/fstab; my folder is called etc/fstab.d. Plus, there is nothing inside that folder. I would not know how to do it. I have read through the page that you provided but I still do not know what to do.

Offline

#6 2014-02-04 14:54:43

VDP76
#! Bean Roaster
Registered: 2012-04-12
Posts: 838

Re: [SOLVED] Dropbox at autostart displays "absent folder"

honestly I do not know what the /etc/fstab.d/ folder is used for, but you surely have an /etc/fstab file...let's see what it contains now, open a terminal window and type

cat /etc/fstab

then copy/paste the output here.

please, use the code tags so the output is more readable, see those helper above the text input box...


#!#!#! Forum etiquette #!#!#!
Are you a new member!? Have you introduced yourself?!
CLI basics | LVM | smxi | chrooting | multiarch

Offline

#7 2014-02-04 16:15:07

luisroncero
Member
Registered: 2013-10-15
Posts: 16

Re: [SOLVED] Dropbox at autostart displays "absent folder"

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda3 during installation
UUID=75d4a6bb-60e0-43c1-b07e-3e06d57257f5 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda4 during installation
UUID=ef6b11e8-3643-4520-9c39-e95c03b85434 none            swap    sw              0       0
/dev/sr0        /media/cdrom0   udf,iso9660 user,noauto     0       0
#/dev/sdb1       /media/usb0     auto    rw,user,noauto  0       0

Ok, now I understand. It seems that fstab is a file. This is the output. I have also used "code" as VDP76 advised.

Thanks in advance.

Offline

#8 2014-02-04 21:05:40

VDP76
#! Bean Roaster
Registered: 2012-04-12
Posts: 838

Re: [SOLVED] Dropbox at autostart displays "absent folder"

ok, now let's add your data partition to the fstab file, assuming to mount it to a folder named vajra.
open a terminal and type this commands

cd /media/
sudo mkdir vajra
sudo mount -t ntfs /dev/sdaX /media/vajra
sudo chown -R user:user /media/vajra

note: replace the X in sdaX with the appropriate number for the partition and user with your actual username.
at this point the partition is mounted and user owns the files contained in it, browse the folder with thunar or from terminal to check that then use

sudo blkid

to find out what is the UUID associated to your /dev/sdaX partition

sudo geany /etc/fstab

and add this line using the appropriate UUID (adapted from the Debian wiki)

UUID=111-222-333   /media/vajra    ntfs-3g    rw,uid=1000,gid=1000,dmask=0002,fmask=0003   0    0

save, close geany, reboot and you should be set.


#!#!#! Forum etiquette #!#!#!
Are you a new member!? Have you introduced yourself?!
CLI basics | LVM | smxi | chrooting | multiarch

Offline

#9 2014-02-05 19:36:35

luisroncero
Member
Registered: 2013-10-15
Posts: 16

Re: [SOLVED] Dropbox at autostart displays "absent folder"

That solved the problem. This community is amazing. Thanks so much for your help.

I am so glad to be using Crunchbang.

Offline

#10 2014-02-05 22:18:19

VDP76
#! Bean Roaster
Registered: 2012-04-12
Posts: 838

Re: [SOLVED] Dropbox at autostart displays "absent folder"

You're welcome, I am glad I could help!

Yep, this is a great community, many of us have come here for the distro but stayed for the forums... wink

Last edited by VDP76 (2014-02-05 22:18:32)


#!#!#! Forum etiquette #!#!#!
Are you a new member!? Have you introduced yourself?!
CLI basics | LVM | smxi | chrooting | multiarch

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo