SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#51 2013-12-02 02:17:31

BrightEyesDavid
New Member
Registered: 2013-12-02
Posts: 2

Re: Steam on #! Waldorf

BrightEyesDavid wrote:

The link to the Ubuntu Glibc in that install script seems to be out of date and no longer available, so I commented out the relevant lines and used this version instead, from here. I extracted the deb archive and copied all the files in the 'lib/i386-linux-gnu' directory into '~/.local/share/Steam/ubuntu12_32', and now I'm able to run steam. [...]?

I posted too soon. It turns out that though I could run Steam, I couldn't run any games and was still getting the missing GLIBC error.

I deleted everything and used GhostSquad57's Re-write of Valve's deb package, and everything just worked.

So to summarise installing Steam in Waldorf 64-bit (not considering GPU drivers which I expect I'll need to do next if the open source ATI driver, which I believe is installed by default in Waldorf(?), doesn't give good enough performance):

Add i386 repositories, update package list and install dependencies
sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install realpath libgl1-mesa-glx:i386 libgl1-mesa-dri:i386 libcurl3-gnutls:i386 libogg0:i386 libpixman-1-0:i386 libsdl1.2debian:i386 libtheora0:i386 libvorbis0a:i386 libvorbisenc2:i386 libvorbisfile3:i386 libasound2:i386 libc6:i386 libcairo2:i386 libcups2:i386 libdbus-1-3:i386 libfontconfig1:i386 libfreetype6:i386 libgcc1:i386 libgcrypt11:i386 libgdk-pixbuf2.0-0:i386 libglib2.0-0:i386 libgtk2.0-0:i386 libnspr4:i386 libnss3:i386 libopenal1:i386 libpango1.0-0:i386 libpng12-0:i386 libpulse0:i386 libstdc++6:i386 libx11-6:i386 libxext6:i386 libxfixes3:i386 libxi6:i386 libxrandr2:i386 libxrender1:i386 zlib1g:i386
Download and install Steam package
wget https://dl.dropboxusercontent.com/u/82856418/Steam-Installer-For-Wheezy/steam-debian_1.0.0.45-3_all.deb
sudo dpkg -i steam-debian_1.0.0.45-3_all.deb
Run Steam
steam-debian

Offline

Help fund CrunchBang, donate to the project!

#52 2013-12-16 20:52:47

MrAptronym
New Member
Registered: 2013-12-16
Posts: 3

Re: Steam on #! Waldorf

Hey all, I am a new user after many years away from anything linux, and I am pretty noobish. I installed steam on a fresh install of Waldorf on AMD64. I used the steps presented here and GhostSquad57's deb and it started up flawlessly. However, I was having issues actually getting 3D games to run so I installed my proprietary fglrx drivers. That too, worked without a hitch, (truly shocking me) but now steam is broken. When I attempt to run steam I now get:

Error: You are missing the following 32-bit libraries, and Steam may not run:
libGL.so.1
/home/username/.local/share/Steam/steam.sh: line 42:  4072 Segmentation fault      zenity "$style" --text="$*" 2> /dev/null

Steam will in fact even launch a graphical error box telling me "Fatal Error: Failed to load steamui.so" I am assuming that installing my proprietary 64bit drivers has made it so steam has no 32 bit drivers up to rely on. I don't mind experimenting a bit, but I am not too confident in my Linux abilities when it comes to working with drivers, so I figured I would come here to ask what my next steps should be. I would be happy to provide any additional info people may need, and many thanks in advance.

Offline

#53 2013-12-16 21:35:08

cloverskull
#! Junkie
Registered: 2013-10-26
Posts: 288

Re: Steam on #! Waldorf

Try

 sudo apt-get install lib<whatever>:i386 

See if that helps with Steam.  Steam relies on 32 bit libs.  smile

Offline

#54 2013-12-16 22:35:32

MrAptronym
New Member
Registered: 2013-12-16
Posts: 3

Re: Steam on #! Waldorf

cloverskull wrote:

Try

 sudo apt-get install lib<whatever>:i386 

See if that helps with Steam.  Steam relies on 32 bit libs.  smile

Okay, I installed the libgl1-fglrx-glx:i386 and now steam will run, but it warns me that direct rendering isn't enabled (It is, I checked glxinfo) and attempting to run any game either seg-faults (Metro Last Light), gives a gray screen but plays audio (Aquaria) or in half-life 2's case throws this Error: "Could not find required OpenGL entry point 'glGetError'! Either your video card is unsupported, or your OpenGL driver needs to be updated."

I tried creating a symbolic link between steam's bin folder and the required libraries as some suggested on other sites before I reinstalled, but that failed to work.

Offline

#55 2013-12-17 00:28:18

cloverskull
#! Junkie
Registered: 2013-10-26
Posts: 288

Re: Steam on #! Waldorf

Hmm...try uninstalling the amd64 glx libs and run it again.  Or, optionally you could launch steam with

LD_LIBRARY=/path/to/your/32/bit/libs steam

or something to that effect.

Offline

#56 2013-12-17 00:48:03

MrAptronym
New Member
Registered: 2013-12-16
Posts: 3

Re: Steam on #! Waldorf

cloverskull wrote:

Hmm...try uninstalling the amd64 glx libs and run it again.  Or, optionally you could launch steam with

LD_LIBRARY=/path/to/your/32/bit/libs steam

or something to that effect.

That worked like a dream, just loaded up HL2 and Metro to test it out. Many thanks for your help!

Offline

#57 2013-12-17 04:52:57

cloverskull
#! Junkie
Registered: 2013-10-26
Posts: 288

Re: Steam on #! Waldorf

Yep!  smile

Offline

#58 2014-01-02 17:47:34

BeeSneeze
New Member
Registered: 2014-01-02
Posts: 1

Re: Steam on #! Waldorf

I tried what you said and its not working. When I try to "unarch it" I get this.
"tar (child): gist4231563-45bbf171953630f9b11acec71b8cc6fa70f0abe0.tar.gz: Cannot open: No such file or directory
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error is not recoverable: exiting now"
What do I do? I didn't find a "what to do if this happens" section of your post.
Thanks in advance.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo