SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-11-18 06:28:59

HELPME
#! CrunchBanger
From: the holley land
Registered: 2013-11-15
Posts: 131
Website

[solved] I can hear clearly now the pain is gone

[nosound] how can I test my sound? my browser is ignoring my headphone

why dont I have a sound thingy in the top right corner? you know where the time and clipboard and networking stuffs located

that leads me to this which leads me to hda-intel if I am not mistaken
^ that first links last post says all of this was just a complete waste but I did what I did below this
everything is in the correct order I did things in but I was reading from everywhere all at the same time so it all probably looks kind of senseless
and did I mention that I dont know anything about what I am doing?

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC887-VD Digital [ALC887-VD Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
$ lspci -v
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02)
	Subsystem: Giga-byte Technology Device a002
	Flags: bus master, fast devsel, latency 0, IRQ 43
	Memory at fdff8000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: snd_hda_intel

for this second command I can see a lot of Capabilities: <access denied> for all of the other things -- I only put the sound related feedback
upon further revision I review that Kernel driver in use: snd_hda_intel of which greatly confuses me hmm

$  modinfo soundcore
filename:       /lib/modules/3.2.0-4-amd64/kernel/sound/soundcore.ko
alias:          char-major-14-*
license:        GPL
author:         Alan Cox
description:    Core sound module
depends:        
intree:         Y
vermagic:       3.2.0-4-amd64 SMP mod_unload modversions 
parm:           preclaim_oss:int
$ sudo modprobe snd-
FATAL: Module snd- not found.

yikes  FATAL!?!?!?!?

I went back to the alsamixer command and will show some screenprints
or maybe not
in the alsamixer I press F2 and get the following

/proc/asound/version ─────────────────┐
││Advanced Linux Sound Architecture Driver Version 1.0.24.

/proc/asound/cards ────────────────┐
││ 0 [Intel          ]: HDA-Intel - HDA Intel
││                      HDA Intel at 0xfdff8000 irq 43

/proc/asound/pcm ──────────────────────────┐
│00-00: ALC887-VD Analog : ALC887-VD Analog : playback 1 : capture 1
│00-01: ALC887-VD Digital : ALC887-VD Digital : playback 1 : capture 1
│00-02: ALC887-VD Analog : ALC887-VD Analog : capture 1 

F6 returns the following

┌───── Sound Card ──────┐
│-  (default)           │
│0  HDA Intel           │
│enter device name...   │
└───────────────────────┘ 

but when I attempt to select 0  HDA Intel it exits the alsamixer and I get cannot load mixer controls: Invalid argument

┌───────────────────────── AlsaMixer v1.0.25 ──────────────────────────┐
│ Card: PulseAudio                             F1:  Help               │
│ Chip: PulseAudio                             F2:  System information │
│ View: F3:[Playback] F4: Capture  F5: All     F6:  Select sound card  │
│ Item: Master                                 Esc: Exit               │
│                                                                      │
│                                 ┌──┐                                 │
│                                 │▒▒│                                 │
│                                 │▒▒│                                 │
│                                 │▒▒│                                 │
│                                 │▒▒│                                 │
│                                 │▒▒│                                 │
│                                 │▒▒│                                 │
│                                 │▒▒│                                 │
│                                 │▒▒│                                 │
│                                 │▒▒│                                 │
│                                 │▒▒│                                 │
│                                 │▒▒│                                 │
│                                 ├──┤                                 │
│                                 │OO│                                 │
│                                 └──┘                                 │
│                               100<>100                               │
│                              < Master >                              │
└──────────────────────────────────────────────────────────────────────┘

I feel that I should also mention that I set them all to max power and 00 mute

now I have found this

$ uname -r
3.2.0-4-amd64

$ lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02)

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC887-VD Digital [ALC887-VD Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

$ groups
helpme cdrom floppy sudo audio dip video plugdev fuse scanner bluetooth netdev cbnetwork

$ apt-cache search alsa-utils
alsa-utils - Utilities for configuring and using ALSA
gnome-alsamixer - ALSA sound mixer for GNOME

$ lsmod | grep snd
snd_hda_codec_realtek   188858  1 
snd_hda_intel          26259  0 
snd_hda_codec          78031  2 snd_hda_intel,snd_hda_codec_realtek
snd_hwdep              13186  1 snd_hda_codec
snd_pcm                68083  2 snd_hda_codec,snd_hda_intel
snd_page_alloc         13003  2 snd_pcm,snd_hda_intel
snd_seq                45126  0 
snd_seq_device         13176  1 snd_seq
snd_timer              22917  2 snd_seq,snd_pcm
snd                    52889  8 snd_timer,snd_seq_device,snd_seq,snd_pcm,snd_hwdep,snd_hda_codec,snd_hda_intel,snd_hda_codec_realtek
soundcore              13065  1 snd

$ cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfdff8000 irq 43

$ apt-cache policy alsa-utils
alsa-utils:
  Installed: 1.0.25-4
  Candidate: 1.0.25-4
  Version table:
 *** 1.0.25-4 0
        500 http://http.debian.net/debian/ wheezy/main amd64 Packages
        100 /var/lib/dpkg/status

$ amixer
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65536
  Mono:
  Front Left: Playback 65536 [100%] [on]
  Front Right: Playback 65536 [100%] [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch cswitch-joined penum
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 65536
  Front Left: Capture 65536 [100%] [on]
  Front Right: Capture 65536 [100%] [on]

$ sudo modprobe snd-hda-intel
$

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC887-VD Digital [ALC887-VD Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

$ alsamixer
{this just opens up the alsamixer}

now I am here

$ lspci | grep Audio
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02)

$ cat ~/.asoundrc
cat: /home/helpme/.asoundrc: No such file or directory

I couldnt continue with post #5 because I dont know if it applies to me or if I must replace some informations with my own systems stuff

this is where I am now

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC887-VD Digital [ALC887-VD Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

$ cat /proc/asound/card0/codec#* | grep Codec
Codec: Realtek ALC887-VD

nothing gives me any sense sad I am now lost and dazzled by the incompetence of my own thinking processes
I should also mention that I do not need or require sound but that it would ultimately be convenient for me to have it with my #!

my browser just crashed but luckily I didnt follow the all of the browser settings part of The paranoid #! Security Guide all of the way or I could have lost all of this whatever I write I will never write again

Last edited by HELPME (2013-11-18 22:36:01)

Offline

Help fund CrunchBang, donate to the project!

#2 2013-11-18 11:19:36

machinebacon
#! unstable
From: China
Registered: 2009-07-02
Posts: 6,619
Website

Re: [solved] I can hear clearly now the pain is gone

Hi,
my usual sound test is:

#!/bin/bash
clear
echo "Your audio device is:"
lspci | grep Audio
echo

echo "Plug in your speakers and headphones, they will be tested."
echo
read -p "Press any key to continue... " -n1 -s
#aplay -l
echo
echo "Restarting ALSA...."
sudo alsactl init
sleep 5s
echo
echo "Opening alsamixer - please adjust the volume levels using
the cursor (arrow) keys. If you see 'M' under the mixer it means 
that the channel is muted. Unmute the channel using the 'm' key. 
When finished press [Esc]"
echo
read -p "Press any key to continue... " -n1 -s
alsamixer
clear
echo "Testing default jack on four channels, twice."
echo
speaker-test -t wav -c 2 -l 2
sudo alsactl store
echo
echo "ALSA driver setup stored and all tests finished."
sleep 3s 
exit 0

save this file as ~/fixsound.sh
then

chmod +x ~/fixsound.sh

then

./fixsound.sh

As for the sound not working - try this:
http://crunchbang.org/forums/viewtopic. … 97#p344997

Last edited by machinebacon (2013-11-18 11:20:32)

Offline

#3 2013-11-18 12:30:48

HELPME
#! CrunchBanger
From: the holley land
Registered: 2013-11-15
Posts: 131
Website

Re: [solved] I can hear clearly now the pain is gone

thanks very much for your wisdom but it didnt work for me unfortunately
I know my headphones work because they just do when I use ubuntu and windows xp and I have my jacks lead plugged into the same socket for both of them
below is my failures

$ ./fixsound.sh

Your audio device is:
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02)

Plug in your speakers and headphones, they will be tested.

Press any key to continue... 
Restarting ALSA....
[sudo] password for helpme: 
Found hardware: "HDA-Intel" "Realtek ALC887-VD" "HDA:10ec0887,1458a002,00100302" "0x1458" "0xa002"
Hardware is initialized using a generic method
/usr/share/alsa/init/default:26: control element not found
/usr/share/alsa/init/default:26: control element not found
/usr/share/alsa/init/default:48: control element not found

Opening alsamixer - please adjust the volume levels using
the cursor (arrow) keys. If you see 'M' under the mixer it means 
that the channel is muted. Unmute the channel using the 'm' key. 
When finished press [Esc]

Press any key to continue... 



Testing default jack on four channels, twice.


speaker-test 1.0.25

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 96 to 1048576
Period size range from 32 to 349526
Using max buffer size 1048576
Periods = 4
was set period_size = 262144
was set buffer_size = 1048576
 0 - Front Left
 1 - Front Right
Time per period = 3.873204
 0 - Front Left
 1 - Front Right
Time per period = 3.536549
alsactl: get_control:250: Cannot read control info '2,0,0,Front Playback Volume,0': Invalid argument

ALSA driver setup stored and all tests finished.

I guess my sound failed so I will consult at your link

$ sudo geany /etc/modprobe.d/alsa-base.conf

(geany:9169): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Failed to create file '/root/.local/share/recently-used.xbel.3OCD6W': No such file or directory

(geany:9169): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: No such file or directory

(geany:9169): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Failed to create file '/root/.local/share/recently-used.xbel.IO5F6W': No such file or directory

(geany:9169): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: No such file or directory

then I try the test again

$ ./fixsound.sh

Your audio device is:
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02)

Plug in your speakers and headphones, they will be tested.

Press any key to continue... 
Restarting ALSA....
Found hardware: "HDA-Intel" "Realtek ALC887-VD" "HDA:10ec0887,1458a002,00100302" "0x1458" "0xa002"
Hardware is initialized using a generic method
/usr/share/alsa/init/default:26: control element not found
/usr/share/alsa/init/default:26: control element not found
/usr/share/alsa/init/default:48: control element not found

Opening alsamixer - please adjust the volume levels using
the cursor (arrow) keys. If you see 'M' under the mixer it means 
that the channel is muted. Unmute the channel using the 'm' key. 
When finished press [Esc]

Press any key to continue... 




Testing default jack on four channels, twice.


speaker-test 1.0.25

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 96 to 1048576
Period size range from 32 to 349526
Using max buffer size 1048576
Periods = 4
was set period_size = 262144
was set buffer_size = 1048576
 0 - Front Left
 1 - Front Right
Time per period = 3.867103
 0 - Front Left
 1 - Front Right
Time per period = 3.533628
alsactl: get_control:250: Cannot read control info '2,0,0,Front Playback Volume,0': Invalid argument

ALSA driver setup stored and all tests finished.

now I will try again with nano because that didnt work for me either

$ sudo nano /etc/modprobe.d/alsa-base.conf

but they are already commented out this time
I saw afterwards while putting them into here that when I used geany instead there was errors
I dont know how I can exit this so I just close the window with my mouse but it feels like the wrong thing to do since I learned about the exit command

I have just realized I should have restarted my pc

$ ./fixsound.sh

Your audio device is:
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02)

Plug in your speakers and headphones, they will be tested.

Press any key to continue... 
Restarting ALSA....
[sudo] password for helpme: 
Sorry, try again.
[sudo] password for helpme: 
Sorry, try again.
[sudo] password for helpme: 
Found hardware: "HDA-Intel" "Realtek ALC887-VD" "HDA:10ec0887,1458a002,00100302" "0x1458" "0xa002"
Hardware is initialized using a generic method
/usr/share/alsa/init/default:26: control element not found
/usr/share/alsa/init/default:26: control element not found
/usr/share/alsa/init/default:48: control element not found

Opening alsamixer - please adjust the volume levels using
the cursor (arrow) keys. If you see 'M' under the mixer it means 
that the channel is muted. Unmute the channel using the 'm' key. 
When finished press [Esc]

Press any key to continue... 
Testing default jack on four channels, twice.


speaker-test 1.0.25

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 96 to 1048576
Period size range from 32 to 349526
Using max buffer size 1048576
Periods = 4
was set period_size = 262144
was set buffer_size = 1048576
 0 - Front Left
 1 - Front Right
Time per period = 3.858864
 0 - Front Left
 1 - Front Right
Time per period = 3.529960
alsactl: get_control:250: Cannot read control info '2,0,0,Front Playback Volume,0': Invalid argument

ALSA driver setup stored and all tests finished.

alas it didnt resolve or I just cant hear anything sad
and now is the time that I realize listening super intently with my headphones plus max volume maybe isnt such a brite idea so maybe the universe is looking out for me like that?

Last edited by HELPME (2013-11-18 12:31:36)

Offline

#4 2013-11-18 12:43:50

machinebacon
#! unstable
From: China
Registered: 2009-07-02
Posts: 6,619
Website

Re: [solved] I can hear clearly now the pain is gone

Hi again,

try this too:

sudo nano /etc/modprobe.d/alsa-base.conf

add this line if it doesn't exist yet:

options snd-hda-intel model=generic

save (ctrl-o Enter) and exit (ctrl-x Enter)
then reboot and run ./fixsound again or play a sound file of your choice and adjust with alsamixer.

If it still doesn't rock, replace the expression "generic" with "auto" in the file.
And if it still doesn't work, please answer a few questions:
0) have you updated and upgraded the system?
1) have you maybe created an ~/.asoundrc file (if yes, please post it, if no, just ignore)
2) what is the output of

apt-cache policy alsa-utils alsa-base

Last edited by machinebacon (2013-11-18 12:46:37)

Offline

#5 2013-11-18 18:29:54

HELPME
#! CrunchBanger
From: the holley land
Registered: 2013-11-15
Posts: 131
Website

Re: [solved] I can hear clearly now the pain is gone

you are sound itself -- but I still cant hear anything lol

thanks unbelievably  for taking the time to help me get this working I extravagantly appreciate it
bellow is everything that happened as it happened and when it happened so you can bask in the glory of my success

okay so I editing it but all of the other options have index=-2 inplace of model=generic
but I added it how you said to and I added it after everything else because you didnt specify so I assumate it
thanks for the nano controls  big_smile

now rebooting

trying not to get my hopes up too high but after running the $ ./fixsound.sh and then when it open the alsamixer I press F6 to test changing the sound card and it works  big_smile but unfortunately my "m" is broken or I cant mute  hmm but I never mute anywayso its just confused me thats all tongue

┌───────────────────────────── AlsaMixer v1.0.25 ──────────────────────────────┐
│ Card: HDA Intel                                      F1:  Help               │
│ Chip: Realtek ID 887                                 F2:  System information │
│ View: F3:[Playback] F4: Capture  F5: All             F6:  Select sound card  │
│ Item: Master [dB gain: 0.00, 0.00]                   Esc: Exit               │
│                                                                              │
│                                                                              │
│                                ┌──┐     ┌──┐                                 │
│                                │▒▒│     │▒▒│                                 │
│                                │▒▒│     │▒▒│                                 │
│                                │▒▒│     │▒▒│                                 │
│                                │▒▒│     │▒▒│                                 │
│                                │▒▒│     │▒▒│                                 │
│                                │▒▒│     │▒▒│                                 │
│                                │▒▒│     │▒▒│                                 │
│                                │▒▒│     │▒▒│                                 │
│                                │▒▒│     │▒▒│                                 │
│                                │▒▒│     │▒▒│                                 │
│                                │▒▒│     │▒▒│                                 │
│                                │▒▒│     │▒▒│                                 │
│                                └──┘     └──┘                                 │
│                              100<>100 100<>100                               │
│                             < Master >  PCM                                  │
│                                                                              │
└──────────────────────────────────────────────────────────────────────────────┘

okay here goes my big test and I am so psyched right now  smileneutralsadbig_smileyikeswinkhmmtonguelolmadrollcool angel cry devil glasses kiss monkey ops
I am procrastinating just incase the world ends and I cant hear what it sounds like just because of this insignificant moment of complete and utter failure

yikes  that was AMAZING and it quite literally blew my ears away! big_smile

now this makes #! the only system I will ever need if I can get graphics to work although I have seen youtube videos playing already and that was when I realised that I had no sound but that was flash/canvas so I am hoping vlc can play my videoes and maybe some linux games can play also if I ever get time for it but I think learning about how to make my conky/lua and tint2 and everything else is going to keep me being pretty busy throughout quite a few kabillion versions of #! until I can find my niche monkey

I have just noticed that I now have a speaker sitting quite comfortably among my right-corner stuff like time and clipboard and networking so that makes changing volume much more accessible than the alsamixer everytime smile

I guess that what it is like for deaf/blind people who are handicapped although they must tolerate it for their whole life whereas I only had to endure it for a day
imagine if we could help them see/hear its like its like the world became renewed again and everything is experienced like it never was before -- except in my case
I got pretty sick of watching silent youtube videoes but thankfully there are some interesting ones I found for deaf people where they use subtitles instead of sign language which I fail to comprehend how it matches with the annotations and I just ended up generally confused entirely by the facial expressions which also didnt add up for anything else going on in the frame at the time  neutral they just looked genuinely content with being in front of a camera

Last edited by HELPME (2013-11-18 18:37:59)

Offline

#6 2014-05-28 23:22:27

linuxreign
#! CrunchBanger
From: Panama
Registered: 2011-09-05
Posts: 178

Re: [solved] I can hear clearly now the pain is gone

I had the very same problem and following everything posted here my problem is now solved

Thank you so much


Linux Registered User 445731

Offline

#7 2014-05-29 08:53:20

josephg
#! Member
From: Surrey
Registered: 2011-10-24
Posts: 79
Website

Re: [solved] I can hear clearly now the pain is gone

i think some of your problems could be traced to this below. are you logged in as "root"? if not, why does it look like your $HOME is /root??

HELPME wrote:

I guess my sound failed so I will consult at your link

$ sudo geany /etc/modprobe.d/alsa-base.conf

(geany:9169): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Failed to create file '/root/.local/share/recently-used.xbel.3OCD6W': No such file or directory

(geany:9169): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: No such file or directory

(geany:9169): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Failed to create file '/root/.local/share/recently-used.xbel.IO5F6W': No such file or directory

(geany:9169): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: No such file or directory

leaner code is cleaner code is more efficient code

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo