SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-10-28 00:03:45

philthy
Member
Registered: 2009-10-21
Posts: 22

[SOLVED] How can I stop the wireless hardware button from blinking?

Hello. I am running the latest #! on a HP Compaq 6510b. When I am connected to a wireless network the hardware wireless button continues to blink. I would like to have it lit solidly without blinking. What settings do I change to do that? Thanks.

Last edited by philthy (2013-11-06 20:35:55)

Offline

Help fund CrunchBang, donate to the project!

#2 2013-10-28 04:41:10

benginm
#! Junkie
From: Underneath!
Registered: 2012-11-11
Posts: 488

Re: [SOLVED] How can I stop the wireless hardware button from blinking?

that depends on your wireless driver and  its dependencies if it offers parameter for LED behavior! 

what is your wireless adapter , and kernel driver in use ! :

# lspci -nn | grep 0280

Offline

#3 2013-10-28 04:52:34

machinebacon
#! unstable
From: China
Registered: 2009-07-02
Posts: 6,634
Website

Re: [SOLVED] How can I stop the wireless hardware button from blinking?

http://www.linuxbbq.org/bbs/viewtopic.p … 313#p11313
this and the follow up posts might help.

Offline

#4 2013-10-28 10:34:12

wizard10000
#! Member
Registered: 2013-02-24
Posts: 80

Re: [SOLVED] How can I stop the wireless hardware button from blinking?

Yeah, Intel considers this a feature but it irritates the crap out of me as well.

Here is the contents of my /etc/modprobe.d/iwlwifi.conf -

options iwlwifi led_mode=1

we see things not as they are, but as we are.
  -- anais nin

Offline

#5 2013-10-29 00:49:41

philthy
Member
Registered: 2009-10-21
Posts: 22

Re: [SOLVED] How can I stop the wireless hardware button from blinking?

Here is the output from my lspci

10:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection [8086:4229] (rev 61)

I looked in the following directory /etc/modprobe.d/ and I don't have either a iwlwifi.conf or wlan.conf file. Does that mean there is something wrong?

Offline

#6 2013-10-29 06:19:28

benginm
#! Junkie
From: Underneath!
Registered: 2012-11-11
Posts: 488

Re: [SOLVED] How can I stop the wireless hardware button from blinking?

philthy wrote:

Here is the output from my lspci

10:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection [8086:4229] (rev 61)

I looked in the following directory /etc/modprobe.d/ and I don't have either a iwlwifi.conf or wlan.conf file. Does that mean there is something wrong?

nothing wrong !

run:
modinfo iwl4965

modinfo iwlegacy

;/

Offline

#7 2013-10-29 08:47:08

wizard10000
#! Member
Registered: 2013-02-24
Posts: 80

Re: [SOLVED] How can I stop the wireless hardware button from blinking?

philthy wrote:

...I looked in the following directory /etc/modprobe.d/ and I don't have either a iwlwifi.conf or wlan.conf file. Does that mean there is something wrong?

Nothing wrong, you have to create the file as it doesn't come with the driver package.  Filename isn't important as long as it's in /etc/modprobe.d and ends in .conf

You could even call it makethedamnwirelesslightstopblinking.conf if you wanted to  smile


we see things not as they are, but as we are.
  -- anais nin

Offline

#8 2013-10-31 17:48:18

philthy
Member
Registered: 2009-10-21
Posts: 22

Re: [SOLVED] How can I stop the wireless hardware button from blinking?

So I've created a file called wlan.conf in /etc/modprobe.d. The permissions on the file are 644. I've put the following in the file.

options iwlegacy led_mode=1
options iwlwifi led_mode=1
options ipw2200 led=1

I've tried changing the number from 1 to 0 and running modprobe -r iwlwifi && modprobe iwlwifi but I still have no luck getting it to work. Is there anything I'm missing?

Offline

#9 2013-10-31 18:24:48

benginm
#! Junkie
From: Underneath!
Registered: 2012-11-11
Posts: 488

Re: [SOLVED] How can I stop the wireless hardware button from blinking?

Yeah, you haven't run modinfo!  , and the reason why! because that should tell us the driver dependencies , and if it has LED function support , and your module/driver belongs to the 'iwlegacy' and your kernel module/driver is iwl4965 , not iwlwifi !

if you still want to keep going, then run:
modinfo iwl4965

modinfo iwlegacy

;/

Offline

#10 2013-11-03 21:38:10

philthy
Member
Registered: 2009-10-21
Posts: 22

Re: [SOLVED] How can I stop the wireless hardware button from blinking?

Here is the following when I run modinfo iwl4965

filename:       /lib/modules/3.2.0-4-686-pae/kernel/drivers/net/wireless/iwlegacy/iwl4965.ko
firmware:       iwlwifi-4965-2.ucode
alias:          iwl4965
license:        GPL
author:         Copyright(c) 2003-2011 Intel Corporation <ilw@linux.intel.com>
version:        in-tree:
description:    Intel(R) Wireless WiFi 4965 driver for Linux
srcversion:     57713622A8E7F662803C701
alias:          pci:v00008086d00004230sv*sd*bc*sc*i*
alias:          pci:v00008086d00004229sv*sd*bc*sc*i*
depends:        iwl-legacy,cfg80211,mac80211
intree:         Y
vermagic:       3.2.0-4-686-pae SMP mod_unload modversions 686 
parm:           swcrypto:using crypto in software (default 0 [hardware]) (int)
parm:           queues_num:number of hw queues. (int)
parm:           11n_disable:disable 11n functionality (int)
parm:           amsdu_size_8K:enable 8K amsdu size (int)
parm:           fw_restart:restart firmware in case of error (int)

I get "ERROR: Module iwlegacy not found" when I run modinfo iwlegacy.

Last edited by philthy (2013-11-03 21:39:05)

Offline

#11 2013-11-03 23:17:26

benginm
#! Junkie
From: Underneath!
Registered: 2012-11-11
Posts: 488

Re: [SOLVED] How can I stop the wireless hardware button from blinking?

depends:        iwl-legacy,cfg80211,mac80211

so , how about :

$ modinfo iwl-legacy

$ lsmod | grep iwl

Offline

#12 2013-11-03 23:30:00

benginm
#! Junkie
From: Underneath!
Registered: 2012-11-11
Posts: 488

Re: [SOLVED] How can I stop the wireless hardware button from blinking?

if iwl4965 depends is actually " iwl-legacy " as stated in modinfo!  then i presume you could try :

sudo nano /etc/modprobe.d/iwlegacy.conf

# Add only the line:

options iwl-legacy led_mode=1

Ctrl+X , Y , hit enter , then you may try it immediately:


$ sudo modprobe -r iwl4965
$ sudo modprobe iwl-legacy led_mode=1
$ sudo modprobe iwl4965

Offline

#13 2013-11-06 20:35:38

philthy
Member
Registered: 2009-10-21
Posts: 22

Re: [SOLVED] How can I stop the wireless hardware button from blinking?

Thank you sir. That worked. I appreciate the help.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo