SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-08-29 11:07:08

hebangs
#! CrunchBanger
Registered: 2013-06-05
Posts: 107

[SOLVED] Help - I screwed up my terminal config.

hi guys, how do iget back the default crunchbang styling on terminator? ive reverted to the original config but still it wont change.

my screwed up terminator

my current terminator config as found in ~/.config/terminator/config

[global_config]
  window_state = maximise
  title_inactive_bg_color = "#000000"
  title_transmit_bg_color = "#000000"
  borderless = True
[keybindings]
  hide_window = <Shift><Control>a
[profiles]
  [[default]]
    scrollbar_position = hidden
    palette = "#000000:#cc0000:#4e9a06:#c4a000:#3465a4:#75507b:#06989a:#d3d7cf:#555753:#ef2929:#8ae234:#fce94f:#729fcf:#ad7fa8$
    background_darkness = 0.83
    scrollback_lines = 5000
    background_type = transparent
    use_system_font = False
    cursor_color = "#d8d8d8"
    foreground_color = "#d8d8d8"
    scroll_on_output = False
    show_titlebar = False
    color_scheme = custom
    font = Monospace 10
    background_color = "#2e3436"
    scrollback_infinite = True
[layouts]
  [[default]]
    [[[child1]]]
      type = Terminal
      parent = window0
      profile = default
    [[[window0]]]
      type = Window
      parent = ""
[plugins]

Last edited by hebangs (2013-08-29 15:35:42)

Offline

Be excellent to each other!

#2 2013-08-29 11:19:48

bleach
#! Member
Registered: 2013-08-09
Posts: 98

Re: [SOLVED] Help - I screwed up my terminal config.

you can change it via the right clicker it is automatically created so editing it has issues if you re-edite it via the gui(it will be overwriten). I have yet to find an option that can not be edited in the gui so it is quit complete in its own.

as for you question delete the config and it will create the defaults.


obstacles are only in your mind. how you deal with them is what "matters".

Offline

#3 2013-08-29 11:22:18

pvsage
Internal Affairs
From: North Carolina
Registered: 2009-10-18
Posts: 12,289

Re: [SOLVED] Help - I screwed up my terminal config.

One thing that stands out to me is that mine doesn't have the "profile = default" stanza.


I'm a moderator here.  How are we doing?  Feedback is encouraged.

Offline

#4 2013-08-29 14:08:22

hebangs
#! CrunchBanger
Registered: 2013-06-05
Posts: 107

Re: [SOLVED] Help - I screwed up my terminal config.

ive deleted the config hoping it'll revert back to the old one but no luck. that red bar is still there.

Offline

#5 2013-08-29 14:10:00

Sector11
77345 ¡#
From: SR11 Cockpit
Registered: 2010-05-05
Posts: 11,703
Website

Re: [SOLVED] Help - I screwed up my terminal config.

@ hebangs

Just a thought ...

Maybe change this:

[layouts]
  [[default]]
    [[[child1]]]
      type = Terminal
      parent = window0
      profile = default
    [[[window0]]]
      type = Window
      parent = ""
[plugins]

to:

[layouts]
  [[default]]
    [[[child1]]]
      type = Terminal
      parent = window0
    [[[window0]]]
      type = Window
      parent = ""
[plugins]

I dont think that "      profile = default" is needed in there, like mine:

[global_config]
  enabled_plugins = LaunchpadCodeURLHandler, APTURLHandler, LaunchpadBugURLHandler
  title_transmit_bg_color = "#000000"
  handle_size = 1
  title_inactive_bg_color = "#000000"
[keybindings]
  hide_window = <Shift><Control>a
[profiles]
  [[default]]
    scrollbar_position = hidden
    palette = "#073642:#dc322f:#859900:#b58900:#268bd2:#d33682:#2aa198:#eee8d5:#002b36:#cb4b16:#586e75:#657b83:#839496:#6c71c4:#93a1a1:#fdf6e3"
    background_image = None
    background_darkness = 0.8
    scrollback_lines = 5000
    background_type = transparent
    use_system_font = False
    cursor_color = "#d8d8d8"
    scroll_background = False
    scroll_on_output = False
    show_titlebar = False
    color_scheme = custom
    font = monofur Bold 11
    background_color = "#252627"
    foreground_color = "#d8d8d8"
    scrollback_infinite = True
[layouts]
  [[default]]
    [[[child1]]]
      type = Terminal
      parent = window0
    [[[window0]]]
      type = Window
      parent = ""
[plugins]

It's already set up as the default.

Now saying that I cheat in OpenBox my terminator command is:

terminator --geometry=950x600+500+25 -b

2013_08_29_11_04_38_1920x1080_Sector11.jpg

or a fullscreen terminal:

terminator -mb

2013_08_29_11_08_33_1920x1080_Sector11.jpg

EDIT:  Adding:

terminator(1) - Linux man page and terminator_config(5) - Linux man page

It's an awesome Linux link: Linux Documentation

Last edited by Sector11 (2013-08-29 14:48:45)


#! Forum Moderator | To #! or not to #!?  That is the question!
#! Conky = 16 Threads & the Conky Archives | Conky PitStop | OHCG'er
StartPage -  protect your privacy   |   BBQLinux

Offline

#6 2013-08-29 14:47:42

lowrider
#! Die Hard
From: Germany
Registered: 2011-09-10
Posts: 640

Re: [SOLVED] Help - I screwed up my terminal config.

In /etc/skel/.config/teminator/ you find the original #! config. Just copy it...

/etc/skel in general is the No.1 resource for stock config files in #!


came for the distro, stayed for the community
streamripper :: smxi

Offline

#7 2013-08-29 14:58:19

thunk
Member
From: hereabouts
Registered: 2011-10-15
Posts: 39

Re: [SOLVED] Help - I screwed up my terminal config.

How about
Preferences > Profiles > General > Untick "Show Titlebar"?

Offline

#8 2013-08-29 15:28:37

hebangs
#! CrunchBanger
Registered: 2013-06-05
Posts: 107

Re: [SOLVED] Help - I screwed up my terminal config.

lowrider wrote:

In /etc/skel/.config/teminator/ you find the original #! config. Just copy it...

/etc/skel in general is the No.1 resource for stock config files in #!

it works like a charm smile
thanks guys for helping the noob in me angel

Last edited by hebangs (2013-08-29 15:31:41)

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo