SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-08-22 03:19:29

rml
#! Member
Registered: 2012-02-10
Posts: 52

[SOLVED] path to external hard drives changed

i just tried to play an m3u file that i had created very recently.  it used to work.  this time when i tried to play it it couldn't find any of the files.  i knew the files were still on those external hard drives, so i checked the path, and it's different than it used to be!

what used to be

/media/seagate/d/Dusty Springfield

is now

/media/ryan/seagate/d/Dusty Springfield

same with my other external drive.  what was once /media/maxtor/... is now /media/ryan/maxtor

why did that happen and how can i change it back so that i don't have to edit all the playlists i've created?

ryan is my user name

/home/ryan is my home folder

thank you!

Last edited by rml (2013-08-25 05:35:16)

Offline

Be excellent to each other!

#2 2013-08-22 04:15:44

jmad2011
#! Junkie
From: newton falls ohio
Registered: 2011-12-25
Posts: 333

Re: [SOLVED] path to external hard drives changed

you could always make the dir then just mount the drive there


mkdir  /media/seagate/   

 

then

 sudo mount /dev/sdX  /media/seagate

Say your prayer's,Eat your vitamins....AND WHAT YOU GONNA DO BROTHA

Offline

#3 2013-08-22 04:35:53

rml
#! Member
Registered: 2012-02-10
Posts: 52

Re: [SOLVED] path to external hard drives changed

thanks.  is that something i would have to set up to do every boot?  what about when i don't have them plugged in when i boot but plug them in later?

Offline

#4 2013-08-22 05:25:30

jmad2011
#! Junkie
From: newton falls ohio
Registered: 2011-12-25
Posts: 333

Re: [SOLVED] path to external hard drives changed

just run the mount /dev/sdX  /media/segate when you plug it in


Say your prayer's,Eat your vitamins....AND WHAT YOU GONNA DO BROTHA

Offline

#5 2013-08-22 07:16:33

lwfitz
#! Die Hard
From: Monrovia, CA
Registered: 2012-01-19
Posts: 886
Website

Re: [SOLVED] path to external hard drives changed

Plug your external into the computer

Install disk manager

sudo apt-get install disk-manager

Once installed run

sudo disk-manager

Disk Manager will look something like this

screenshot-08222013-120352am.png

Check the box associated with your external. If your drive is formated as ntfs you will need to click on edit and tell disk manager to use the ntfs-3g driver for read/write ability.

Once disk manager has added the drive open a terminal and run

sudo geany /etc/fstab

and edit fstab to mount your external using UUID. Save fstab and now when you reboot the drive will mount just fine.

To get the drives UUID open a terminal and run

blkid

Find the correct drive and the corresponding UUID

Go back to your fstab and edit by replacing the correct /dev/xxxx with the correct UUID.

For example mine looks like this

blkid

luke@VSIDO-FX:~$ blkid
/dev/sda1: UUID="29f9269d-8d3e-4e13-b082-2b0f6916981c" TYPE="ext4" 
/dev/sdb1: UUID="1789D9923188F40F" TYPE="ntfs" 
/dev/sdc1: LABEL="storage" UUID="0D78843743DFACE1" TYPE="ntfs" 
/dev/sdd1: UUID="50D6CAF5D6CADA7C" TYPE="ntfs" 
/dev/sdb2: LABEL="Backup" UUID="51B128766AD22A13" TYPE="ntfs" 
/dev/sdd2: UUID="9c6bd694-a8c0-4d7d-9c0a-b9cba0a3b654" TYPE="ext4" 
/dev/sda3: UUID="f5a327b3-8ffb-48e8-9cf3-5cdb66b73d10" TYPE="swap" 
/dev/sde1: UUID="188B5F0207AF0B69" TYPE="ntfs" 

/etc/fstab

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc	/proc	proc	defaults	0	0
#Entry for /dev/sdd2 :
UUID=9c6bd694-a8c0-4d7d-9c0a-b9cba0a3b654	/	ext4	defaults,relatime,errors=remount-ro,data=ordered	0	0
#Entry for /dev/sde1 :
UUID=188B5F0207AF0B69	/media/sdf1	ntfs-3g	defaults,locale=en_US.UTF-8	0	0
#Entry for /dev/sdd1 :
UUID=50D6CAF5D6CADA7C	/media/sdb1	ntfs-3g	defaults,locale=en_US.UTF-8	0	0
#Entry for /dev/sdc1 :
UUID=0D78843743DFACE1	/media/storage	ntfs-3g	defaults,locale=en_US.UTF-8	0	0
#Entry for /dev/sdb2 :
UUID=51B128766AD22A13	/media/Backup	ntfs-3g	defaults,locale=en_US.UTF-8	0	0
#Entry for /dev/sda1 :
UUID=29f9269d-8d3e-4e13-b082-2b0f6916981c	/home	ext4	defaults	0	0
#Entry for /dev/sda3 :
UUID=f5a327b3-8ffb-48e8-9cf3-5cdb66b73d10	none	swap	sw	0	0
/dev/cdrom	/media/cdrom	udf,iso9660	user,noauto,exec,utf8	0	0

Although the /dev/xxxx association may change the UUID stays the same so when you mount using UUID it will mount in the same place all the time.
Note that if you boot up without the external plugged in you will get an error because the drive isnt there to mount. Its not a big deal.

Hope this helps

Last edited by lwfitz (2013-08-22 07:19:42)

Offline

#6 2013-08-22 12:31:04

rml
#! Member
Registered: 2012-02-10
Posts: 52

Re: [SOLVED] path to external hard drives changed

okay, thank you.   does anybody have any idea why this changed in the first place?

Offline

#7 2013-08-22 14:49:32

lowrider
#! Die Hard
From: Germany
Registered: 2011-09-10
Posts: 581

Re: [SOLVED] path to external hard drives changed

as a short fix you can symlink /media/seagate to /media/ryan/seagate and do the same with your other devices.
this should make your m3u files work again.


came for the distro, stayed for the community
streamripper :: smxi

Offline

#8 2013-08-23 14:48:25

rml
#! Member
Registered: 2012-02-10
Posts: 52

Re: [SOLVED] path to external hard drives changed

thanks everybody.  does anybody know why this happened in the first place?

Offline

#9 2013-08-23 16:25:12

lwfitz
#! Die Hard
From: Monrovia, CA
Registered: 2012-01-19
Posts: 886
Website

Re: [SOLVED] path to external hard drives changed

^ Your welcome. Thats a really good question and Im not totally sure  hmm

Offline

#10 2013-08-23 20:21:50

arclance
#! Die Hard
Registered: 2012-03-29
Posts: 861

Re: [SOLVED] path to external hard drives changed

^ That is the behavior of udisks2 as patched by Debian (unpatched is /run/media/username).
Updates to gnome related packages have started to pull that in.

Offline

#11 2013-08-23 20:43:47

lwfitz
#! Die Hard
From: Monrovia, CA
Registered: 2012-01-19
Posts: 886
Website

Re: [SOLVED] path to external hard drives changed

Right on, thanks for the explanation arclance.

Offline

#12 2013-08-23 21:08:08

lowrider
#! Die Hard
From: Germany
Registered: 2011-09-10
Posts: 581

Re: [SOLVED] path to external hard drives changed

so it is related to udisk2 right? i noticed this behavior when i dist-upgrade my sid #!. well, no biggie for me. other distros goes the same way nowadays. thx for the clearance...

Last edited by lowrider (2013-08-23 21:09:47)


came for the distro, stayed for the community
streamripper :: smxi

Offline

#13 2013-08-25 01:39:06

rml
#! Member
Registered: 2012-02-10
Posts: 52

Re: [SOLVED] path to external hard drives changed

arclance wrote:

^ That is the behavior of udisks2 as patched by Debian (unpatched is /run/media/username).
Updates to gnome related packages have started to pull that in.

but it used to mount to /media/seagate, not /run/media/ryan/seagate.

Offline

#14 2013-08-25 01:51:11

arclance
#! Die Hard
Registered: 2012-03-29
Posts: 861

Re: [SOLVED] path to external hard drives changed

^ udisks (udisks1) is from gnome2 and mounted in "/media/Label".

udisks2 is from gnome3 and if built without modifying the source it mounts in "/run/media/user/Label"
Debian and Ubuntu use this patch to make udisks2 mount in "/media/user/Label" instead.
This is the reason given by Fedora for the change.

Removable media mounted in the user's session, such as hot-plugged USB drives, will be mounted in a user-specific directory.
Mount points are provisioned in /run/media/$USER/ with permissions allowing $USER exclusive access. 

There may be a way to make udisks2 mount in "/media/Label" but I don't know it since I use udevil with spacefm instead so I did not look into that.

udisks2 is started to be pulled in by programs in testing and unstable as they transition from their Gnome2 to Gnome3 versions and start requiring or recommending udisks2.
Most of those programs are pulling it indirectly by needing "gvfs-daemons" or "gnome-disk-utility".

Last edited by arclance (2013-08-25 02:04:23)

Offline

#15 2013-08-25 05:33:14

rml
#! Member
Registered: 2012-02-10
Posts: 52

Re: [SOLVED] path to external hard drives changed

sweet!  i use spacefm too, so i read about udevil and installed it, set up kernel polling, and now things are back to the way they should be wink

thanks arclance and everybody for your help.
SoLvEd

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo