SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-07-07 21:32:34

tehol
#! Member
Registered: 2013-05-29
Posts: 53

[SOLVED] Installing printer Brother MFC-6800 - "Software index ..."

CUPS or LPR? deb or rpm? I don't really know what this means (other than I know what CUPS is)... but based on what I've been reading, it seems people like deb better than rpm, and CUPS better than LPR. But apparently Brother doesn't offer the PPD file for the model of printer I have, as you can see here. So I followed the instructions here for LPR, I believe (though I don't know how to check) that I"ve properly installed ia32-libs, I've downloaded the deb LPR driver, and then I've tried a couple differnet thingson step 4, but I seem to have messed it all up.

I did two separate things, to the best of my knowledge. First, I just clicked the driver and tried to install it that way. That gave me this error message:
2013_07_07_1373231437_715x457_scrot.jpg

Second, I tried to follow the brother instructions more directly, and typed the following in the command line:

<user>@crunchbang:~/brother$ dpkg -i --force-all mfc6800lpr-1.1.2-1.i386.deb
dpkg: error: operation requires read/write access to dpkg status area
<user>@crunchbang:~/brother$ sudo dpkg -i --force-all mfc6800lpr-1.1.2-1.i386.deb 
[sudo] password for <user>
(Reading database ... 81967 files and directories currently installed.)
Preparing to replace mfc6800lpr 1.1.2-1 (using mfc6800lpr-1.1.2-1.i386.deb) ...
Unpacking replacement mfc6800lpr ...
/var/lib/dpkg/info/mfc6800lpr.postrm: 3: /var/lib/dpkg/info/mfc6800lpr.postrm: /etc/init.d/lpd: not found
dpkg: warning: subprocess old post-removal script returned error exit status 127
dpkg: trying script from the new package instead ...
/var/lib/dpkg/tmp.ci/postrm: 3: /var/lib/dpkg/tmp.ci/postrm: /etc/init.d/lpd: not found
dpkg: error processing mfc6800lpr-1.1.2-1.i386.deb (--install):
 subprocess new post-removal script returned error exit status 127
/var/lib/dpkg/tmp.ci/postrm: 3: /var/lib/dpkg/tmp.ci/postrm: /etc/init.d/lpd: not found
dpkg: error while cleaning up:
 subprocess new post-removal script returned error exit status 127
Errors were encountered while processing:
 mfc6800lpr-1.1.2-1.i386.deb

At this point I don't really know what's going on. I'm not aware of the Synaptic Package Manager, and searching for it online returns things about Ubuntu. I don't know how to check the file permissions/correctness of the file "/etc/apt/sources.list". I also don't know what to do with the error messages from terminal, though I guess I could try and build the directory /etc/init.d/lpd, but I think my problems are bigger than that...

All help is greatly appreciated!

EDIT: SUCCESS! So far as I can tell, these are the steps that worked for me: http://crunchbang.org/forums/viewtopic.php?id=28376 (Thanks to Bigbenaugust!). The thread that I just linked to is easier to understand if you also follow the instructions in this specific post, in another thread: http://crunchbang.org/forums/viewtopic. … 18#p277918
The early link in my thread provided by the second poster (who's name I currently forget) was also very helpful: https://wiki.debian.org/SystemPrinting

Last edited by tehol (2013-08-21 02:56:59)


~

Offline

Be excellent to each other!

#2 2013-07-08 02:01:39

shengchieh
#! Die Hard
Registered: 2009-01-07
Posts: 616

Re: [SOLVED] Installing printer Brother MFC-6800 - "Software index ..."

I'm not much help.  I assume you are using

http://www.dice.inf.ed.ac.uk/units/user … nting.html
http://cups.sourceforge.net/cups_install.html

If not, give it a try.

Sheng-Chieh

Offline

#3 2013-07-08 14:32:10

andreas-r
#! CrunchBangian
From: The North
Registered: 2013-05-26
Posts: 226

Re: [SOLVED] Installing printer Brother MFC-6800 - "Software index ..."

You should use CUPS. Can be installed by the cb-welcome script. I you haven't installed it you can type "cb-welcome" in a terminal.

This guide on configuring CUPS helped me.

Basically:
- in a terminal type

sudo usermod -a -G lpadmin [i]username[/i]

- go to http://localhost:631/ in a browser

- use the menus to add printer. It should register the printer if it's connected and from there it should be easy ...


"There is nothing to writing. All you do is sit down at a typewriter and bleed." - Hemmingway >>> CLI Typewriter

Offline

#4 2013-07-08 21:11:26

tehol
#! Member
Registered: 2013-05-29
Posts: 53

Re: [SOLVED] Installing printer Brother MFC-6800 - "Software index ..."

ok, thanks! I'll try cups again when I get home later.


~

Offline

#5 2013-08-01 19:49:58

tehol
#! Member
Registered: 2013-05-29
Posts: 53

Re: [SOLVED] Installing printer Brother MFC-6800 - "Software index ..."

Ok... so this took me forever to get back to.

1) I have cups installed.
2) It said my printer didn't have a driver.
3) I downloaded the appropriate cupswrapper driver.
4) I tried opening the driver. I got the following error message:

cupswrapper.jpg

5) I tried to follow the appropriate brother cupswrapper instructions. They suggested I do two things:
(a) Install ia32-libs or lib32stdc++ (I follow the "Debian 64 pre-install requirements"). I didn't do this (yet) because last time I tried to install ia32-libs, everything got messed up.
(b) type the followin in Terminal: "ln -s /etc/init.d/cupsys /etc/init.d/lpd". I did, and I got the following error mesage:

lncupsys.jpg

Any suggestions?


~

Offline

#6 2013-08-13 22:46:29

tehol
#! Member
Registered: 2013-05-29
Posts: 53

Re: [SOLVED] Installing printer Brother MFC-6800 - "Software index ..."

Bump?


~

Offline

#7 2013-08-13 23:31:07

annoyingbeggar
#! Junkie
From: Florida
Registered: 2013-05-30
Posts: 430

Re: [SOLVED] Installing printer Brother MFC-6800 - "Software index ..."

Try sudo dpkg --add-architecture i386.

Installing ia32-libs is no longer supported.


“I don't believe in charity. I believe in solidarity. Charity is so vertical. It goes from the top to the bottom. Solidarity is horizontal. It respects the other person. I have a lot to learn from other people.” - Eduardo Hughes Galeano

Offline

#8 2013-08-14 03:41:33

bigbenaugust
#! Junkie
From: the 919
Registered: 2009-03-04
Posts: 341

Re: [SOLVED] Installing printer Brother MFC-6800 - "Software index ..."

Check out the other Brother printer thread and see if that is of any assistance.


--Ben
Debian: II   Arch: II   openSUSE: I

Offline

#9 2013-08-14 15:07:10

hinto
#! Windbag
From: Cary, NC
Registered: 2010-12-08
Posts: 1,389

Re: [SOLVED] Installing printer Brother MFC-6800 - "Software index ..."

Generally all you need is the ppd file which you can download from Brother's website.
No package needed.  Just point cups to the ppd when you install the printer.
-Hinto


"Sometimes I wish I hadn't taken the red pill" -Me

Offline

#10 2013-08-16 03:38:54

tehol
#! Member
Registered: 2013-05-29
Posts: 53

Re: [SOLVED] Installing printer Brother MFC-6800 - "Software index ..."

Hey annoyingbeggar,

I typed that in and it did nothing. I'm assuming I have that installed then already? So I proceeded with the brother instructions here. I got to step 4-3, and received the following errors.

tehol@crunchbang:~$ ls /media/1TB/backup/brother
cupswrapperMFC6800-1.0.2-1.i386.deb  mfc6800lpr-1.1.2-1.i386.deb  screenshots
tehol@crunchbang:~$ cd /media/1TB/backup/brother
tehol@crunchbang:/media/1TB/backup/brother$ sudo dpkg -i --force-all mfc6800lpr-1.1.2-1.i386.deb
[sudo] password for tehol: 
(Reading database ... 87846 files and directories currently installed.)
Preparing to replace mfc6800lpr 1.1.2-1 (using mfc6800lpr-1.1.2-1.i386.deb) ...
Unpacking replacement mfc6800lpr ...
/var/lib/dpkg/info/mfc6800lpr.postrm: 3: /var/lib/dpkg/info/mfc6800lpr.postrm: /etc/init.d/lpd: not found
dpkg: warning: subprocess old post-removal script returned error exit status 127
dpkg: trying script from the new package instead ...
/var/lib/dpkg/tmp.ci/postrm: 3: /var/lib/dpkg/tmp.ci/postrm: /etc/init.d/lpd: not found
dpkg: error processing mfc6800lpr-1.1.2-1.i386.deb (--install):
 subprocess new post-removal script returned error exit status 127
/var/lib/dpkg/tmp.ci/postrm: 3: /var/lib/dpkg/tmp.ci/postrm: /etc/init.d/lpd: not found
dpkg: error while cleaning up:
 subprocess new post-removal script returned error exit status 127
Errors were encountered while processing:
 mfc6800lpr-1.1.2-1.i386.deb

Bigbenaugust, which thread do you mean? I used the #! forum search, and nothing seemed to have *quite* what I was looking for...

hinto, according to this page on the brother website, there is no ppd file for my printer option. I wish it were that simple! Thanks for the suggestion, though.

EDIT: I'll wait for help on this route.. but if it fails, what do you think of me trying this?

Last edited by tehol (2013-08-16 03:41:41)


~

Offline

#11 2013-08-16 03:52:55

annoyingbeggar
#! Junkie
From: Florida
Registered: 2013-05-30
Posts: 430

Re: [SOLVED] Installing printer Brother MFC-6800 - "Software index ..."

The errors seems to be in their Debian package (maybe it is not up-to-date with the new multiarch?).

In any case, I don't think trying that installer will hurt anything. It's just a bash script and looks to be pretty straight forward based on a quick scroll through it. It's going to install ia32-libs, though. Just so you are aware. This has been known to cause some minor headaches with #! because it removes some #! related packages. You can just reinstall these onces it's complete.


“I don't believe in charity. I believe in solidarity. Charity is so vertical. It goes from the top to the bottom. Solidarity is horizontal. It respects the other person. I have a lot to learn from other people.” - Eduardo Hughes Galeano

Offline

#12 2013-08-16 13:06:10

hinto
#! Windbag
From: Cary, NC
Registered: 2010-12-08
Posts: 1,389

Re: [SOLVED] Installing printer Brother MFC-6800 - "Software index ..."


"Sometimes I wish I hadn't taken the red pill" -Me

Offline

#13 2013-08-16 15:51:46

bigbenaugust
#! Junkie
From: the 919
Registered: 2009-03-04
Posts: 341

Re: [SOLVED] Installing printer Brother MFC-6800 - "Software index ..."

the other brother thread

This is the thread I was referring to, which didn't show up in a search for me either.


--Ben
Debian: II   Arch: II   openSUSE: I

Offline

#14 2013-08-21 02:13:07

tehol
#! Member
Registered: 2013-05-29
Posts: 53

Re: [SOLVED] Installing printer Brother MFC-6800 - "Software index ..."

hey! just spent the past couple hours working on and typing a long reply, and then I accidentally hit ctrl+q, destroying it all... I will try my best to remember everything I wrote/did. EDIT: I certainly can't remember everything about the brother installer...

annoyingbeggar, I tried the brother installer. I ran into two errors. I forget the first, but the installer kept running after that. The second (where things stopped) was that "lpr" was not a valid command... Is this enough information to help me with, or should I go through the process again and see what happens?

hinto, I tried using CUPS with that 64-bit driver, and it didn't work. It gave the below error message when I used the add printer option in CUPS via localhost 631. The URLS you provided, if I follow the instructions present, suggest I use sane-utils. This doesn't seem to be what you're suggesting I do, is it?

Add Printer Brother_MFC-6800 Error

Unable to add printer:

    Unable to copy interface script - No such file or directory

I actually was able (this time in CUPS) to select a Brother MFC-6800 option... that's when I ran into the same issues as the thread bigbenaugust posted. Currently running through the steps from that thread.

Last edited by tehol (2013-08-21 02:13:43)


~

Offline

#15 2013-08-21 03:03:19

tehol
#! Member
Registered: 2013-05-29
Posts: 53

Re: [SOLVED] Installing printer Brother MFC-6800 - "Software index ..."

Sucess! Thanks BigBenAugust! I have successfully printed the default test page from CUPS, and I printed "test" from LibreOffice writer. woo!


~

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo