SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-06-29 19:01:44

cpgos
New Member
Registered: 2013-06-27
Posts: 4

QtCreator installation problem

I would appreciate some help with an installation problem related to QtCreator.

One broken package results at the end of attempting to install it, the package being libqt4-opengl-dev and the
displayed error messages as shown below:

  W: Failed to fetch http://security.debian.org/pool/updates … 1_i386.deb
  404  Not Found [IP: 212.211.132.32 80]

  W: Failed to fetch http://security.debian.org/pool/updates … 1_i386.deb
  404  Not Found [IP: 212.211.132.250 80]

The searching that I have done seem to suggest that this error may be something to do with the repositories used?
If so the contents of /etc/apt/sources.list follows below

## CRUNCHBANG
## Compatible with Debian Wheezy, but use at your own risk.
deb http://packages.crunchbang.org/waldorf waldorf main
deb-src http://packages.crunchbang.org/waldorf waldorf main

## DEBIAN
deb http://http.debian.net/debian wheezy main contrib non-free
deb-src http://http.debian.net/debian wheezy main contrib non-free

## DEBIAN SECURITY
deb http://security.debian.org/ wheezy/updates main
deb http://http.us.debian.org/debian/ wheezy contrib non-free main
# deb-src http://security.debian.org/ wheezy/updates main

Any suggestions or comments much appreciated.

Best regards,
cpgos

Offline

Be excellent to each other!

#2 2013-06-29 21:16:29

pvsage
Internal Affairs
From: North Carolina
Registered: 2009-10-18
Posts: 11,943

Re: QtCreator installation problem

For one thing, you have two Wheezy security URIs; what happens if you comment out the main security.debian.org repo?


I'm a moderator here.  How are we doing?  Feedback is encouraged.

Offline

#3 2013-06-29 22:14:43

cpgos
New Member
Registered: 2013-06-27
Posts: 4

Re: QtCreator installation problem

Thank you for your response.

The error message below was displayed after doing what you suggest and then trying to fix the broken package:

E: I wasn't able to locate a file for the mesa-common-dev package. This might mean you need to manually fix this package.

The new version of /etc/apt/sources.list ia as follows:

## CRUNCHBANG
## Compatible with Debian Wheezy, but use at your own risk.
deb http://packages.crunchbang.org/waldorf waldorf main
deb-src http://packages.crunchbang.org/waldorf waldorf main

## DEBIAN
deb http://http.debian.net/debian wheezy main contrib non-free
deb-src http://http.debian.net/debian wheezy main contrib non-free

## DEBIAN SECURITY
# deb http://security.debian.org/ wheezy/updates main
deb http://http.us.debian.org/debian/ wheezy contrib non-free main
# deb-src http://security.debian.org/ wheezy/updates main

Offline

#4 2013-06-29 22:56:16

pidsley
Window Mangler
Registered: 2012-05-23
Posts: 1,752

Re: QtCreator installation problem

Did you "sudo apt-get update" after you commented out the security repo? That package is in wheezy: http://packages.debian.org/wheezy/mesa-common-dev

Offline

#5 2013-06-30 02:02:17

pvsage
Internal Affairs
From: North Carolina
Registered: 2009-10-18
Posts: 11,943

Re: QtCreator installation problem

Yes, I forgot to point out that an `apt-get update` is necessary after any change to /etc/apt/sources.list.  From the first post, I see that APT was originally trying to get the package from security.debian.net; it makes sense that it would fail with that kind of error with that repo commented out.


I'm a moderator here.  How are we doing?  Feedback is encouraged.

Offline

#6 2013-06-30 11:15:47

cpgos
New Member
Registered: 2013-06-27
Posts: 4

Re: QtCreator installation problem

Thanks to you both for your responses.

Initially, I did'nt execute sudo apt-get update, doing it now completes without error, however when I try to fix the broken dependency with Synaptic the following error is displayed

E: Internal Error, No file name for libqt4-opengl-dev:i386

It seems that links to several versions of the required package are located at the location below

http://packages.debian.org/search?searc … opengl-dev

Would a possible solution be to add whichever one is appropriate to the /etc/apt/sources.list?

Best regards,
cpgos

Offline

#7 2013-06-30 16:50:06

cpgos
New Member
Registered: 2013-06-27
Posts: 4

Re: QtCreator installation problem

QtCreator, version 2.5.0, now seems to be working.

As mentioned in my previous post an attempt to fix the broken dependency resulted in an error message. However, after about two hours I tried Synaptic again, without doing anything in the interval, and this time it completed without error.

Thanks for your help.

Best regards,
cpgos

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo