SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-01-19 17:02:53

pheebs
Member
Registered: 2010-04-03
Posts: 25

waldorf pulseaudio quirks and potential fixes

pulseaudio has been very finicky for me on waldorf, but I finally solved it with some google and hackery.

I had two major problems:

  • If I lowered the volume to say 50% and opened a gmusicbrowser to play a song, the volume would raise itself to 100%.

This was not limited to gmusicbrowser. VLC, chrome (youtube) and other audio apps were doing the same. I nearly blew out my speakers because of this behavior

I was able to find a potential solution on the arch forums, but I also took a peek at my xubuntu partition /etc/pulse/daemon.conf  because I never had the problem there.

In an attempt to copy xubuntu, here were the lines I uncommented/added in my #! config:

flat-volumes = no
resample-method = speex-float-1
default-fragments = 8
default-fragment-size-msec = 10
deferred-volume-extra-delay-usec = 1

After adding these, the volume now works as expected. Other apps do not auto boost the volume to 100%.  I added these options all at once, but you might have success with just the flat-volumes option.

  • Skype or VLC audio would be very distorted and fuzzy

This was a more common issue, but it's worth mentioning. Found the solution here on the arch forums and here. Essentially it's adding

tsched=0

to the load module settings.

# /etc/pulse/default.pa
### Automatically load driver modules depending on the hardware available
.ifexists module-udev-detect.so
load-module module-udev-detect tsched=0
.else
### Use the static hardware detection module (for systems that lack udev/hal support)
load-module module-detect tsched=0
.endif

There are some implications to adding this option, but it's a nice quick fix. Check out the arch link above for a good discussion.

When modifying these settings, make sure to restart pulseaudio:

pulseaudio -k
# or
pulseaudio --kill && pulseaudio --start

Offline

Help fund CrunchBang, donate to the project!

#2 2013-02-10 08:37:46

vlax
#! Member
From: Alcatraz
Registered: 2012-12-25
Posts: 77
Website

Re: waldorf pulseaudio quirks and potential fixes

pheebs wrote:
# /etc/pulse/default.pa
### Automatically load driver modules depending on the hardware available
.ifexists module-udev-detect.so
load-module module-udev-detect tsched=0
.else
### Use the static hardware detection module (for systems that lack udev/hal support)
load-module module-detect tsched=0
.endif

thanks, it works for me in Waldorf;
pulse gaves me choppy sound when using mplayer, now it looks working good....

Offline

#3 2013-02-26 13:27:08

RobyIndie
New Member
Registered: 2013-02-19
Posts: 3

Re: waldorf pulseaudio quirks and potential fixes

I really want to fix the quirks, but this made all wine and google chrome flash player sounds way too fast! How can we fix this without screwing up other things?

Offline

#4 2013-02-27 17:34:52

pheebs
Member
Registered: 2010-04-03
Posts: 25

Re: waldorf pulseaudio quirks and potential fixes

RobyIndie wrote:

I really want to fix the quirks, but this made all wine and google chrome flash player sounds way too fast! How can we fix this without screwing up other things?

I'm guessing that happens as a result of the these lines:

default-fragments = 8
default-fragment-size-msec = 10

Try mixing, matching or removing the settings to see what works best.  Also try googling for that specific issue.

Offline

#5 2013-03-21 22:11:20

mehr
New Member
Registered: 2013-03-14
Posts: 8

Re: waldorf pulseaudio quirks and potential fixes

good find. I installed #! a few weeks ago and wondered why increasing volume in VLC would also increase the master volume. Didn't know how to diagnose the problem until I read more about Pulseaudio in the Arch wiki.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo