SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-03-19 20:05:09

Barnabyh
#! Die Hard
From: Church of the Subgenius
Registered: 2012-11-07
Posts: 809
Website

[Solved] VLC: no sound after pause/unpause

The image of Waldorf 32-bit I installed was one issued before the switch back to VLC. Although very happy with gnome-mplayer I followed the recent decision in so far as to add VLC to my setup, but mplayer remains as well.

Funny thing, VLC looses sound after unpausing any kind of movie/ file it's playing, sound is recovered when dragging the slider slightly back to before the point where it was paused. The recent update of the package in Testing did not resolve this for me. Any ideas?

Last edited by Barnabyh (2013-03-20 12:56:49)


From ArchBang to SlackBang | Project SlackBang

Say no to bugs. - It's not a bug, it's a worm.

Offline

Help fund CrunchBang, donate to the project!

#2 2013-03-20 08:21:44

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: [Solved] VLC: no sound after pause/unpause

google for "vlc loses sound after pause".
Let us know which solution works for you.
Cheers

Last edited by xaos52 (2013-03-20 08:23:56)

Offline

#3 2013-03-20 08:44:56

th3pun15h3r
#! Die Hard
Registered: 2011-11-22
Posts: 509

Re: [Solved] VLC: no sound after pause/unpause

https://dl.dropbox.com/u/10573557/SUSE% … _issue.png

http://forum.videolan.org/viewtopic.php?f=32&t=87731

From what I read on these forums and others checking if your sound is Alsa or pulse your using corresponds with what vlc is trying to use

Offline

#4 2013-03-20 11:16:46

Jimbo_G
#! Barcalounger
From: Paris, France
Registered: 2009-12-08
Posts: 135

Re: [Solved] VLC: no sound after pause/unpause

I had exactly this problem for a while and never found a solution. With the latest Waldorf image, VLC works fine. Sorry I can't be of any help.

Offline

#5 2013-03-20 12:05:54

zalew
#! Junkie
From: Warsaw, .PL
Registered: 2012-03-28
Posts: 374

Re: [Solved] VLC: no sound after pause/unpause

had this problem on sid with alsa a long time ago, and replicated it yesterday on waldorf after fiddling with pulseaudio and alsa. for me, the solution linked by thepunisher (set proper output in vlc audio settings) works. currently on pulseaudio with pulseaudio set in vlc and works fine, with alsa you have to experiment with the device dropdown.

Offline

#6 2013-03-20 12:55:17

Barnabyh
#! Die Hard
From: Church of the Subgenius
Registered: 2012-11-07
Posts: 809
Website

Re: [Solved] VLC: no sound after pause/unpause

Thanks guys, classic mistake, google first  tongue . I chose to use the dropdown for Alsa instead of installing the vlc-plugin-pulse. Set it to 'Analog default audio device' and it works as intended.

Cheers~


From ArchBang to SlackBang | Project SlackBang

Say no to bugs. - It's not a bug, it's a worm.

Offline

#7 2013-03-20 13:32:13

Barnabyh
#! Die Hard
From: Church of the Subgenius
Registered: 2012-11-07
Posts: 809
Website

Re: [Solved] VLC: no sound after pause/unpause

I don't think anybody who installed an image with VLC already default player would have had this problem as the pulse plugin would already be present. If you don't want to use the plugin but go the traditional way...

Just for future convenience I'm posting a screenshot of the relevant section in VLC Preferences, if anyone else should come across this. Click the radio button at the bottom left to show 'All'. In my case there was no device selected. Choose one according to your setup, i.e. you might want surround sound.

screenshot-200313-132443.php

VLC will now not show up as running application in the PA mixer because it's using Alsa.

Last edited by Barnabyh (2013-03-20 13:38:31)


From ArchBang to SlackBang | Project SlackBang

Say no to bugs. - It's not a bug, it's a worm.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo