SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-03-06 07:49:33

ohnonot
...again
Registered: 2012-05-22
Posts: 1,675
Website

After Messing up GRUB: CB Boots but No Keyboard, No Touchpad

Hello!
i was trying new distros and one of them messed up my grub so i couldn't boot anything else anymore. (it was antix, fwiw)

after shooting in the dark (=trying to solve the problem without really knowing what i'm doing) for a while, i did manage to restore grub, and i can boot into all 3 distros currently installed.
i can boot into cb, too, but neither keyboard nor touchpad or usb mouse are working. the desktop comes up normally and conky is monitoring the system and everything seems to be working otherwise, but i just can't do anything. also ctrl+alt+F1 has no effect.

at some point during my rescue efforts i noticed that the initrd.img and vmlinuz links in the cb root directory were broken, plus there was some weird file which i've never seen before (looked like chinese symbols without a chinese font installed; right-click properties said "broken utf encoding" or sth like that).
(i suspect i accidentally tried to apply 32-bit solution on a 64-bit system)
those i deleted and since i could not recreate the links i just copied the appropriate img and vmlinuz from the boot directory.

i can access the partition read/write.
what can i do to make cb boot properly again?

right now i'm on tangostudio (based on ubuntu 10.04) on the same hd, different partition.

thanks for reading.
any help appreciated.


PS:
i did it again, i didn't supply any hard info. sorry.
so, this is a shitty msi vr601 laptop, capable of running on 64 bit. however the tango studio seems to be 32 bit (the names of the files in /boot do NOT say amd64). the crunchbang install in question is 64bit. the antiX that originally messed up my system is 32bit. however the kernel says 486 instead of 386, not sure if that matters.

only one hard drive (250GB) with 3 primary partitions (crunchbang on sda1, data on sda2 and i think swap on sda3) and 1 extended partition with 2 logical partitions containing tango studio and antix.

my rescue efforts were:
- trying to fix grub with a rescatux cd in 32 bit mode (error)
- trying to fix grub with hirens boot cd (no error, but no success either)
...sometimes i'd get a grub menu but could not boot anything except either tangostudio or antix - all others gave a file not found error.
- trying grub-install from tango studio (no error; after reboot i don't get a grub menu, but the grub rescue prompt.
- trying to boot all partitions in this way:

ls
set prefix=(hdX,Y)/boot/grub
set root=(hdX,Y)
set
ls /boot
insmod /boot/grub/linux.mod
linux /vmlinuz root=/dev/sdXY ro
initrd /initrd.img
boot

(usually i'd get an "unknown file system error" except for 1 partition)
- trying to fix grub with rescatux in 64bit mode (success, everything boots but cb is broken)

i compared the contents of /boot on different partitions; everything looks as it should be to me, except on sda1 (the partition in question, containing crunchbang linux) there's another boot folder inside the /boot folder,  with another grub folder inside it, but no kernel. (edit: i removed that too, no effect)

Last edited by ohnonot (2013-03-07 06:02:56)

Offline

Help fund CrunchBang, donate to the project!

#2 2013-03-07 06:22:00

ohnonot
...again
Registered: 2012-05-22
Posts: 1,675
Website

Re: After Messing up GRUB: CB Boots but No Keyboard, No Touchpad

i tried some more changes; still haven't solved the problem.

what i striked out in my first post, it doesn't seem to have any effect. first i hardlinked the files, then i removed the links, the boot process looks the same and no keyboard, no touchpad.

one thing i noticed:
all the info is whizzing by during boot (i set it up to be like that) and there was something i have never seen before:

...
....
waiting for udev to be fully populated...
udevd[337]: IMPORT{} type missing, ignoring IMPORT /lib/udev/rules.d/60-persistent-serial.rules:9
udevd[337]: IMPORT{} type missing, ignoring IMPORT /lib/udev/rules.d/60-persistent-serial.rules:13
udevd[337]: IMPORT{} type missing, ignoring IMPORT /lib/udev/rules.d/60-persistent-storage-tape.rules:15
udevd[337]: IMPORT{} type missing, ignoring IMPORT /lib/udev/rules.d/60-persistent-serial.rules:9
udevd[337]: IMPORT{} type missing, ignoring IMPORT /lib/udev/rules.d/60-persistent-serial.rules:13
udevd[337]: IMPORT{} type missing, ignoring IMPORT /lib/udev/rules.d/60-persistent-storage-tape.rules:15
udevd[337]: IMPORT{} type missing, ignoring IMPORT /lib/udev/rules.d/60-persistent-serial.rules:9
udevd[337]: IMPORT{} type missing, ignoring IMPORT /lib/udev/rules.d/60-persistent-serial.rules:13
udevd[414]: failed to execute '/lib/udev/mtp-probe' 'mtp-probe /sys/devices/pci0000:00/0000:00:1a.7/usb/1-1 1 2': no such file or directory
done
....
...

- that makes sense to me but i wouldn't know how to fix it.

i was thinking to reinstall and/or update but it seems i cannot connect to the internet (wlan) (probably for the same reasons)
i was thinking sth like this:
http://askubuntu.com/questions/34295/ke … er-upgrade
http://superuser.com/questions/102449/h … ng-apt-get
so how to do that offline? if it's a good solution or worth a try?

other things i tried to no avail:
http://askubuntu.com/questions/225587/k … ot-working


i hope somebody can make more sense out of it...

again, thanks in advance.

Last edited by ohnonot (2013-03-07 07:31:24)

Offline

#3 2013-03-07 10:30:22

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: After Messing up GRUB: CB Boots but No Keyboard, No Touchpad

Offline

#4 2013-03-07 19:52:44

ohnonot
...again
Registered: 2012-05-22
Posts: 1,675
Website

Re: After Messing up GRUB: CB Boots but No Keyboard, No Touchpad

thanks a lot xaos, good doctor!

i tried your magic suggestion with grub-install first, and got this after update-grub:
taG9seg

it didn't make matters worse but i still couldn't use the #! install.

so i did the magic thing again, and did an apt-get upgrade --reinstall -f.
it was downloading a lot but after a while it started spitting weird warnings, about locale not found first, and soon serious errors.

reboot.

this made matters worse, now the boot process would stop completely and switch to busybox after a while.

so i did the magic thing again and did the grub-install, now i get this:
taG9tMA

... well, i guess there's not much to do with less than 10 years linux experience and a no degrees in anything nerdy....

Offline

#5 2013-03-07 21:52:29

wuxmedia
wookiee madclaw
From: Back in Blighty
Registered: 2012-03-09
Posts: 1,472
Website

Re: After Messing up GRUB: CB Boots but No Keyboard, No Touchpad

jeez man. you've had a good run, that looks preetty borked. sad
time to pull what files you can and re-install.  imho sad
sorry to be absolutely no use whatsoever.  roll

Offline

#6 2013-03-08 10:28:03

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: After Messing up GRUB: CB Boots but No Keyboard, No Touchpad

Seems related to this.
Three cases now.
I guess more will follow.

re-install, but first post relevant info mentioned in that threads last post and take the necessary precautions - backup - before you update/upgrade, until this is ironed out.

cheers

Last edited by xaos52 (2013-03-08 10:31:07)

Offline

#7 2013-03-14 15:57:31

ohnonot
...again
Registered: 2012-05-22
Posts: 1,675
Website

Re: After Messing up GRUB: CB Boots but No Keyboard, No Touchpad

thanks again you all for trying to help.

sorry for not posting for a while - after my last post with the mobile phone screenshots i realised that things are getting worse instead of better... and since i could still access the partition (but not boot into it) i just copied the whole thing to an external drive and started from a clean slate (is that how u say in english? tabula rasa?) and have been busy with other self-inflicted problems since... duh...

so, i don't know what the last post of the thread you're refering to is, because it's not the last anymore. but i'd be happy to provide any file from the "after-the-messup-snapshot".

however i don't think my original problem has anything to do with anything inside crunchbang.

i quote myself from post 1:

my rescue efforts (after a messed-up grub config?) were:
- trying to fix grub with a rescatux cd in 32 bit mode (error)
- trying to fix grub with hirens boot cd (no error, but no success either)
...sometimes i'd get a grub menu but could not boot anything except either tangostudio or antix - all others gave a file not found error.
- trying grub-install from tango studio (no error; after reboot i don't get a grub menu, but the grub rescue prompt.
- trying to boot all partitions in this way:

ls
set prefix=(hdX,Y)/boot/grub
set root=(hdX,Y)
set
ls /boot
insmod /boot/grub/linux.mod
linux /vmlinuz root=/dev/sdXY ro
initrd /initrd.img
boot

(usually i'd get an "unknown file system error" except for 1 partition)
- trying to fix grub with rescatux in 64bit mode (success, everything boots but cb is broken)

and only after that the problems discussed here started.
personally i think one of the first two actions did the harm (trying to fix a 64bit system with a 32bit rescue system, and trying to fix with a powerful but somewhat dubious rescue cd)

Offline

#8 2013-03-14 16:41:20

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: After Messing up GRUB: CB Boots but No Keyboard, No Touchpad

My definition of starting from a clean slate is:

- backup everything that has value for you
- remove all existing partitions
- start new installs one by one
- once you have a situation that you feel is good, take a backup so you can always revert to it.
- take detailed notes of what you all do, so that you can reproduce any problems that occur.

Cheers

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo