SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-02-18 22:26:22

donkeyotay
#! CrunchBanger
From: Everywhere
Registered: 2011-01-28
Posts: 192

Configuring Evilwm [Solved]

I must be particularly thick at the moment, because, for the life of me, I cannot work out how to configure Evilwm. I'm using a standard Waldorf installation & I've installed evilwm from the repos. I've added it to Slim so that I can load it instead of Openbox at login. But I cannot work out where to put

-mask1 mod4
-nosoliddrag
-bw 2

And I'm sure that I can change the cursor from an X to an arrow, but that is eluding me too!
Can somebody please enlighten me?
Many thanks
Simon

Last edited by donkeyotay (2013-02-21 15:29:58)


I didn't say it was your fault... I said I was going to blame you.

Offline

Help fund CrunchBang, donate to the project!

#2 2013-02-19 01:24:44

PackRat
#! Die Hard
From: USA
Registered: 2011-03-03
Posts: 1,330

Re: Configuring Evilwm [Solved]

They are command line options (not sure about the cursor though). Have a read through this post:

Evilwm - 30 Window Managers in 30 Days.


"It does not require many words to speak the truth." - Chief Joseph, Nez Perce tribe

Offline

#3 2013-02-19 05:34:30

donkeyotay
#! CrunchBanger
From: Everywhere
Registered: 2011-01-28
Posts: 192

Re: Configuring Evilwm [Solved]

I had read the 30 in 30 post but re-read it... and in

/usr/share/xsessions/evil.desktop

I added

Exec=/usr/bin/evilwm -nosoliddrag -mask1 mod4 -bw 2 -term terminator

to start evilwm with outline dragging, moving Ctrl+Alt to Win, have a border width of 2 pixels & the default terminal as Terminator. This hasn't worked. I then renamed the file to evilwm.desktop with no effect (I've renamed it back now). Nothing seems to work.
What am I missing?  hmm


I didn't say it was your fault... I said I was going to blame you.

Offline

#4 2013-02-19 09:22:41

Doomicide
#! Junkie
From: the Nightosphere
Registered: 2011-06-24
Posts: 472
Website

Re: Configuring Evilwm [Solved]

Try putting the options in ~/.evilwmrc without the leading `-', that's how I do it. How did you set the X cursor?


“From each according to his faculties; to each according to his needs”
Look at the code. Look at the silly code!

Offline

#5 2013-02-19 13:35:27

gutterslob
#! Resident Bum
Registered: 2009-11-03
Posts: 3,085

Re: Configuring Evilwm [Solved]

Yup. the key file, as Doomicide stated is ~/.evilwmrc
That's DOTevilwmrc in your home directory. *nix loves its polkadots. Hang on, I'll go see if I have an old config lying around. Will update this post in a couple of minutes.

Edit:
Okay, here's a sample ~/.evilwmrc
I tried to incorporate all the options you previously parsed with the command. this way, all you'll need in your evilwm.desktop file will be "Exec=/usr/bin/evilwm"

term terminator
#term urxvtc
mask1 mod4
#mask2 mod4
#mask2 mod1
altmask shift
fn terminus:pixelsize9
nosoliddrag
snap 8
bw 2
fg #cc6666
fc #6699cc
bg #999999
#dock conky

I commented out some variables. If you want to enable them, just uncomment by removing the # from the start of each line. Replace the fn (font) with your desired choice (if you want terminus, which you do, just "apt-get install xfonts-terminus" and restart X)

man pages are your friend.

In a terminal, do:

man evilwm

It should give you all you need. It even tells you about the $HOME/.evilwmrc file, which makes this entire post of mine redundant.

Cheers.

Last edited by gutterslob (2013-02-19 13:53:06)


Point & Squirt

Offline

#6 2013-02-19 17:15:32

donkeyotay
#! CrunchBanger
From: Everywhere
Registered: 2011-01-28
Posts: 192

Re: Configuring Evilwm [Solved]

Thanks for the replies. As I installed this from the repos I'm running Ver 1.0.0 which AFAIA doesn't support a config file.
According to the original 30 in 30 by 2manydogs, I should be able to enter

evilwm -nosoliddrag -term terminator

but I'm not sure whereabouts to enter this  hmm


I didn't say it was your fault... I said I was going to blame you.

Offline

#7 2013-02-19 20:45:16

joek
#! Junkie
Registered: 2011-09-06
Posts: 497

Re: Configuring Evilwm [Solved]

I'm fairly certain the version available in the Stable repos supported a config file at ~/.evilwmrc: it certainly did when I used it...

Offline

#8 2013-02-19 22:19:09

donkeyotay
#! CrunchBanger
From: Everywhere
Registered: 2011-01-28
Posts: 192

Re: Configuring Evilwm [Solved]

Thanks for the reply. I should have mentioned that I had tried ~/.evilwmrc config file, but it still doesn't work. I've tried logging out of Openbox and logging into Evilwm and I've also tried rebooting into Evilwm all to no avail. I probably should also mention that I'm using slim as well.
Thanks for the replies so far, please keep them coming smile


I didn't say it was your fault... I said I was going to blame you.

Offline

#9 2013-02-20 10:36:39

joek
#! Junkie
Registered: 2011-09-06
Posts: 497

Re: Configuring Evilwm [Solved]

Hm...
You're on Waldorf, right?

Right, I'll install and have a poke round...

Offline

#10 2013-02-20 10:48:41

joek
#! Junkie
Registered: 2011-09-06
Posts: 497

Re: Configuring Evilwm [Solved]

Okay, I was able to use
`evilwm -mask1 alt` to successfully remap C-A to A. Must go now, but I can't see why it's not working...

Offline

#11 2013-02-20 12:16:49

donkeyotay
#! CrunchBanger
From: Everywhere
Registered: 2011-01-28
Posts: 192

Re: Configuring Evilwm [Solved]

Hi Joek, yes I'm on Waldorf. This is really a stupid question but whereabouts did you enter/place

evilwm -mask1 alt

Bloody hell, I thought I was brighter that this but obviously not  ops


I didn't say it was your fault... I said I was going to blame you.

Offline

#12 2013-02-20 14:28:18

joek
#! Junkie
Registered: 2011-09-06
Posts: 497

Re: Configuring Evilwm [Solved]

I have in my .xinitrc
`exec evilwm -mask1 alt`
I don't use SLiM/GDM whatever is being used these days, though, so I don't know how much that affects things.

Offline

#13 2013-02-20 16:22:02

PackRat
#! Die Hard
From: USA
Registered: 2011-03-03
Posts: 1,330

Re: Configuring Evilwm [Solved]

Basic question about Waldorf - does it use Slim by default and have it read the *.desktop files in /usr/share/xsessions?

If not, I've only known Slim to read the ~/.xinitrc file, so:

exec evilwm -nosoliddrag -term terminator

would be the line in your .xinitrc to start it with your options.

Last edited by PackRat (2013-02-20 16:23:18)


"It does not require many words to speak the truth." - Chief Joseph, Nez Perce tribe

Offline

#14 2013-02-20 19:57:45

donkeyotay
#! CrunchBanger
From: Everywhere
Registered: 2011-01-28
Posts: 192

Re: Configuring Evilwm [Solved]

AFAIA Waldorf uses slim by default, certainly I haven't installed it. Slim, on my laptop, seems to work regardless of whether I have a .xinitrc file or not.
A .evilwmrc file has no effect when I launch into Evilwm.
I've even tried editing the desktop file with

Exec=/usr/bin/evilwm -nosoliddrag -term terminator

again to no effect.
Very perplexing... hmm


I didn't say it was your fault... I said I was going to blame you.

Offline

#15 2013-02-20 20:41:08

PackRat
#! Die Hard
From: USA
Registered: 2011-03-03
Posts: 1,330

Re: Configuring Evilwm [Solved]

I would try a startup script for evilwm then. Your /usr/share/xsessions/evilwm.desktop file would be:

[Desktop Entry]
Name=evilwm
Type=Application
Exec=/usr/local/bin/startevilwm

startevilwm:

#!/bin/sh
<stuff you want to start like conky, wallpaper, etc> &
exec evilwm -nosoliddrag -mask1 mod4 -bw 2 -term terminator

obviously you can name startevilwm what you want, and place it where you want. It will need to be executable though.

this is the startup file I use for fvwm:

#!/bin/sh

xmodmap "$HOME/.Xmodmap"
xrdb -l "$HOME/.Xdefaults" 
xsetroot -solid "#2E2E2E" &
xset -b 25 &

# Applications you want to run with fvwm.
# MAKE SURE THAT APPS THAT KEEP RUNNING HAVE AN ''&'' AT THE END.
urxvtd -q -o -f &
(sleep 2s && fbsetbg -c -r "$HOME/wallpaper/") &
(sleep 2s && system-config-printer-applet) &
(sleep 2s && update-notifier) &

# And last but not least we start fluxbox.
# Because it is the last app you have to run it with ''exec'' before it.
exec fvwm

One other question, is evilwm installed in /usr/bin or /usr/local/bin ?

Last edited by PackRat (2013-02-20 20:49:13)


"It does not require many words to speak the truth." - Chief Joseph, Nez Perce tribe

Offline

#16 2013-02-20 21:48:59

donkeyotay
#! CrunchBanger
From: Everywhere
Registered: 2011-01-28
Posts: 192

Re: Configuring Evilwm [Solved]

Thanks for the reply.
Evilwm is in /usr/bin


I didn't say it was your fault... I said I was going to blame you.

Offline

#17 2013-02-21 00:52:00

gutterslob
#! Resident Bum
Registered: 2009-11-03
Posts: 3,085

Re: Configuring Evilwm [Solved]

Fwiw, any variables/options you parse with the evilwm executable will override those in your ~/.evilwmrc. Are you sure you didn't have just:

Exec=/usr/bin/evilwm

in whatever file you're launching evilwm with. No "-snap X" or "-nosoliddrad" options included. Put those in the rc only. Does it still not read the .evilwmrc?  Quite perplexing indeed.....

I recall assisting someone else with evilwm some taime ago, and all that person needed to do was create an evilwm start script (~/bin/evilwmstart.sh) like the one PackRat showed, make it executable, and change his /usr/share/xsessions/evilwm.desktop to point to the script. The start handled wallpaper, daemons and whatnot, but evilwm would still recognize the .evilwmrc file without problems as long as it was just the executable being issued (without options) in the script.

Last edited by gutterslob (2013-02-21 00:55:22)


Point & Squirt

Offline

#18 2013-02-21 05:32:06

gutterslob
#! Resident Bum
Registered: 2009-11-03
Posts: 3,085

Re: Configuring Evilwm [Solved]

@donkeyotay

Did some checking:
https://github.com/nikolas/evilwm/blob/master/ChangeLog
http://www.6809.org.uk/evilwm/ChangeLog-1.1
According to the changelogs, support for $HOME/.evilwmrc was added in Version 1.1.0

I don't currently have a system with Debian/#! installed, but afaik, Waldorf is still based on Wheezy which, according to Debian's packages database, still has EvilWM at 1.0.0: http://packages.debian.org/wheezy/evilwm

Even the version for Unstable/Sid is at 1.0.0: http://packages.debian.org/unstable/x11/evilwm
Seriously wtf? That's like 5yrs+ old!!

First, confirm what version you have installed with;

apt-cache policy evilwm

If the output says 1.0.0-1, then you have a version that doesn't read a config file, so your options are; to either parse the variables via the executable, or build the latest version (1.1.0) from source: http://www.6809.org.uk/evilwm/install.shtml

Last edited by gutterslob (2013-02-21 13:38:45)


Point & Squirt

Offline

#19 2013-02-21 15:27:52

donkeyotay
#! CrunchBanger
From: Everywhere
Registered: 2011-01-28
Posts: 192

Re: Configuring Evilwm [Solved]

I have it working! yikes
Okay, I wrote a a start Evilwm executable with

#!/bin/sh
exec evilwm -nosoliddrag -term terminator -mask1 mod4 -bw 2

& called it startevilwm.sh

Then in /etc/slim.conf I put the full path /home/daddy/bin/startevilwm.sh in the sessions line.  And voila  big_smile

It seems the the .desktop files in /usr/share/xsessions don't have anything to do with slim.

Thank you one & all for your help & patience.

Now to change the cursor to an arrowhead...

Last edited by donkeyotay (2013-02-21 15:29:28)


I didn't say it was your fault... I said I was going to blame you.

Offline

#20 2013-02-22 00:59:34

gutterslob
#! Resident Bum
Registered: 2009-11-03
Posts: 3,085

Re: Configuring Evilwm [Solved]

donkeyotay wrote:

Now to change the cursor to an arrowhead...

Something like this in your startevilwm.sh should do the trick:

xsetroot -cursor_name left_ptr &

Point & Squirt

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo