SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-01-27 16:41:52

zubcho81
#! CrunchBanger
From: Sofia, Bulgaria
Registered: 2012-08-12
Posts: 200

xxkb not starting via autostart

Hi,

I've added

xxkb &

to my autostart, but when I start the laptop from shutdown the process is not starting. Any solution?

I can start it manually and it is working fine.


Dried frog pills
As their name suggests, these are pills made chiefly from frogs, specifically the extremely poisonous ones that live in the vivarium at Unseen University and handled by the first-year students, so that if they kill one of them, not too much education has been wasted.

I use them daily! tongue

Offline

Be excellent to each other!

#2 2013-01-27 17:22:44

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: xxkb not starting via autostart

Using strace, I see that xxkb searches for a config file in following order:

access("/home/xaos52/en_US.UTF-8/.xxkbrc", R_OK) = -1 ENOENT (No such file or directory)
access("/home/xaos52/en/.xxkbrc", R_OK) = -1 ENOENT (No such file or directory)
access("/home/xaos52/.xxkbrc", R_OK) = -1 ENOENT (No such file or directory)
access("/home/xaos52/en_US.UTF-8/.xxkbrc", R_OK) = -1 ENOENT (No such file or directory)
access("/home/xaos52/en/.xxkbrc", R_OK) = -1 ENOENT (No such file or directory)
access("/home/xaos52/.xxkbrc", R_OK) = -1 ENOENT (No such file or directory)
xxkb: Unable to get a default value for the required resource `XXkb.mainwindow.type'f none exists, it exits with an error:

So, the next question is: do you have a config file and what is in it?

Offline

#3 2013-01-27 20:49:21

zubcho81
#! CrunchBanger
From: Sofia, Bulgaria
Registered: 2012-08-12
Posts: 200

Re: xxkb not starting via autostart

XXkb.image.path: /usr/share/xxkb

XXkb.group.base: 1
XXkb.group.alt: 2

XXkb.mainwindow.enable: no
XXkb.mainwindow.geometry: 15x15
XXkb.mainwindow.image.1: en15.xpm
XXkb.mainwindow.image.2: bg15.xpm
XXkb.mainwindow.image.3: 
XXkb.mainwindow.image.4:
XXkb.mainwindow.label.font: -misc-*-r-*-20-*

XXkb.*.border.color: black
XXkb.*.border.width: 0

XXkb.*.label.foreground: white
XXkb.*.label.background: blue4
XXkb.*.label.enable: no

XXkb.mainwindow.type: tray
! possible values - normal, top, tray, wmaker

XXkb.button.enable: no
XXkb.button.geometry: 15x15-60+7
XXkb.button.image.1: en15.xpm
XXkb.button.image.2: bg15.xpm
XXkb.button.image.3: 
XXkb.button.image.4:
XXkb.button.label.font: -misc-*-r-*-13-*

XXkb.controls.add_when_start: yes
XXkb.controls.add_when_create: yes
XXkb.controls.add_when_change: no
XXkb.controls.focusout: no
XXkb.controls.two_state: yes
XXkb.controls.button_delete: yes
XXkb.controls.button_delete_and_forget: yes
XXkb.controls.mainwindow_delete: yes

XXkb.mousebutton.1.reverse: no
XXkb.mousebutton.3.reverse: no

XXkb.bell.enable: no
XXkb.bell.percent: -50

XXkb.ignore.reverse: no

! XXkb.app_list.<match>.<action>: <list>
! <match> is one of "wm_class_class", "wm_class_name", "wm_name", "property"
! <action> is one of "ignore", "start_alt", "alt_groupM" (M - 1..4) 
! For example:
!   XXkb.app_list.wm_class_class.ignore: *clock Fvwm*
!   XXkb.app_list.wm_class_name.start_alt: licq
!
!  ignore windows in KDE tray
!  XXkb.app_list.property.ignore: _KDE_NET_WM_SYSTEM_TRAY_WINDOW_FOR

When I start xxkb from terminal there are no errors.

Last edited by zubcho81 (2013-01-27 20:50:30)


Dried frog pills
As their name suggests, these are pills made chiefly from frogs, specifically the extremely poisonous ones that live in the vivarium at Unseen University and handled by the first-year students, so that if they kill one of them, not too much education has been wasted.

I use them daily! tongue

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo