SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-01-24 16:23:06

ywang9
New Member
Registered: 2013-01-24
Posts: 5

How to adjust brightness, crunchbang 11

Hi experts,

I installed CrunchBang 11, have been wasting many hours to adjust the brightness through a menu. Frustrated. Why Linux is always so user-non-unfriendly??? I could not even find such a basic functionality.

-wayne

Offline

Help fund CrunchBang, donate to the project!

#2 2013-01-24 16:25:43

ywang9
New Member
Registered: 2013-01-24
Posts: 5

Re: How to adjust brightness, crunchbang 11

I am old and stupid from Windows world, please help.

Offline

#3 2013-01-24 16:29:56

dura
Bloated Gimp
From: interzone
Registered: 2012-09-15
Posts: 2,107

Re: How to adjust brightness, crunchbang 11

You might want to have a look at some grub parameters, like backlight=vendor or whatever. Not sure. You'll have to do some searches on that around the forums and google. Do your fn keys not work? i.e. windows key + f7 or something? Do some searches- 'debian + your computer model + screen brightness'. If you cant find anything then get back to us. Otherwise you can do it manually:

sudo apt-get install xbacklight

xbacklight - dec 10

http://linux.die.net/man/1/xbacklight

Tell us what your machine and its gubbins are:

lspci

Offline

#4 2013-01-24 16:49:40

ywang9
New Member
Registered: 2013-01-24
Posts: 5

Re: How to adjust brightness, crunchbang 11

Thanks. It's Lenovo T400, Fn + Home/End does not work, which is fine because I never expect it to work in Linux since Lenovo recommends Windows.

I tried the following two solutions:

Solution 1: (did not work)
1).    sudo gedit /etc/default/grub
2).    find the line starting with GRUB_CMDLINE_LINUX_DEFAULT
3).    add "acpi_osi=Linux acpi_backlight=vendor" to the options
4).    sudo update-grub
5).    reboot

Solution 2:
setpci -s 00:02.0 F4.B=FF

This works, but I have to run this command every time I boot the PC.

Offline

#5 2013-01-24 16:57:07

ywang9
New Member
Registered: 2013-01-24
Posts: 5

Re: How to adjust brightness, crunchbang 11

FYI, command 'xbacklight - inc 20 ' helped a little bit, but the screen is still not as bright as set by 'setpci -s 00:02.0 F4.B=FF'

In "Xfce Power Manager", the Level is 80% "On AC", but the screen is dim.

Offline

#6 2013-01-24 17:09:57

rkwurth
#! Junkie
Registered: 2012-09-04
Posts: 365

Re: How to adjust brightness, crunchbang 11

If xbacklight works, you can keybind xbacklight + & - # in your ~/.config/openbox/rc.xml and be done with it. The only considerations would be that decreasing too much will completely blank your screen, and you may not be able to use the default fn brightness keys. For your reference, I need a 3.x kernel for my machine to handle multimedia keys correctly- you may need the same. You've posted in Support (Stable), but say you're using Crunchbang 11, so I'm not sure which kernel you've got.

Offline

#7 2013-01-24 17:14:17

ywang9
New Member
Registered: 2013-01-24
Posts: 5

Re: How to adjust brightness, crunchbang 11

How to store the value somewhere? setpci -s 00:02.0 F4.B=FF'

and.

How hard it is to add a brightness progress bar in "power management", or some other related places, to give users stupid like me a little freedom. ???

Offline

#8 2013-01-26 12:17:26

Yannbane
Member
Registered: 2013-01-26
Posts: 13
Website

Re: How to adjust brightness, crunchbang 11

geany .config/openbox/autostart

I've added "xbacklight -set 70" at the end of that file because I wanted to reduce my monitor's brightness, and it worked perfectly.

I suggest you do something similar.

As far as I can tell, the power manager is from XFCE, and #! simply includes some XFCE components. I have noticed some weird behaviors with it as well because the settings for my power button simply don't work (thread).

Offline

#9 2013-01-26 17:42:47

GergoE
New Member
From: Budapest, Hungary
Registered: 2013-01-26
Posts: 4

Re: How to adjust brightness, crunchbang 11

ywang9 wrote:

Thanks. It's Lenovo T400, Fn + Home/End does not work, which is fine because I never expect it to work in Linux since Lenovo recommends Windows.

They surely do, but ThinkPads are built from rather standard components. Fn + Home/End works well under Waldorf on my SL400. So did it under the half dozen other Linux distros I've tried recently.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo