SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2012-11-16 10:39:21

hamed.asl
New Member
Registered: 2012-11-16
Posts: 9

funection key not work...

hi

i'm new to crunch bang and install it today in my laptop..

but my fn+f2 and fn+f3 not work to dcrease or increse the backlight  brightness smile (also controling volume is not work but it work with icon in the tray and no prob with this at all)

i'm install xbacklight and add "acpi_backlight=vendor" to grub and update that but after restart nothing changed and brightness control not work at all.

it work only with power manager...for example after 1 min it dim the display without problem..

my laptop is HP 4520s...


---------------------
also i want to know how install my vga (ati hd radeon 4350 mobility)



plz help me...thank u smile

Last edited by hamed.asl (2012-11-16 13:18:07)

Offline

Help fund CrunchBang, donate to the project!

#2 2012-11-16 10:44:24

el_koraco
#!/loony/bun
From: inside Ed
Registered: 2011-07-25
Posts: 4,749

Re: funection key not work...

It's not gonna work without the Gnome or KDE power (and likely settings) manager by default. It's a HP thing. You have to make keybindings in rc.xml with xbacklight. If you don't know how, post your .config/openbox/rc.xml to http://pastebin.com/

Offline

#3 2012-11-16 13:14:41

hamed.asl
New Member
Registered: 2012-11-16
Posts: 9

Re: funection key not work...

i also install gnome-power-manager but i dont know how open it and use it....
when type "gnome-power-manager" in terminal nothing happen...

also when type xbacklight on terminal it's says "No outputs have backlight property"

and i dont know about keybinding...here my rc.xml : http://pastebin.com/sz4f5cxB

my english is not very good plz explain simple...thank u very much

Last edited by hamed.asl (2012-11-16 13:17:03)

Offline

#4 2012-11-17 20:12:00

hamed.asl
New Member
Registered: 2012-11-16
Posts: 9

Re: funection key not work...

can any one help?

Offline

#5 2012-11-17 20:17:06

el_koraco
#!/loony/bun
From: inside Ed
Registered: 2011-07-25
Posts: 4,749

Re: funection key not work...

Sorry, didn't see this earlier. Can you post the output of

 lspci -knn

please?

Offline

#6 2012-11-18 14:36:17

hamed.asl
New Member
Registered: 2012-11-16
Posts: 9

Re: funection key not work...

hi..thank u for quick answer smile

it the output :

00:00.0 Host bridge [0600]: Intel Corporation Core Processor DRAM Controller [8086:0044] (rev 02)
	Subsystem: Hewlett-Packard Company Device [103c:1411]
00:01.0 PCI bridge [0604]: Intel Corporation Core Processor PCI Express x16 Root Port [8086:0045] (rev 02)
	Kernel driver in use: pcieport
00:16.0 Communication controller [0780]: Intel Corporation 5 Series/3400 Series Chipset HECI Controller [8086:3b64] (rev 06)
	Subsystem: Hewlett-Packard Company Device [103c:1411]
00:1a.0 USB Controller [0c03]: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller [8086:3b3c] (rev 05)
	Subsystem: Hewlett-Packard Company Device [103c:1411]
	Kernel driver in use: ehci_hcd
00:1b.0 Audio device [0403]: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio [8086:3b56] (rev 05)
	Subsystem: Hewlett-Packard Company Device [103c:1411]
	Kernel driver in use: HDA Intel
00:1c.0 PCI bridge [0604]: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 [8086:3b42] (rev 05)
	Kernel driver in use: pcieport
00:1c.1 PCI bridge [0604]: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 [8086:3b44] (rev 05)
	Kernel driver in use: pcieport
00:1c.3 PCI bridge [0604]: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 4 [8086:3b48] (rev 05)
	Kernel driver in use: pcieport
00:1c.5 PCI bridge [0604]: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 6 [8086:3b4c] (rev 05)
	Kernel driver in use: pcieport
00:1d.0 USB Controller [0c03]: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller [8086:3b34] (rev 05)
	Subsystem: Hewlett-Packard Company Device [103c:1411]
	Kernel driver in use: ehci_hcd
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev a5)
00:1f.0 ISA bridge [0601]: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller [8086:3b0b] (rev 05)
	Subsystem: Hewlett-Packard Company Device [103c:1411]
00:1f.2 SATA controller [0106]: Intel Corporation 5 Series/3400 Series Chipset 6 port SATA AHCI Controller [8086:3b2f] (rev 05)
	Subsystem: Hewlett-Packard Company Device [103c:1411]
	Kernel driver in use: ahci
00:1f.6 Signal processing controller [1180]: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem [8086:3b32] (rev 05)
	Subsystem: Hewlett-Packard Company Device [103c:1411]
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc M93 [Mobility Radeon HD 4500 Series] [1002:9555]
	Subsystem: Hewlett-Packard Company Device [103c:1411]
	Kernel driver in use: radeon
01:00.1 Audio device [0403]: ATI Technologies Inc RV710/730 [1002:aa38]
	Subsystem: Hewlett-Packard Company Device [103c:1411]
	Kernel driver in use: HDA Intel
44:00.0 Network controller [0280]: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
	Subsystem: Hewlett-Packard Company Device [103c:3040]
	Kernel driver in use: ath9k
45:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 03)
	Subsystem: Hewlett-Packard Company Device [103c:1411]
	Kernel driver in use: r8169
ff:00.0 Host bridge [0600]: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers [8086:2c62] (rev 02)
	Subsystem: Intel Corporation Device [8086:8086]
ff:00.1 Host bridge [0600]: Intel Corporation Core Processor QuickPath Architecture System Address Decoder [8086:2d01] (rev 02)
	Subsystem: Intel Corporation Device [8086:8086]
ff:02.0 Host bridge [0600]: Intel Corporation Core Processor QPI Link 0 [8086:2d10] (rev 02)
	Subsystem: Intel Corporation Device [8086:8086]
ff:02.1 Host bridge [0600]: Intel Corporation Core Processor QPI Physical 0 [8086:2d11] (rev 02)
	Subsystem: Intel Corporation Device [8086:8086]
ff:02.2 Host bridge [0600]: Intel Corporation Core Processor Reserved [8086:2d12] (rev 02)
	Subsystem: Intel Corporation Device [8086:8086]
ff:02.3 Host bridge [0600]: Intel Corporation Core Processor Reserved [8086:2d13] (rev 02)
	Subsystem: Intel Corporation Device [8086:8086]

Offline

#7 2012-11-18 15:51:23

el_koraco
#!/loony/bun
From: inside Ed
Registered: 2011-07-25
Posts: 4,749

Re: funection key not work...

Ok, try to edit the _file named /etc/default/grub, and add

acpi_backlight=vendor

to GRUB_CMDLINE_LINUX_DEFAULT ater "Quiet". Then run

sudo update-grub

and reboot. Anything change?

Offline

#8 2012-11-18 18:43:27

hamed.asl
New Member
Registered: 2012-11-16
Posts: 9

Re: funection key not work...

el_koraco wrote:

Ok, try to edit the _file named /etc/default/grub, and add

acpi_backlight=vendor

to GRUB_CMDLINE_LINUX_DEFAULT ater "Quiet". Then run

sudo update-grub

and reboot. Anything change?


i do that befor post an topic in this from...say that in first post...nothing changed after add "acpi_backlight=vendor" in Grub and reboot (also i update the grub)

Offline

#9 2012-11-18 19:18:55

el_koraco
#!/loony/bun
From: inside Ed
Registered: 2011-07-25
Posts: 4,749

Re: funection key not work...

Sorry, missed that one. Not to worry, we'll sort it out. Link: http://pastebin.com/RFMaFdsH

Now, first copy your current rc.xml, like this

cp .config/openbox/rc.xml .config/openbox/rcbak

Secondly, replace your rc.xml with the one I posted. Log out, log back in. Take note, I haven't used openbox for a while, so I might have screwed up the configuration a little. If openbox doesn't start, drop to a tty with Control Alt F1, log in, restore your original rc xml with

cp .config/openbox/rcbak .config/openbox/rc.xml 

and run

sudo service slim restart

It should work. If it doesn't report back and we'll look for other options.

Offline

#10 2012-11-18 19:53:41

hamed.asl
New Member
Registered: 2012-11-16
Posts: 9

Re: funection key not work...

i try new rc.xml but it's get me an error...i take a screenshot:

http://dl.dropbox.com/u/103839735/CB-error01.png

Offline

#11 2012-11-18 20:06:03

hamed.asl
New Member
Registered: 2012-11-16
Posts: 9

Re: funection key not work...

and when i try this code "sudo service slim restart" i get this "slim: unrecognized service"

Offline

#12 2012-11-18 20:19:43

el_koraco
#!/loony/bun
From: inside Ed
Registered: 2011-07-25
Posts: 4,749

Re: funection key not work...

Add the sign

at the very beginning of rc.xml

Log out and in.

Offline

#13 2012-11-19 19:46:20

hamed.asl
New Member
Registered: 2012-11-16
Posts: 9

Re: funection key not work...

Offline

#14 2012-11-19 19:59:58

el_koraco
#!/loony/bun
From: inside Ed
Registered: 2011-07-25
Posts: 4,749

Re: funection key not work...

Does your rc.xml end with this:

</openbox_config>

Offline

#15 2012-11-20 05:34:36

hamed.asl
New Member
Registered: 2012-11-16
Posts: 9

Re: funection key not work...

yes ..no problem with that

Offline

#16 2012-11-20 08:58:58

el_koraco
#!/loony/bun
From: inside Ed
Registered: 2011-07-25
Posts: 4,749

Re: funection key not work...

Paste your rc.xml to pastebin and link it please. Plus, are your function keys working? If not, can you adjust the volume via the command line lik this:

xbacklight -dec 10

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo