SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2012-10-31 03:15:59

acylus
New Member
Registered: 2012-10-31
Posts: 6

New to #! (and Linux in general), using 20120207 version

Hello, I'm new to Linux and I need some help with configuring the stuff in #!

  • Everytime I change the display settings with grandr, I log out and log back in and it resets to default (using dual monitors)

  • I'm trying to install wmfs but I have no idea how

  • Trying to change the x-www-browser default to /opt/firefox does not work, it gives me a "Permission error" and I don't know how to fix it

I've used Ubuntu and Mint so far but I haven't really learned much.

Last edited by acylus (2012-10-31 03:16:19)

Offline

Help fund CrunchBang, donate to the project!

#2 2012-10-31 04:31:41

stolid
#! CrunchBanger
Registered: 2012-09-06
Posts: 206

Re: New to #! (and Linux in general), using 20120207 version

acylus wrote:

Everytime I change the display settings with grandr, I log out and log back in and it resets to default (using dual monitors)

Will grandr save a script? You'll need to execute that script from your autostart file to apply the resolution on startup. Or, at least in my case since I'm using AMD video drivers, the graphics control panel applies my dual monitor resolution every time when I saved it from there. Nvidia and Intel may have something similar. I don't know.


Registered Linux User #555399
crunchbox:     Phenom II X6 1055T | 8GB RAM | OCZ Vertex 4 128GB | Radeon 7870XT | Win7 / #! 11 (i3 WM)
lambdacore:     4x Opteron 8431 | 16GB RAM | 2x1TB mirrored (ZFSoL) | Debian 7 (headless)
crunchtop:     Acer Aspire 1410 11.6" | 2GB RAM | Crucial M4 128GB | #! 11 (i3 WM)

Offline

#3 2012-11-01 05:59:43

acylus
New Member
Registered: 2012-10-31
Posts: 6

Re: New to #! (and Linux in general), using 20120207 version

Bump, it's legitimitely irritating. I got the xrandr settings down, but I still have no idea how to install WMFS nor do I have any idea on how to change my default browser to Nightly. I did it through x-www-browser on update-alternatives but when I launch it now it gives me "failed to execute child process (x-www-browser). Permission Denied".

I do not know what I am doing wrong.

Offline

#4 2012-11-01 07:08:03

ivanovnegro
Ivan #000000
From: unstable madness
Registered: 2011-06-02
Posts: 5,420

Re: New to #! (and Linux in general), using 20120207 version

acylus wrote:

[*]Trying to change the x-www-browser default to /opt/firefox does not work, it gives me a "Permission error" and I don't know how to fix it[/*]

Forget that /opt thing. This is my way if you like it:

Download the newest version from Firefox from their official homepage for your system and language. Unpack it into your homefolder.
Basically that is all, you can now start the Firefox executable.

To make Firefox or FF Nightly also the default browser and use it for everything instead of other things we sure use
the update-alternatives from Debian to do that.

sudo update-alternatives --install  /usr/bin/x-www-browser x-www-browser /home/youruser/firefox/firefox 100   

That's all.

Assure it is the default if you have other browsers installed, also remove Iceweasel before you proceed just in case. And put your user name in youruser:

sudo update-alternatives --config x-www-browser 

Maybe you have to give it a higher priority, instead of 100, choose 200 or whatever from the above first step.

Enjoy the Nightly and do not get tired by the updates. wink

Offline

#5 2012-11-01 07:46:13

machinebacon
#! unstable
Registered: 2009-07-02
Posts: 6,586

Re: New to #! (and Linux in general), using 20120207 version

1) set your display, run

xrandr

search for the asterisk (*), it looks for example like this

   1600x1200      60.0  
   1280x1024      60.0* 
   1024x768       85.0     75.1     70.1     60.0  
   800x600        85.1     72.2     75.0     60.3  
   640x480        85.0     72.8     75.0     60.0 

then right click the desktop -> Settings -> Openbox -> Autostart
add this line somewhere:

xrandr -s 1280x1024 -r 60 &

replacing the values with those your xrandr has spit out

2) WMFS? AFAIK not in the repos, so roll your own: http://wmfs.info/  Edit: Why bother, there are ~40 WMs in the repos.

3) what BlackIvanovic said wink

Last edited by machinebacon (2012-11-01 07:47:13)

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo