SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2012-10-19 15:32:07

wetdirtmud
New Member
Registered: 2012-10-19
Posts: 3

Theme Issues

Here's a screenshot
http://i.imgur.com/JHGD9.png

Here's the theme
http://browse.deviantart.com/customizat … 9#/d59dyyh

If  you notice on the screenshot the File Explorer in particular looks very weird, there's a lot of white text where there shouldn't be and things seem off.

If anyone has an idea why, it would be greatly appreciated. Thanks!


Edit: here's what it looks like with a different theme: http://i.imgur.com/j4Ypu.png

Last edited by wetdirtmud (2012-10-19 15:35:11)

Offline

Help fund CrunchBang, donate to the project!

#2 2012-10-19 15:59:48

machinebacon
#! unstable
From: China
Registered: 2009-07-02
Posts: 6,620
Website

Re: Theme Issues

Hello there,

I guess (!) it has to do with the fact that you use a gtk3 theme, it says you need Adwaita:

sudo apt-get install gnome-themes-standard
sudo apt-get install gtk3-engines-unico

(the latter is a wild guess, but there are only two gtk3 engines in the repos, the other one being Oxygen)

This should fix it, hopefully smile

Last edited by machinebacon (2012-10-19 16:02:29)

Offline

#3 2012-10-19 16:01:35

VastOne
#! Ranger
From: #! Fringe Division
Registered: 2011-04-26
Posts: 10,163
Website

Re: Theme Issues

^^ I loaded the black and white and it worked fine in Xfce, I am going to boot to OB now to test it and let you know

I see MasterBacon is on it... greets mate!

Last edited by VastOne (2012-10-19 16:02:19)


VSIDO | SolusOS

Words That Build Or Destroy

Offline

#4 2012-10-19 16:03:37

machinebacon
#! unstable
From: China
Registered: 2009-07-02
Posts: 6,620
Website

Re: Theme Issues

Greets Vastony! In XFCE4 they work when you have the xfce4(?)-themes installed (those with greybird, bluebird, shearwater and albatross)

Offline

#5 2012-10-19 16:09:03

VastOne
#! Ranger
From: #! Fringe Division
Registered: 2011-04-26
Posts: 10,163
Website

Re: Theme Issues

^ Worked fine too in OB same machine, same setup...

I do not have gnome-themes-standard loaded... and you are correct, Xfce4 has it's own them engine that does work with OB


VSIDO | SolusOS

Words That Build Or Destroy

Offline

#6 2012-10-19 16:10:09

wetdirtmud
New Member
Registered: 2012-10-19
Posts: 3

Re: Theme Issues

Thanks for the responses!

Unfortunately I've already installed both of those packages and I'm still having the same issue. Perhaps I'm applying the theme improperly?

I've got the following file structure for the theme:

 ~/.themes/BlackWhite/gtk-3.0

also

 ~/.themes/BlackWhite/gtk-2.0

I've got the Albatross theme currently installed, that one works fine.

I'm applying my themes using 'LXAppearance 0.5.1'

Offline

#7 2012-10-19 16:12:14

machinebacon
#! unstable
From: China
Registered: 2009-07-02
Posts: 6,620
Website

Re: Theme Issues

@wetdirtmud: That's the proper way, lxappearance, yes. Did you install other custom themes maybe before?

@VastOne: Off-topic: Am I blind or does wetdirtmud have two posts and only one is shown in his counter?

4naFB.png haha, a BUG smile

Last edited by machinebacon (2012-10-19 16:13:29)

Offline

#8 2012-10-19 16:12:30

VastOne
#! Ranger
From: #! Fringe Division
Registered: 2011-04-26
Posts: 10,163
Website

Re: Theme Issues

^ Do you have a rogue .gtk2rc file in /home/your user that could be affecting it?  I have seen themes altered this way when there was a file like that in use.


VSIDO | SolusOS

Words That Build Or Destroy

Offline

#9 2012-10-19 16:13:27

VastOne
#! Ranger
From: #! Fringe Division
Registered: 2011-04-26
Posts: 10,163
Website

Re: Theme Issues

machinebacon wrote:

@VastOne: Off-topic: Am I blind or does wetdirtmud have two posts and only one is shown in his counter?

One of those timing issues that you and I seem to have in common, I would suspect... big_smile


VSIDO | SolusOS

Words That Build Or Destroy

Offline

#10 2012-10-19 16:15:27

machinebacon
#! unstable
From: China
Registered: 2009-07-02
Posts: 6,620
Website

Re: Theme Issues

Issues? This is TALENT big_smile

But good call on the gtkrc file!

Offline

#11 2012-11-20 22:50:13

ohnonot
#! Die Hard
Registered: 2012-05-22
Posts: 1,008
Website

Re: Theme Issues

@OP
fwiw - the screeshot looks like what gtk comes up with when it can't find the theme specified or when the theme is faulty and gtk can't read it.
so, apart from a typo somewhere it could also be that you extracted the folder to the right place and applied it with lxappearance, but the gtkrc files have wrong permissions set. has happened to me, swear to god!
of course it could be 10 other things; but i recognize the distinctive non-look.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo