SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#26 2009-10-06 08:19:12

Mufasa
Member
Registered: 2009-10-04
Posts: 20

Re: Using Nautilus under Openbox

corenominal wrote:

Thanks! Ok this solves the problem that it opened new folders in a seperate window.
But it is still like a "castrated nautilus" without sidebar or any toolbar.....

I want the look like
linux_nautilus.jpg



Do you have this normal look??

Offline

Be excellent to each other!

#27 2010-09-23 20:40:41

vsbladz
Member
Registered: 2010-09-16
Posts: 27

Re: Using Nautilus under Openbox

Can I uninstall "nautilus" altogether?

Offline

#28 2011-05-03 20:17:59

db_crunch
#! Member
From: Your Hard-Disk
Registered: 2011-04-12
Posts: 68
Website

Re: Using Nautilus under Openbox

I found a way to stop nautilus taking control of the desktop altogether. I like the new XFCE4 desktop but I was missing the features of 9.04 and I like some of my Gnome apps.. So I was content to remove XFCE4 from OpenBox in it's entirety to return back to having a Gnomed System.

The easiest way I found for stopping Nautilus from taking control of your desktop was by following this thread with one exception, I used gconf-editor available in the repositories to apply the following

# Disable Nautilus desktop.
/apps/nautilus/preferences/show_desktop false &
# Do not let Nautilus set the background image.
/desktop/gnome/background/draw_background false &
# Make Nautilus use spatial mode, should start-up quicker.
/apps/nautilus/preferences/always_use_browser false &
# Make Nautilus show the advanced permissions dialog
/apps/nautilus/preferences/show_advanced_permissions true &

By launching the gconf-editor as root by doing a sudo su or sudo -i you can apply the fixes above by navigating to each of there respective properties in the gconf-editor and then untick (false) out the ones you want, once you exit the editor and then launch nautilus as root, you'll notice no desktop change. Thereby making cb-bad-nautilus redundant wink You have to apply it to both the root version of gconf-editor and the non-root account of the home user for it to take effect in both enviroments. hth.

.. now silently pondering if I should apply wbar or docky to add a quick launch panel above or to the left of lxpanel..

..settled on adeskbar, its small and light enough to play with OB nicely, blended in to top-left..

Who says you cant have icons on your OpenBox Desktop!? big_smile

http://030.img98.net/out.php/i294284_20 … 3933373532

Last edited by db_crunch (2011-05-04 07:23:03)


~My mind works like lightning. One brilliant flash and it's gone.

Offline

#29 2012-01-19 10:01:18

stevepoppers
Member
From: America. Studying in Japan.
Registered: 2010-06-14
Posts: 31

Re: Using Nautilus under Openbox

If I may jump in here and ask a question...

Edit: As I see below, it might be worth mentioning I'm actually using Ubuntu 11.04 with Openbox this time. I come here because you seem to be the only one with advice on this, and because I got my start with minimalistic Linux on Crunchbang.

Using the suggested settings causes my desktop to go black when I log into openbox after feh does it's thing. Does anybody know why?

# Disable Nautilus desktop.
gconftool-2 -s -t bool /apps/nautilus/preferences/show_desktop false &
# Do not let Nautilus set the background image.
gconftool-2 -s -t bool /desktop/gnome/background/draw_background false &

Leaving the first set to true prevents this, but when I actually run nautilus, the background goes to black and the takeover happens.

Also, what's the most sensible way to set the reverse for Gnome sessions?

Last edited by stevepoppers (2012-01-20 17:42:33)

Offline

#30 2012-01-19 14:48:19

dbvolvox
#! CrunchBanger
From: England
Registered: 2011-01-05
Posts: 157

Re: Using Nautilus under Openbox

This thread confused me. I have always used Nautilus because I need to browse Windows shares and have never had any trouble. So I checked the autostart.sh on my laptop (2010 install) and it already has the lines advised by Corenominal. I checked an install I did last week and in that autostart.sh is a call to cb-bad-nautilus which contains the required lines.

So it seems that us new bugs that haven't messed with autostart.sh don't need to worry?

Offline

#31 2012-01-20 18:01:41

Unia
#! Octo-portal-pussy
From: The Netherlands
Registered: 2010-07-17
Posts: 4,010

Re: Using Nautilus under Openbox

stevepoppers wrote:

Using the suggested settings causes my desktop to go black when I log into openbox after feh does it's thing. Does anybody know why?

# Disable Nautilus desktop.
gconftool-2 -s -t bool /apps/nautilus/preferences/show_desktop false &
# Do not let Nautilus set the background image.
gconftool-2 -s -t bool /desktop/gnome/background/draw_background false &

Leaving the first set to true prevents this, but when I actually run nautilus, the background goes to black and the takeover happens.

That's probably because of an update in the GNOME backend. I don't know for sure but I think Nautilus is using dconf now, instead of gconf. All I can help you with is that once Nautilus starts running (without changing the default settings), it draws the background. No program will override this, and AFAIK not even killing Nautilus itself will. You will have to find the setting of Nautilus to disable this. I think it's now called "Manage Desktop" or "Draw Desktop", something like that. Apologies for not being more precise, but I can't check it because I don't run Linux anymore.

dbvolvox wrote:

So it seems that us new bugs that haven't messed with autostart.sh don't need to worry?

If it works, you don't have to worry tongue

Last edited by Unia (2012-01-20 18:02:33)


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres
Github

I am a #! forum moderator. Feel free to send me a PM with any question you have!

Offline

#32 2012-01-20 20:19:47

stevepoppers
Member
From: America. Studying in Japan.
Registered: 2010-06-14
Posts: 31

Re: Using Nautilus under Openbox

Unia wrote:

That's probably because of an update in the GNOME backend. I don't know for sure but I think Nautilus is using dconf now, instead of gconf. All I can help you with is that once Nautilus starts running (without changing the default settings), it draws the background. No program will override this, and AFAIK not even killing Nautilus itself will. You will have to find the setting of Nautilus to disable this. I think it's now called "Manage Desktop" or "Draw Desktop", something like that. Apologies for not being more precise, but I can't check it because I don't run Linux anymore.

The Crunchbang autostart file, which I found here (http://crunchbanglinux.org/forums/topic … tostartsh/) contains the following:

## Bad Nautilus, minimises the impact of running Nautilus under
## an Openbox session by applying some gconf settings. Safe to delete.
cb-bad-nautilus &

But Google turns up nothing on this command. I assume it's Crunchbang-specific. I guess the config commands I want are in there. But I dun has sad

Could anyone take a look at that file and maybe share it?

Oh, and I don't think it's a gconf/dconf problem. The commands I posted get changed, and I use gconf-editor to change them manually.

Thank you...

Offline

#33 2012-01-20 21:09:16

Unia
#! Octo-portal-pussy
From: The Netherlands
Registered: 2010-07-17
Posts: 4,010

Re: Using Nautilus under Openbox

You can find the cb-bad-nautilus somewhere in /usr/bin or /usr/share/bin or something like that tongue Again sorry for being so vague


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres
Github

I am a #! forum moderator. Feel free to send me a PM with any question you have!

Offline

#34 2012-01-21 06:50:14

stevepoppers
Member
From: America. Studying in Japan.
Registered: 2010-06-14
Posts: 31

Re: Using Nautilus under Openbox

No, I'm sorry, I don't think you've noticed my edit.

I'm not running crunchbang. Ubuntu 11.04 w/openbox. I don't have that file on my system.

Offline

#35 2012-01-21 10:30:50

EnochRoot
#! Junkie
From: London, UK
Registered: 2011-10-15
Posts: 282
Website

Re: Using Nautilus under Openbox

Here you go

#!/bin/bash
# cb-bad-nautilus
# CrunchBang Linux ships with Openbox and Xfce sessions,
# Nautilus can be troublesome for both of these sessions and
# this script helps to prevent those troubles.
# Written for CrunchBang Linux <http://crunchbanglinux.org/>
# by Philip Newborough (aka corenominal) <corenominal@corenominal.org>
if [ -e "/home/$USER/.config/crunchbang/cb-bad-nautilus" ]; then
    exit 0
else
    gconftool-2 -s -t bool /apps/nautilus/preferences/show_desktop false
    gconftool-2 -s -t bool /desktop/gnome/background/draw_background false
    gconftool-2 -s -t bool /apps/nautilus/preferences/show_advanced_permissions true
    if [ ! -d "/home/$USER/.config/crunchbang" ]; then
        mkdir /home/$USER/.config/crunchbang
    fi
    if [ ! -f "/home/$USER/.config/crunchbang/cb-bad-nautilus" ]; then
        touch /home/$USER/.config/crunchbang/cb-bad-nautilus
    fi
fi
exit 0

Offline

#36 2012-01-21 11:07:49

stevepoppers
Member
From: America. Studying in Japan.
Registered: 2010-06-14
Posts: 31

Re: Using Nautilus under Openbox

EnochRoot wrote:

Here you go

Ah, thank you. Unfortunately, that doesn't seem to do anything different, does it? Nautilus is still blacking out my background despite definitely being set to not do so.

Offline

#37 2012-01-21 15:23:11

saneks
#! Die Hard
Registered: 2009-10-01
Posts: 999

Re: Using Nautilus under Openbox

maybe pursue your quest on the ubuntu forums? I have no problems with nautilus taking over the desktop. but I use crunchbang. maybe give it a try?


eee701 user & other lap/desktops

Offline

#38 2012-06-08 23:38:49

Tropcon
New Member
Registered: 2012-06-08
Posts: 1

Re: Using Nautilus under Openbox

Hello, all.

This forum thread has been a real lifesaver for me, so I thought I'd give something back.

My setup:

Clean install of Ubuntu 12.04, installed Gnome-Shell for normal use, then installed Openbox for dual-screen presentation.

The Problem:
The gconf commands given in the first post of this thread no longer work. When Nautilus is started, it still takes over the desktop.

The Solution:
As I understand it, "in Gnome 3, Gconf is being replaced by DConf, which is accessed through GSettings." - quote from http://askubuntu.com/questions/87829/ho … -via-gconf
From the information I aquired from the link above, I was able to craft the following commands:

gsettings set org.gnome.desktop.background draw-background false

and

gsettings set org.gnome.desktop.background show-desktop-icons false

These commands can be added to openbox's autostart file and should prevent a Gnome 3 nautilus desktop takeover.

The Short and Sweet:
If you have Gnome 3, add the following lines to autostart file to prevent nautilus from taking over your openbox desktop:

# Disable Nautilus desktop.
gsettings set org.gnome.desktop.background draw-background false &
# Do not let Nautilus set the background image.
gsettings set org.gnome.desktop.background show-desktop-icons false &

Now I just need to fugure out how to reverse this when starting Gnome-Shell. smile

Have a nice day,
        Tropcon

Offline

#39 2012-06-09 00:34:20

omns
#! wanderer
From: ~/
Registered: 2008-11-25
Posts: 5,131

Re: Using Nautilus under Openbox

Tropcon wrote:

Now I just need to fugure out how to reverse this when starting Gnome-Shell. smile

That script shouldn't autorun when logging into a gnome-shell session as it only effects Openbox

Offline

#40 2012-10-01 05:19:36

bennisixx
#! CrunchBanger
From: the woods arkansas
Registered: 2011-11-10
Posts: 127
Website

Re: Using Nautilus under Openbox

thank you for the gsettings method, it also works on the nautilus fork nemo wink perfect, as Im running openbox,mate,and cinnamon. I needed it for nemo-connect-server (or nautilus-connect-servet) so I could manage ssh and webdav easy in a file manager

thanks again

Offline

#41 2012-12-16 01:37:03

thomassisson
New Member
From: Indianapolis, Indiana, USA
Registered: 2012-12-15
Posts: 5
Website

Re: Using Nautilus under Openbox

david wrote:

----

I should add! using dropbox with openbox is quite easy even though i do like nautilus it can be slow so if i use, say, thunar, i will install dropbox like this:

http://wiki.getdropbox.com/TipsAndTrick … nuxInstall

The updated URL as of 2012.12.15 is http://www.dropboxwiki.com/Almost_Text- … ux_Install.

Is it possible to place this as a threaded reply to the original post that I quoted?

Offline

#42 2012-12-16 02:49:06

VastOne
#! Ranger
From: V-Ger
Registered: 2011-04-26
Posts: 10,163
Website

Re: Using Nautilus under Openbox

^ Since the original post is over three years old, I would start a new thread and reference this post with your new information.

That is what we ask instead of necroposting.

Thanks!


VSIDO | Words That Build Or Destroy

We do not run from challenges, they become new innovations within VSIDO!

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo