SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#26 2011-12-22 18:16:37

Tunafish
#! Die Hard
From: the Netherlands
Registered: 2010-03-07
Posts: 1,204

Re: [SOLVED] bash: command not found

Sector11 wrote:

@ johnraff

HUSTON WE HAVE A PROBLEM!!

big_smile big_smile big_smile


Glad i'm not the only one!


I'm using lightdm as login manager..


sed 's/stress/relaxation/g'
Privacy & Security on #!

Offline

Help fund CrunchBang, donate to the project!

#27 2011-12-22 18:18:22

Sector11
77345 ¡#
From: SR11 Cockpit
Registered: 2010-05-05
Posts: 11,994
Website

Re: [SOLVED] bash: command not found

Tunafish wrote:
Sector11 wrote:

@ johnraff

HUSTON WE HAVE A PROBLEM!!

big_smile big_smile big_smile


Glad i'm not the only one!

I'm using lightdm as login manager..

Yup, me too; lightdm.
It's always nice when you have company.  big_smile

Last edited by Sector11 (2011-12-22 18:18:46)


To #! or not to #!?  That is the question! | #! Forum Moderator
#! Conky = 16 Threads & the Conky Archives | Conky PitStop | OTHCG'er
StartPage -  protect your privacy   |   LinuxBBQ

Online

#28 2011-12-22 18:24:10

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: [SOLVED] bash: command not found

Offline

#29 2011-12-22 18:28:45

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: [SOLVED] bash: command not found

To see the value of the PATH variable when it executes your openbox autostart.sh, add this command to the autostart.sh

(echo $PATH > /tmp/path) &
openbox --reconfigure

and verify the content of /tmp/path

It works in a terminal because your .bashrc is sourced as part of the terminal startup.

Offline

#30 2011-12-22 18:45:29

VastOne
#! Ranger
From: V-Ger
Registered: 2011-04-26
Posts: 10,163
Website

Re: [SOLVED] bash: command not found

On the new Point Release, I had these issues as well..

Also noticed things like ifconfig no longer works because /sbin is no longer in the path

Query ... When you do a

export PATH=$PATH:/sbin

Does this permanently add /sbin or just for this session?


VSIDO | Words That Build Or Destroy

We do not run from challenges, they become new innovations within VSIDO!

Offline

#31 2011-12-22 18:48:41

Tunafish
#! Die Hard
From: the Netherlands
Registered: 2010-03-07
Posts: 1,204

Re: [SOLVED] bash: command not found

xaos52 wrote:

To see the value of the PATH variable when it executes your openbox autostart.sh, add this command to the autostart.sh

(echo $PATH > /tmp/path) &
openbox --reconfigure

and verify the content of /tmp/path

It works in a terminal because your .bashrc is sourced as part of the terminal startup.

cat /tmp/path:

/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games

Thanks for the explanation... it's a bug... what should i do now?
Add   export PATH=$PATH:$HOME/bin     to ~/.config/openbox/autostart?
Or would it be better to source $HOME/.profile from .xsession (before openbox-session is started) ?

Last edited by Tunafish (2011-12-22 18:56:53)


sed 's/stress/relaxation/g'
Privacy & Security on #!

Offline

#32 2011-12-22 18:50:25

VastOne
#! Ranger
From: V-Ger
Registered: 2011-04-26
Posts: 10,163
Website

Re: [SOLVED] bash: command not found

^ I add it to .bashrc

PATH=$PATH:$HOME/bin:/sbin


VSIDO | Words That Build Or Destroy

We do not run from challenges, they become new innovations within VSIDO!

Offline

#33 2011-12-22 18:56:10

Tunafish
#! Die Hard
From: the Netherlands
Registered: 2010-03-07
Posts: 1,204

Re: [SOLVED] bash: command not found

VastOne wrote:

^ I add it to .bashrc

PATH=$PATH:$HOME/bin:/sbin

Eh VastOne, that's what it's all about here.... that doesn't work hmm
At least not for everything... just when you open a terminal...

Last edited by Tunafish (2011-12-22 18:58:13)


sed 's/stress/relaxation/g'
Privacy & Security on #!

Offline

#34 2011-12-22 18:57:08

VastOne
#! Ranger
From: V-Ger
Registered: 2011-04-26
Posts: 10,163
Website

Re: [SOLVED] bash: command not found

Tunafish wrote:
VastOne wrote:

^ I add it to .bashrc

PATH=$PATH:$HOME/bin:/sbin

Eh VastOne, that's what it's all about here.... that doesn't work hmm

Just noticed that Tuna

Sorry for my gaffe...


VSIDO | Words That Build Or Destroy

We do not run from challenges, they become new innovations within VSIDO!

Offline

#35 2011-12-22 19:20:00

EnochRoot
#! Junkie
From: London, UK
Registered: 2011-10-15
Posts: 279
Website

Re: [SOLVED] bash: command not found

Adding it to your .bashrc will mean it is picked up when you run a terminal which will start a shell for you, likewise doing export PATH=$PATH:~/bin will add it only for that instance of the shell. Best solution is to put the full pathname into rc.xml, so call /home/username/bin/kfc.sh rather than kfc.sh

Other entries in rc.xml are working because the executables (scripts/binaries) are in your default path (usr/bin, usr/local/bin etc).

I used to have env vars etc in my .bash_profile and aliases / functions etc in my .bashrc but this meant having to ensure my xterms were started as a login session, in my view its easier to just run them as normal shells and have everything in the .bashrc but like so many things in Linux there are multiple ways of doing it

Offline

#36 2011-12-22 19:20:51

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: [SOLVED] bash: command not found

Let me install lightdm and see how it works.
Will come back with an answer.

Offline

#37 2011-12-22 19:32:11

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: [SOLVED] bash: command not found

Where did you guys get lightdm from?
You upgraded to testing or unstable?

Offline

#38 2011-12-22 19:35:46

VastOne
#! Ranger
From: V-Ger
Registered: 2011-04-26
Posts: 10,163
Website

Re: [SOLVED] bash: command not found

^ Correct... it is not in Stable .. you would need to grab the source


VSIDO | Words That Build Or Destroy

We do not run from challenges, they become new innovations within VSIDO!

Offline

#39 2011-12-23 08:56:29

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: [SOLVED] bash: command not found

I think this is the easiest solution:

Create $HOME/.xsession

with this content

#!/bin/sh

if [ -e $HOME/.profile ]; then
    . $HOME/.profile
fi

exec openbox-session

This works for me. YMMV.

Offline

#40 2011-12-23 09:23:55

Tunafish
#! Die Hard
From: the Netherlands
Registered: 2010-03-07
Posts: 1,204

Re: [SOLVED] bash: command not found

xaos52 wrote:

I think this is the easiest solution:

Create $HOME/.xsession

with this content

#!/bin/sh

if [ -e $HOME/.profile ]; then
    . $HOME/.profile
fi

exec openbox-session

This works for me. YMMV.

Thanks... works for me as well.
Tuna


sed 's/stress/relaxation/g'
Privacy & Security on #!

Offline

#41 2011-12-23 11:39:56

chaanakya
#! Die Hard
Registered: 2010-12-30
Posts: 940

Re: [SOLVED] bash: command not found

Or you could

source ~/.bashrc

in autostart.sh


Check out Musik - an easy-to-use text-to-music converter!
Join SpiderOak using this link and get an extra 1 GB free: https://spideroak.com/download/referral … 660e787ff1

Offline

#42 2011-12-23 14:31:57

Sector11
77345 ¡#
From: SR11 Cockpit
Registered: 2010-05-05
Posts: 11,994
Website

Re: [SOLVED] bash: command not found

xaos52 wrote:

Shame on you lightDM
grumble grumble GRRRRRRRRRRRRRRRRRRRRRRRRRR
OK they will fix it ... right!
OK they will fix it ... right!
OK they will fix it ... right!
OK they will fix it ... right! roll

works OK here too!  +2 (first post)

Last edited by Sector11 (2011-12-23 14:42:24)


To #! or not to #!?  That is the question! | #! Forum Moderator
#! Conky = 16 Threads & the Conky Archives | Conky PitStop | OTHCG'er
StartPage -  protect your privacy   |   LinuxBBQ

Online

#43 2011-12-23 17:01:30

johnraff
#!Drunkard
From: Nagoya, Japan
Registered: 2009-01-07
Posts: 2,927
Website

Re: [SOLVED] bash: command not found

chaanakya wrote:

Or you could

source ~/.bashrc

in autostart.sh

The stuff in .bashrc is intended for working in terminals. I don't think you'd want/need it in an x-session. (Anyway, .bashrc just returns if it doesn't find a terminal.)

xaos52's does sound like the easiest solution, though I wonder what the Approved Debian Way of setting personal environment variables would now be?

Last edited by johnraff (2011-12-23 17:42:00)


John
--------------------
( a boring Japan blog , idle twitterings  and GitStuff )
#! forum moderator

Offline

#44 2011-12-23 17:19:49

Awebb
The Singularity
Registered: 2009-07-23
Posts: 2,812

Re: [SOLVED] bash: command not found

I'd be patient with lightdm. They have plans and those plans will take time. If I understood the goals right, they try to provide a DM platform, instead of having 1000 different implementations with more or less minor differences. Ubuntu using lightdm might push it a little, I hope not in the wrong direction.


I'm so meta, even this acronym

Offline

#45 2011-12-23 17:40:42

johnraff
#!Drunkard
From: Nagoya, Japan
Registered: 2009-01-07
Posts: 2,927
Website

Re: [SOLVED] bash: command not found

...you could try creating ~/.xsessionrc , putting the PATH command in there and seeing if it gets executed? If it works, that might be the official substitute for .profile?


John
--------------------
( a boring Japan blog , idle twitterings  and GitStuff )
#! forum moderator

Offline

#46 2012-03-05 10:38:02

jelloir
#! CrunchBanger
From: Outside the garden wall
Registered: 2009-08-21
Posts: 212

Re: [SOLVED] bash: command not found

Debian are not going to fix this for lightdm (refer to the Debian bug link xaos52 posted) so unless the upstream lightdm dev's change it then you will have to manually ensure ~/.profile or ~/.bash_profile are sourced.

I would suggest the best way to do this is per a response in that bug report.  Simply source ~/.profile using ~/.xsessionrc then you still only need to make changes to ~/.profile.

So in ~/.xsessionrc simply insert

. /etc/profile
. ${HOME}/.profile

(or ${HOME}/.bash_profile if you are using that)

And be done with it.

Last edited by jelloir (2012-03-05 10:41:18)

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo