SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2008-12-09 18:01:01

Tosick
#! CrunchBanger
From: Sweden
Registered: 2008-12-08
Posts: 184

view LAN

I like to see the NAS and shared folders from the other PCs in the LAN.
In this link, (that I found here in this forum,)it tells how to view (share) a folder  in your PC on the LAN.
http://crunchbanglinux.org/forums/post/1170/#p1170
Perhaps pyNeighborhood is the best way, but I didn.t mangage to configure it.

A GTK+ application that allows you to browse network shares
pyNeighborhood is GTK+ 2 rewrite of a well-known GTK+ 1 tool
LinNeighborhood.

pyNeighborhood allows users to browse SMB (e.g. Windows Network Neighborhood)
networks under X, and mount/unmount SMB shared filesystems via a graphical
interface.

In order for pyNeighborhood to work properly,  you must have the
smbfs filesystem compiled into your kernel and have a working Samba
setup.

Is it possible?

Offline

Be excellent to each other!

#2 2008-12-10 09:19:21

Tosick
#! CrunchBanger
From: Sweden
Registered: 2008-12-08
Posts: 184

Re: view LAN

Was it that hard?

Id got some instructions from the Ubuntu forum of how to do it manualy.
ie static IP adresses  and writting instructions in some files.
Yes that should work. But its hard if there is several PCs in the house
and ........yes think you know.

Offline

#3 2008-12-10 17:11:41

EYo
Member
From: Sonoma County, California
Registered: 2008-12-10
Posts: 11
Website

Re: view LAN

smbfs seems broken in 8.10.  So instead I use smbnetfs and mount to my home directory like this:

sudo apt-get install smbnetfs
mkdir ~/.smb
cp -v /etc/samba/smb.conf ~/.smb/
cp -v /etc/smbnetfs.conf ~/.smb/
mkdir ~/network
smbnetfs ~/network

I can browse the shares on my NSLU2 through the ~/network directory.

To unmount:

fusermount -u ~/network/

Edit: fixed ~/.smb paths.  Thanks razienwolf.

Last edited by EYo (2008-12-11 03:55:29)

Offline

#4 2008-12-10 18:09:25

Tosick
#! CrunchBanger
From: Sweden
Registered: 2008-12-08
Posts: 184

Re: view LAN

Yes, thanks!
..............Samba,...that is something that I have to install first?
Looking at Package Mangager in the !#-lite, and here Samba is not installed.

Offline

#5 2008-12-10 18:35:43

Tosick
#! CrunchBanger
From: Sweden
Registered: 2008-12-08
Posts: 184

Re: view LAN

I tryed it on the P2-PC after all,as I was sitting there.

I had to repit "your commads" three times. Before the last thing was "done".
But then my NAS and other thing showed up nicely.


There was an error message at the end.
Is it something that should takn care of?

cl@cl:~$ mkdir ~/network
cl@cl:~$ smbnetfs ~/network
WARNING!!! Configuration directory ~/.smb is not found. Please create it.
This directory should contain at least two files: smb.conf and smbnetfs.conf.
You may copy smb.conf from the /etc/samba directory. You can find a sample of
smbnetfs.conf in the /etc directory.

Using default settings for now.
cl@cl:~$

Offline

#6 2008-12-10 18:43:28

EYo
Member
From: Sonoma County, California
Registered: 2008-12-10
Posts: 11
Website

Re: view LAN

I have samba-common and smbclient installed.

Configured  two custom actions in Thunar, so I can right-click to mount/umount :

Name: Mount SMB network
Command: smbnetfs ~/network

Name: Unmount SMB network
Command: fusermount -u ~/network

Seems to be working okay.  There's probably a more elegant way to do it, but I'm just getting in to this crunchiness and sort of muddling my way around.

Offline

#7 2008-12-10 18:53:00

EYo
Member
From: Sonoma County, California
Registered: 2008-12-10
Posts: 11
Website

Re: view LAN

Tosick wrote:

There was an error message at the end.
Is it something that should takn care of?

cl@cl:~$ mkdir ~/network
cl@cl:~$ smbnetfs ~/network
WARNING!!! Configuration directory ~/.smb is not found. Please create it.
This directory should contain at least two files: smb.conf and smbnetfs.conf.
You may copy smb.conf from the /etc/samba directory. You can find a sample of
smbnetfs.conf in the /etc directory.

Make the ~.smb directory (that's /home/$username/.smb <- don't forget the dot) and copy the smb.conf and smbnetfs.conf to it.
It takes a few seconds for the share to appear mounted on my system.

Offline

#8 2008-12-10 19:01:36

Tosick
#! CrunchBanger
From: Sweden
Registered: 2008-12-08
Posts: 184

Re: view LAN

So I made the same Commands in the AMD64x2-PC with "!#" (not -lite) and got the same message.
I double check the function of the PC and the two NAS showed up fine.
But here on the far more powerfull PC, things did not work 100%.
After while the LAN connection disapered.
Before that I could just see the Maxtor and not the D-link DNS323.

Any idee?

Offline

#9 2008-12-10 19:20:09

Tosick
#! CrunchBanger
From: Sweden
Registered: 2008-12-08
Posts: 184

Re: view LAN

I can browse the shares on my NSLU2 through the ~/network directory.

Sorry I did not understand NSLU2.

I repited to procesdure one more time on the AMD, and the DNS323 is still not willing to open??

And after 1-2 minutes everything i gone.

Last edited by Tosick (2008-12-10 19:23:39)

Offline

#10 2008-12-10 19:26:29

razienwolf
#! CrunchBanger
From: SP, Brasil
Registered: 2008-12-01
Posts: 115

Re: view LAN

So, how does this work?
Im getting errors with fusesmb and wouldn't mind trying something new.

Can I navigate on folders just like on windows or fusesmb?

Offline

#11 2008-12-10 19:32:03

Tosick
#! CrunchBanger
From: Sweden
Registered: 2008-12-08
Posts: 184

Re: view LAN

Name: Mount SMB network
Command: smbnetfs ~/network

Name: Unmount SMB network
Command: fusermount -u ~/network

smbnetfs ~/network  that is the one.......
and there is an "~/.smb
I am doing the command twice, as I wanted to sure about the ~/.smb

hc@hc:~$ smbnetfs ~/network
WARNING!!! Configuration directory ~/.smb is not found. Please create it.
This directory should contain at least two files: smb.conf and smbnetfs.conf.
You may copy smb.conf from the /etc/samba directory. You can find a sample of
smbnetfs.conf in the /etc directory.

Using default settings for now.
hc@hc:~$ smbnetfs ~/network
WARNING!!! Configuration directory ~/.smb is not found. Please create it.
This directory should contain at least two files: smb.conf and smbnetfs.conf.
You may copy smb.conf from the /etc/samba directory. You can find a sample of
smbnetfs.conf in the /etc directory.

Using default settings for now.
fuse: mountpoint is not empty
fuse: if you are sure this is safe, use the 'nonempty' mount option
hc@hc:~$


What wrong??

Offline

#12 2008-12-10 20:10:24

Tosick
#! CrunchBanger
From: Sweden
Registered: 2008-12-08
Posts: 184

Re: view LAN

In both PCs the connection disapared after restart.
So what does it take to make a permanet connection?

Offline

#13 2008-12-10 20:12:22

Tosick
#! CrunchBanger
From: Sweden
Registered: 2008-12-08
Posts: 184

Re: view LAN

Can I navigate on folders just like on windows or fusesmb?

When it works and you do not restart the PC,.....Yes.:)

Offline

#14 2008-12-10 21:15:20

greenguru
#! Member
From: UK
Registered: 2008-11-27
Posts: 69

Re: view LAN

I use gnome-commander to browse my samba shares and the double pane view makes file copying quick and easy.

Offline

#15 2008-12-10 21:21:58

razienwolf
#! CrunchBanger
From: SP, Brasil
Registered: 2008-12-01
Posts: 115

Re: view LAN

There's a typo on EYo post. Tosick you are supposed to create the folder ~/.smb 
The slash is missing

heres the right one.

sudo apt-get install smbnetfs
mkdir ~/.smb
cp -v /etc/samba/smb.conf ~/.smb/
cp -v /etc/smbnetfs.conf ~/.smb/
mkdir ~/network
smbnetfs ~/network 

Then, assuming you created the network on ~/network , you can just put the same command on your autostart.sh file to load at every boot.

smbnetfs ~/network &

Got it?

Offline

#16 2008-12-10 22:12:34

Tosick
#! CrunchBanger
From: Sweden
Registered: 2008-12-08
Posts: 184

Re: view LAN

Got it?

Almost hopefully. Where is the autostart.sh located, so that I can edit it?

ie Im newbie as well:D

Offline

#17 2008-12-10 22:24:10

greenguru
#! Member
From: UK
Registered: 2008-11-27
Posts: 69

Re: view LAN

Right click to get the menu and then:

Preferences - Openbox Config - Edit autostart.sh

Offline

#18 2008-12-11 02:13:58

EYo
Member
From: Sonoma County, California
Registered: 2008-12-10
Posts: 11
Website

Re: view LAN

Tosick wrote:

Sorry I did not understand NSLU2.

That's my tiny little Linksys NAS :-)

Offline

#19 2008-12-11 11:12:14

Tosick
#! CrunchBanger
From: Sweden
Registered: 2008-12-08
Posts: 184

Re: view LAN

Almost there........:)

I edit the autostart.sh and saves it.
Restarts !#, but......there is nothing i the ~/network.

Without restart I go to the Terminal and pastes the commandes all at ones (as Ive done before)
But this time there is still nothing in ~/network.

This is the printout from Terminal.
hc@hc:~$ sudo apt-get install smbnetfs
[sudo] password for hc: ..............................1)Doesnt this request happen, with running the "autostart.sh"?
Reading package lists... Done
Building dependency tree       
Reading state information... Done
smbnetfs is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
hc@hc:~$ .................................2)Here you can see the it stopes.
hc@hc:~$ sudo apt-get install smbnetfs.................................3)Im make a complet paste a 2nd time.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
smbnetfs is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
hc@hc:~$ mkdir ~/.smb
mkdir: cannot create directory `/home/hc/.smb': File exists
hc@hc:~$ cp -v /etc/samba/smb.conf ~/.smb/
`/etc/samba/smb.conf' -> `/home/hc/.smb/smb.conf'
hc@hc:~$ cp -v /etc/smbnetfs.conf ~/.smb/
`/etc/smbnetfs.conf' -> `/home/hc/.smb/smbnetfs.conf'
hc@hc:~$ mkdir ~/network...........................................................4)here or
mkdir: cannot create directory `/home/hc/network': File exists
hc@hc:~$ smbnetfs ~/network .......................................................5)here it stopes agane and I hit enter.
fusermount: failed to open /etc/fuse.conf: Permission denied
fusermount: failed to access mountpoint /home/hc/network: Permission denied
hc@hc:~$
hc@hc:~$



Where is my misstake?
Should enter the commands line by line in the terminal?
Is there a authorization problem that makes the autostart.sh not work.

autostart.sh looks like this at the bottum of the file:
# Launch Conky
conky &

# Launch LAN connection at start up
sudo apt-get install smbnetfs
mkdir ~/.smb
cp -v /etc/samba/smb.conf ~/.smb/
cp -v /etc/smbnetfs.conf ~/.smb/
mkdir ~/network
smbnetfs ~/network

Uuups..........now I see the all other intructions and with a "&".
Is that why?

Offline

#20 2008-12-11 11:36:24

Tosick
#! CrunchBanger
From: Sweden
Registered: 2008-12-08
Posts: 184

Re: view LAN

Dont forget the "&".

There it is:):):)

Thanks a lot EYo, razienwolf and greenguru. Ive been trying to have this solved for several weeks now.
This open up the posebility to use, not just !# but the other Xfce based distros.

So to sum it up.....

Write following in the autostart.sh

# Launch LAN connection at start up
sudo apt-get install smbnetfs
mkdir ~/.smb
cp -v /etc/samba/smb.conf ~/.smb/
cp -v /etc/smbnetfs.conf ~/.smb/
mkdir ~/network
smbnetfs ~/network &

To find the autostart.sh:

Right click to get the menu and then:

Preferences - Openbox Config - Edit autostart.sh

Some NAS is less "friendly" the others. So in one PC I can see both, but in the other PC(AMD64) my D-link is "arrogant".

Offline

#21 2008-12-11 15:16:09

razienwolf
#! CrunchBanger
From: SP, Brasil
Registered: 2008-12-01
Posts: 115

Re: view LAN

Wow hold on Tosick. You getting the all idea of autostart wrong. This is what you file should look like

# Launch LAN connection at start up
smbnetfs ~/network &

You dont need all the others, because they only need to be done once. Let me clarify what they do.

sudo apt-get install smbnetfs

Install the program smbnetfs

mkdir ~/.smb

Creates a folder on your home directory called .smb  (the dot is to make the folder invisible, press CTRL+H to see it)

cp -v /etc/samba/smb.conf ~/.smb/

Copies the smb.conf file into the new folder you just created.

cp -v /etc/smbnetfs.conf ~/.smb/

Copies the smbnetfs.conf into the .smb folder.

mkdir ~/network

This creates a new directory where you're going to mount the network.

smbnetfs ~/network 

And finally this one here builds the network. And its the only one you have to keep on autostart, to build the network at every start.

Now about the error you get.

Try this

sudo apt-get update && sudo apt-get install samba

Then restart, and see if the folder now has the network.

Offline

#22 2008-12-11 16:43:42

Tosick
#! CrunchBanger
From: Sweden
Registered: 2008-12-08
Posts: 184

Re: view LAN

Well it works great on the Pentium 2, so ..........I should perhaps stick to that one:D:D

Thanks razienwolf,
Ill look in to this right away.

Offline

#23 2008-12-11 17:05:20

Tosick
#! CrunchBanger
From: Sweden
Registered: 2008-12-08
Posts: 184

Re: view LAN

I update and that was a lot.
sudo apt-get update && sudo apt-get install samba

I edit the "restart.sh"

I also make the terminal commads one more time , just see and make sure that I "got it".
At the end there is an Permission denied.

hc@hc:~$ smbnetfs ~/network
fusermount: failed to open /etc/fuse.conf: Permission denied
fusermount: failed to access mountpoint /home/hc/network: Permission denied
hc@hc:~$

and the forlder ~/network is still enty.

I guess you got the answer?

Last edited by Tosick (2008-12-11 17:12:38)

Offline

#24 2008-12-11 17:10:57

Tosick
#! CrunchBanger
From: Sweden
Registered: 2008-12-08
Posts: 184

Re: view LAN

????? so I restart a third or forth time ,
and now it works (allmost verything)..??

So that about the Permission denied??
I try to understand...:/

Last edited by Tosick (2008-12-11 17:14:03)

Offline

Help fund CrunchBang, donate to the project!

#25 2008-12-11 17:17:41

razienwolf
#! CrunchBanger
From: SP, Brasil
Registered: 2008-12-01
Posts: 115

Re: view LAN

Hmm...

After you install samba you have to restart for the permissions to take. I dont know how to explain so well, but its like samba gives you permission to mount the network.

So, now is everything working accordingly?

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo