SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2009-03-28 09:03:39

prenaud
Member
From: Ottawa, Ontario, Canada
Registered: 2008-12-20
Posts: 47
Website

still need help with the keyboard setting

My apologies for posting so many basic questions.

I installed CB on a USB Flash Drive for my Dell Mini 9:
http://www.pendrivelinux.com/crunchbang … l-windows/

I still can't figure out how to type French accents on the Mini. Ine the past, I always used the right-alt key as compose, but there are no right-alt key. Maybe there is a combination I can use. I notice that I can do the following:

Fn - Alt - = : è
Fn - Alt - i : ē

I wonder if I don't have the wrong keyboard setup. Here's what I get when I type the following:

Shift-2 : "
Shift-3 : £
Shift-" : @

Pierre

Offline

Be excellent to each other!

#2 2009-03-28 13:25:51

anonymous
The Mystery Member
From: Arch Linux Forums
Registered: 2008-11-29
Posts: 9,416

Re: still need help with the keyboard setting

For your right alt key, maybe this post will help:

http://crunchbanglinux.org/forums/post/4957/#p4957

Also looks like youre using the default GB keyboard layout.

Open your autostart.sh file and uncomment (one of) the lines that begins with "setxkbmap" (pick the correct layout for your Mini).

Offline

#3 2009-03-28 21:15:00

prenaud
Member
From: Ottawa, Ontario, Canada
Registered: 2008-12-20
Posts: 47
Website

Re: still need help with the keyboard setting

anonymous wrote:

Open your autostart.sh file and uncomment (one of) the lines that begins with "setxkbmap" (pick the correct layout for your Mini).

I'm so bad. The file always goes back to the previous version after I reboot.  I opened autostart.sh using gksu gedit thinking that would do it, but I didn't have any success with that either. Am I doing something wrong?

By the way, I had a terrible time opening the file with the File/Open menu. I couldn't see the .config folder. I had to use the File/Open location menu.

Thanks again anonymous for your dedication,.

Pierre

Offline

#4 2009-03-29 00:02:34

anonymous
The Mystery Member
From: Arch Linux Forums
Registered: 2008-11-29
Posts: 9,416

Re: still need help with the keyboard setting

When you get the Open file dialog box, right-click on an empty space and make sure Show Hidden Files is checked.

Offline

#5 2009-03-29 02:45:36

radioz
#! Member
Registered: 2009-01-24
Posts: 72

Re: still need help with the keyboard setting

prenaud,
Are you running #! from a pendrive? I've heard that some pen drive installs have problems with persistance (not being able to save configuration changes). If so, that might explain why it does not keep the configuration after a reboot.

If that is the case, you may need to reinstall #! again to your pen drive to make the persistance work.

radioz


____________
#! on EEE 701

Offline

#6 2009-03-29 08:21:58

prenaud
Member
From: Ottawa, Ontario, Canada
Registered: 2008-12-20
Posts: 47
Website

Re: still need help with the keyboard setting

anonymous wrote:

When you get the Open file dialog box, right-click on an empty space and make sure Show Hidden Files is checked.

Thanks for the tip. Same results though. The file goes back to its original after I reboot.

radioz wrote:

Are you running #! from a pendrive?

Yes, I'm using #! from a stick. So far, this is the only configuration change I have problems with. I would be very happy to install #! with a dual boot, but I still looking for clear instructions on how to do it with a Dell Mini 9. As you can tell, I'm not much of an expert and I'm kind of nervous about messing up XP.

Last edited by prenaud (2009-03-29 08:25:31)

Offline

#7 2009-03-29 15:59:06

radioz
#! Member
Registered: 2009-01-24
Posts: 72

Re: still need help with the keyboard setting

...I'm kind of nervous about messing up XP

I know what you mean. My 701 came with XP installed and I was very nervous about doing anything to mess up the installation. I run Linux on all of my home machines, but the XP version was the only one available at the time I got it. I was loathe to mess up the installation because I needed the EEE to just work.

I opted for a full install of #! to a USB stick without  touching the MBR on the EEE. I can provide more info on how to do this if you are interested.

radioz


____________
#! on EEE 701

Offline

#8 2009-03-29 16:20:59

prenaud
Member
From: Ottawa, Ontario, Canada
Registered: 2008-12-20
Posts: 47
Website

Re: still need help with the keyboard setting

radioz wrote:

I opted for a full install of #! to a USB stick without  touching the MBR on the EEE. I can provide more info on how to do this if you are interested.

The installation you talk about is better than this one?

http://www.pendrivelinux.com/crunchbang … l-windows/

If so, I would be very interested. Is the info somewhere on the net?

Pierre

Offline

#9 2009-03-29 20:14:54

radioz
#! Member
Registered: 2009-01-24
Posts: 72

Re: still need help with the keyboard setting

Full Install of #! To A Memory Stick

This installation procedure produces a full install of #! to a USB stick that has full persistance. It does not rely on any external installation scripts or applications. It also does not make ANY modifications to existing installations on your computer (hopefully).

This install is performed using a CD drive connected to your computer (I have an EEE 701 4G with an external CD drive).

Note the highlighting on the critical steps in performing this installation:

Installation Steps:
1. Download and burn the #! iso to a CD.
2. Plug in your USB memory stick and boot up the system from the CD.
3. Once #! is running, select 'Install' from the right-click menu.
4. Go through the installation choices. When you reach the partitioning step, select 'Manual'
5. Delete any existing partitions on the stick and create one for '/' and one for '/home'. Skip '/swap' for a memory stick install.
6. On the 'Install' dialog following the partition selection, select 'Advanced'.
7. Select the MBR of the USB stick for the boot loader location.
8. Finish the install. Enjoy!

Notes:

  • Make sure to burn the iso file correctly (burn a CD image)

  • Before starting the install, make sure that the USB stick is NOT mounted (it wasn't on my system). If it is, open a terminal and type 'sudo umount /dev/xxx' where 'xxx' is the path of your USB stick (mine is /dev/sdb1). If the USB stick is mounted, the partitioner won't see it.

  • In step 4, make sure you select your memory stick for partitioning. If you make a mistake, you can destroy your existing installation.

  • I had a 4GB stick and partitioned it with 3GB for '/' and 1 GB for '/home'.

  • When selecting the location for the boot loader, select the root of the USB stick. For example, on my machine the selection menu will show /dev/sdb, /dev/sdb1, and /dev/sdb2 for my USB stick. I selected /dev/sdb (the root of the stick). Just make sure NOT to select the MBR of your hard drive, or it will mess up your Windows (or whatever) installation.

I hope this helps.

radioz


____________
#! on EEE 701

Offline

#10 2009-03-29 20:26:10

prenaud
Member
From: Ottawa, Ontario, Canada
Registered: 2008-12-20
Posts: 47
Website

Re: still need help with the keyboard setting

Thanks radioz for the detailed explanations. I will try later.

I don't have a CD drive with on Mini. I assume I can do the installation on a key using my desktop computer.

Offline

#11 2009-03-31 18:22:10

prenaud
Member
From: Ottawa, Ontario, Canada
Registered: 2008-12-20
Posts: 47
Website

Re: still need help with the keyboard setting

I was finally to do the whole thing, but at about 75% I got a message saying there was no more room. That's too bad. All I have available at this point is a 2GB key. I first went 1.5GB for '/' and .5GB for '/home'. Then I tried 1.75GB for '/' and .25GB for '/home'.

I had no clue we needed much more space with a clean install. A 2GB key is plenty with this method:

http://www.pendrivelinux.com/crunchbang … l-windows/

Pierre

Offline

#12 2009-03-31 20:49:14

theZoid
Member
From: Florida
Registered: 2009-03-27
Posts: 20
Website

Re: still need help with the keyboard setting

I have CB installed on a USB stick per PDL.com.  How can I change my keyboard layout?  My " and @ are reversed and driving me crazy....thx'!


Cheers, Big Ears!

DΞLL Precision M6500 "Big Dog": i7-820QM w/USB 3.0, 8.0GB DDR3-1333, Intel x-25M 160 G2 + 500GB 7200.3, nVidia Quadro FX 3800M 1.0GB DDR3, RGBLED, Intel 6300 //Win7Pro x64/Sabayon KDE 4.5.4 x64

Offline

#13 2009-03-31 22:35:29

anonymous
The Mystery Member
From: Arch Linux Forums
Registered: 2008-11-29
Posts: 9,416

Offline

#14 2009-04-02 20:58:57

prenaud
Member
From: Ottawa, Ontario, Canada
Registered: 2008-12-20
Posts: 47
Website

Re: still need help with the keyboard setting

Anaconda wrote:

Living in Canada so using a US keyboard and didn't know how to change the (incorrect for me) default settings for that when I first booted.
Didn't see it in the forum anywhere but since I figured it out I thought I'd post it here for others with the same problem.

Bring up a terminal and type "setxkbmap us"

Finally,  I have all the French accents. For the francophiles out there:

setxkbmap us intl

´ and e = é
¨ and e = ë
^ and e = ê
Fn-` and e = è
Fn-Alt-, = ç

Pierre

Offline

#15 2009-04-06 16:34:21

disassembler
Member
From: New Jersey
Registered: 2009-02-28
Posts: 15
Website

Re: still need help with the keyboard setting

prenaud wrote:

I wonder if I don't have the wrong keyboard setup. Here's what I get when I type the following:

Shift-2 : "
Shift-3 : £
Shift-" : @

Pierre

I have the same problem. I'm running the Live CD on a MacBook. At least I know how to make the @ symbol now. tongue I need it for entering my e-mail when logging into some accounts.


Work. Buy. Consume. Die. The Designers Republic Is Dead!
8static|Blip Festival|Last.fm|Pulsewave|Tumblr|Twitter

Offline

#16 2009-04-06 16:55:01

disassembler
Member
From: New Jersey
Registered: 2009-02-28
Posts: 15
Website

Re: still need help with the keyboard setting

"setxkbmap us" worked for me! :]


Work. Buy. Consume. Die. The Designers Republic Is Dead!
8static|Blip Festival|Last.fm|Pulsewave|Tumblr|Twitter

Offline

#17 2009-06-07 09:12:05

arnoldus
New Member
Registered: 2009-05-31
Posts: 3

Re: still need help with the keyboard setting

radioz wrote:

Full Install of #! To A Memory Stick

This installation procedure produces a full install of #! to a USB stick that has full persistance. It does not rely on any external installation scripts or applications. It also does not make ANY modifications to existing installations on your computer (hopefully).

This install is performed using a CD drive connected to your computer (I have an EEE 701 4G with an external CD drive).

Note the highlighting on the critical steps in performing this installation:

Installation Steps:
1. Download and burn the #! iso to a CD.
2. Plug in your USB memory stick and boot up the system from the CD.
3. Once #! is running, select 'Install' from the right-click menu.
4. Go through the installation choices. When you reach the partitioning step, select 'Manual'
5. Delete any existing partitions on the stick and create one for '/' and one for '/home'. Skip '/swap' for a memory stick install.
6. On the 'Install' dialog following the partition selection, select 'Advanced'.
7. Select the MBR of the USB stick for the boot loader location.
8. Finish the install. Enjoy!

Notes:

  • Make sure to burn the iso file correctly (burn a CD image)

  • Before starting the install, make sure that the USB stick is NOT mounted (it wasn't on my system). If it is, open a terminal and type 'sudo umount /dev/xxx' where 'xxx' is the path of your USB stick (mine is /dev/sdb1). If the USB stick is mounted, the partitioner won't see it.

  • In step 4, make sure you select your memory stick for partitioning. If you make a mistake, you can destroy your existing installation.

  • I had a 4GB stick and partitioned it with 3GB for '/' and 1 GB for '/home'.

  • When selecting the location for the boot loader, select the root of the USB stick. For example, on my machine the selection menu will show /dev/sdb, /dev/sdb1, and /dev/sdb2 for my USB stick. I selected /dev/sdb (the root of the stick). Just make sure NOT to select the MBR of your hard drive, or it will mess up your Windows (or whatever) installation.

I hope this helps.

radioz

Can you do this without burning the iso to CD; but from within eg Ubuntu?

edit: found this guide, will try later in the afternoon

Last edited by arnoldus (2009-06-07 09:17:23)

Offline

#18 2009-10-15 14:59:38

nick.letellier
New Member
Registered: 2009-10-15
Posts: 4

Re: still need help with the keyboard setting

Hello,

I've followed the installation instructions booting from the Live CD and installing to USB key, but get a copy error - this might be caused by a faulty CD, though it works fine and the MD5 was ok.

Also tried another copy using different instructions (www.pendrivelinux.com/crunchbang-linux-flash-drive-install-via-cd/). However, when I boot with the USB key, it is mounted as read-only, which means I can't use the casper-rw configuration. Any thoughts? Should I create a separate partition to use the casper-rw? If so, how do I go about doing this?

Help will be much appreciated.

Offline

#19 2009-10-15 20:16:07

cheeserolls
Member
From: Battersea, London, UK
Registered: 2009-10-13
Posts: 13

Re: still need help with the keyboard setting

prenaud wrote:

I wonder if I don't have the wrong keyboard setup. Here's what I get when I type the following:

Shift-2 : "
Shift-3 : £
Shift-" : @

Pierre

That is the layout of a UK Keyboard.  Could this be something to do with Corenomial  being based in the UK?  Is a UK keyboard the default in Crunchbang?

I sometimes have to use other keyboard layouts - the command to switch is

setxkbmap [layoutcode]

You can find the list of codes in /usr/share/X11/xkb/symbols
In fact you can edit these symbol files as well to create your own custom keyboard layout with all your favourite symbols mapped to shortcut keys which is fun for geeks like me.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo