SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2010-06-27 19:26:59

groovydaddy
#! Member
From: North Carolina, USA
Registered: 2010-03-17
Posts: 69

[SOLVED]CrunchBang 10 Alpha 2 Bug

I'm liking the changes from the A1 to the A2 so far corenomical.  Thanks for the updates!

However, I'm having trouble with the keymaping.  During the installation setup from the Alpha 2 ISO, I set the keymap to US.  However, the @ is at the Shift+' position instead of the Shift+2 position.  Likewise, the " is at the Shift+2 position, not the Shift+' position.  This happened in the Alpha 1, but the keymap tool in the System Toolbar of the panel was set to GB instead of US, and I'm thinking it defaulted to GB instead of US for some reason.  How can I correct this?  Should I try a new install to see if it happens again?

Any suggestions or assistance would be greatly appreciated.  Thanks all!

--GroovyD

Last edited by groovydaddy (2010-06-27 21:36:07)


Ubuntu 13.10
HP Probook Laptop, i3 (first gen), 8GB RAM

Offline

Help fund CrunchBang, donate to the project!

#2 2010-06-27 20:24:00

anonymous
The Mystery Member
From: Arch Linux Forums
Registered: 2008-11-29
Posts: 9,418

Re: [SOLVED]CrunchBang 10 Alpha 2 Bug

I can confirm this.

Just run fbxkb. This will launch the icon so you change the keyboard layout. For some reason, Philip decided to only have the icon show up when using the Live environment.

Offline

#3 2010-06-27 21:03:20

groovydaddy
#! Member
From: North Carolina, USA
Registered: 2010-03-17
Posts: 69

Re: [SOLVED]CrunchBang 10 Alpha 2 Bug

Thanks anonymous.  I ran the command and the icon is in the system tray.  However, when I click on it, nothing is happening.  It is stuck on GB.  Is there a setting that I need to update in order to change the keymap to US?

Thanks!

--GroovyD


Ubuntu 13.10
HP Probook Laptop, i3 (first gen), 8GB RAM

Offline

#4 2010-06-27 21:25:10

anonymous
The Mystery Member
From: Arch Linux Forums
Registered: 2008-11-29
Posts: 9,418

Re: [SOLVED]CrunchBang 10 Alpha 2 Bug

Just run "setxkbmap us". Also if you want to add it to your autostart.sh remember to add an ampersand at the end so it reads "setxkbmap us &".

Offline

#5 2010-06-27 21:32:05

groovydaddy
#! Member
From: North Carolina, USA
Registered: 2010-03-17
Posts: 69

Re: [SOLVED]CrunchBang 10 Alpha 2 Bug

Worked like a charm!  smile

Thanks anonymous.  Maybe we should sticky this one, just in case anyone else is having trouble with this?  I think it should be until the problem is fixed at the very least...  smile  I appreciate your help.

--GroovyD


Ubuntu 13.10
HP Probook Laptop, i3 (first gen), 8GB RAM

Offline

#6 2010-06-27 21:37:12

qed
New Member
Registered: 2010-06-27
Posts: 1

Re: [SOLVED]CrunchBang 10 Alpha 2 Bug

Does this also affect the text installer? I grabbed alpha 2 (xfce) earlier today and had to install it several times before noticing that it takes my password (with symbols from the top number row) during the install but not when I log in for the first time.

Offline

#7 2010-06-27 21:43:13

groovydaddy
#! Member
From: North Carolina, USA
Registered: 2010-03-17
Posts: 69

Re: [SOLVED]CrunchBang 10 Alpha 2 Bug

qed wrote:

Does this also affect the text installer? I grabbed alpha 2 (xfce) earlier today and had to install it several times before noticing that it takes my password (with symbols from the top number row) during the install but not when I log in for the first time.

Hi qed.  I'm using the Openbox version, so I don't know if this issue is effecting the XFCE version.  I installed #! to my computer via text mode, so in the Openbox version text install, I would say yes.  If you find this keymap issue is effecting you in the XFCE version, you should be able to follow the same advise that anonymous gave me to fix the problem since the core system is the same.


Ubuntu 13.10
HP Probook Laptop, i3 (first gen), 8GB RAM

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo