SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2010-03-31 13:40:13

Tunafish
#! Die Hard
From: the Netherlands
Registered: 2010-03-07
Posts: 1,204

(solved) Change local settings

I'm trying to change the regional/local settings. I googled a lot but no results that helped me.
I want to solve the following:
- Orange and Conky show sunday as first day of the week... my week starts on monday smile
- In gnumeric numbers are shown as 34,200.00  instead of 34.200,00

Thanks,
Tunafish

Last edited by Tunafish (2010-04-02 11:22:52)


sed 's/stress/relaxation/g'
Privacy & Security on #!

Offline

Be excellent to each other!

#2 2010-03-31 16:57:09

johnraff
#!Drunkard
From: Nagoya, Japan
Registered: 2009-01-07
Posts: 2,847
Website

Re: (solved) Change local settings

Maybe you need to change your locale setting. If you type 'locale' in a terminal what do you get?


John
--------------------
( a boring Japan blog , idle twitterings  and GitStuff )
#! forum moderator

Offline

#3 2010-03-31 18:19:34

Tunafish
#! Die Hard
From: the Netherlands
Registered: 2010-03-07
Posts: 1,204

Re: (solved) Change local settings

This is what i get:
LANG=C
LC_CTYPE="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_COLLATE="C"
LC_MONETARY="C"
LC_MESSAGES="C"
LC_PAPER="C"
LC_NAME="C"
LC_ADDRESS="C"
LC_TELEPHONE="C"
LC_MEASUREMENT="C"
LC_IDENTIFICATION="C"
LC_ALL=
Doesn't say much does it....

i think my system language and settings are en_US.utf8


sed 's/stress/relaxation/g'
Privacy & Security on #!

Offline

#4 2010-03-31 21:10:19

aaro
#! Die Hard
Registered: 2009-11-15
Posts: 648

Re: (solved) Change local settings


- closed account - gone to better places -

Offline

#5 2010-04-01 02:15:40

johnraff
#!Drunkard
From: Nagoya, Japan
Registered: 2009-01-07
Posts: 2,847
Website

Re: (solved) Change local settings

Maybe these too:
http://www.debian.org/doc/manuals/intro … le.en.html
http://www.michael-hammer.at/blog/debian_locale/
http://serverfault.com/questions/54591/ … -on-debian

Anyway, I don't think "C" is what you want for your locale- that's a sort of default.

Last edited by johnraff (2010-04-01 02:17:06)


John
--------------------
( a boring Japan blog , idle twitterings  and GitStuff )
#! forum moderator

Offline

#6 2010-04-01 19:04:35

Tunafish
#! Die Hard
From: the Netherlands
Registered: 2010-03-07
Posts: 1,204

Re: (solved) Change local settings

Thanks for the response...
After a lot of reading i still didn't know what to do.

So i thought... i just give it a try, and i edited /etc/default/locale

#  File generated by update-locale
LANGUAGE="en_US:en"
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="nl_NL.UTF-8"
LC_TIME="nl_NL.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="nl_NL.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="nl_NL.UTF-8"
LC_NAME="nl_NL.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="nl_NL.UTF-8"
LC_MEASUREMENT="nl_NL.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

it seems to work... calendar is in dutch and  messages in english...
If this is a good solution, than it is pretty simple and might help more people.

Cheers.

Last edited by Tunafish (2010-04-01 19:05:34)


sed 's/stress/relaxation/g'
Privacy & Security on #!

Offline

#7 2010-04-01 19:08:45

pablokal
#! CrunchBanger
From: Nijmegen, Holland
Registered: 2009-12-11
Posts: 232
Website

Re: (solved) Change local settings

he, tuna, look here>http://stillstup.blogspot.com/2009/12/localize-crunchbang-in-liveusb-install.html


GNu/Linux: Nu nog schoner: http://linuxnogschoner.blogspot.com/  Dutch

Offline

#8 2010-04-01 19:41:53

Tunafish
#! Die Hard
From: the Netherlands
Registered: 2010-03-07
Posts: 1,204

Re: (solved) Change local settings

Pablokal,
I can't find language-selector in the repository. And i just want to change some settings to dutch, not my system language, messages etc.   
Did you solve this?
Tonijn


sed 's/stress/relaxation/g'
Privacy & Security on #!

Offline

#9 2010-04-01 21:56:59

kodx
Member
From: Russia
Registered: 2010-03-26
Posts: 24

Re: (solved) Change local settings

sudo dpkg-reconfigure locales

Choose your locales(with spacebar) and set the default one.

Then reboot.

Last edited by kodx (2010-04-01 21:59:02)

Offline

#10 2010-04-02 11:28:36

Tunafish
#! Die Hard
From: the Netherlands
Registered: 2010-03-07
Posts: 1,204

Re: (solved) Change local settings

Kodx suggestion changes everything (language, messages, etc) on my system. I want most stuff to be in english, and i just need some locale settings. Post 6 solves the problem for me now, so i stick to that solution.
Thanks,
Tonijn


sed 's/stress/relaxation/g'
Privacy & Security on #!

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo