SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2010-02-11 15:06:07

Carl
Member
From: Isle of Wight, UK
Registered: 2010-02-03
Posts: 49

Problem running Debian inside VirtualBox...

I installed debian inside VirtualBox using the net install image and only installed the base package and nothing else however on boot I get the below error:

Loading, please wait...
[        66.572793] BUG: soft lockup - CPU#0 stuck for 61s! [modprobe :90]

so it's safe to assume it doesent like something... =]

I'm running VirtualBox-3.1 from the sun virtualbox website installed on CrunchBang  on my Dell Inspiron 1525

Thanks in advance!

Offline

Help fund CrunchBang, donate to the project!

#2 2010-02-11 21:45:25

Carl
Member
From: Isle of Wight, UK
Registered: 2010-02-03
Posts: 49

Re: Problem running Debian inside VirtualBox...

I have discovered that disabling everything (network, cdrom, floppy) in Virtualbox will allow Debian to boot

after re-enabling the network Debian no longer works which leads me to believe that I need some kind of network package to get it to work?

I don't know how VirtualBox does the whole network thing but I know for a fact my wifi card isn't supported out of the box in Debian...

Offline

#3 2010-03-24 14:09:07

hgk
Member
Registered: 2009-08-25
Posts: 11

Re: Problem running Debian inside VirtualBox...

I have the same problem if I install CrunchBang 10 alpha in Virtualbox 3.1.4. (Not very suprising, because it's now based on Debian.) My solution: reduce the amount of RAM for the virtual machine from 1024MB to 512MB. Odd, but it works...

Offline

#4 2010-04-13 10:25:06

arand
New Member
Registered: 2010-03-28
Posts: 1

Re: Problem running Debian inside VirtualBox...

I mocked up a dpatch for karmic version of virtualbox, now attached at http://www.virtualbox.org/ticket/6425

Offline

#5 2010-04-14 01:11:27

almigi
Member
From: Fairview Park, Ohio, USA
Registered: 2009-04-03
Posts: 43

Re: Problem running Debian inside VirtualBox...

hgk wrote:

I have the same problem if I install CrunchBang 10 alpha in Virtualbox 3.1.4. (Not very suprising, because it's now based on Debian.) My solution: reduce the amount of RAM for the virtual machine from 1024MB to 512MB. Odd, but it works...

I managed to get CrunchBang 10 alpha working inside VirtualBox.  Granted, it's the i486 .iso that I'm using, and I got the RAM on the virtual machine at only 256MB.  But, it works rather well.  I haven't used it for anything major, but I've installed programs with Synaptic and apt-get, browsed the web, used XChat, etc.  All with no issue.

Offline

#6 2010-04-14 05:53:20

Peace9r
#! Member
From: Johannesburg, SA
Registered: 2010-03-04
Posts: 98

Re: Problem running Debian inside VirtualBox...

I installed #! 10 Alpha (Openbox) in Virtual Box 3.1.6, I let VB allocate the RAM (256mb) and I haven't experienced any problems.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo