SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2009-07-19 10:36:19

bconnor
Member
Registered: 2009-06-29
Posts: 23

Volume hot keys on Eee PC

to add fn volume key functionality to your eee pc, add these lines to your rc.xml

<keybind key="XF86AudioLowerVolume">
      <action name="Execute">
      <execute>amixer -q set PCM 10- unmute</execute>
      </action>
    </keybind>
    <keybind key="XF86AudioRaiseVolume">
      <action name="Execute">
      <execute>amixer -q set PCM 10+ unmute</execute>
      </action>
    </keybind>
    <keybind key="XF86AudioMute">
      <action name="Execute">
      <execute>amixer -q set PCM 0</execute>
      </action>
    </keybind>

toggle for some reason doesn't work for me, so my mute button just sets volume to 0.

i also added a volume bar to my conky:

${execibar 1 amixer sget PCM,0 |grep "Front Left:"|cut -d "[" -f2|cut -d "%" -f1}

Offline

Help fund CrunchBang, donate to the project!

#2 2009-07-29 15:01:02

diablomarcus
Member
Registered: 2009-07-06
Posts: 26

Re: Volume hot keys on Eee PC

This one isn't working for me on my eeePC 1000HE running CrunchBang Linux 9.04.01 Lite Edition.

I copied and restarted, but no luck.  Also, whenever I turn on the comp, the sound starts at 0 volume.  Any ideas?

Offline

#3 2009-07-31 04:42:53

echerrst
Member
Registered: 2009-07-15
Posts: 22

Re: Volume hot keys on Eee PC

for the OP, what is your EEE PC?

I have a 1005HA and it did not work for me either. I think that maybe the mute worked, however, volume up and down did not work.

Is it possible for someone to explain how to determine what key "code" each keystroke performs?

Marcus,

run "gnome-volume-control" and see if those volume levels are at the high level...

Offline

#4 2009-07-31 05:03:54

Toolz
#! Die Hard
From: Asia
Registered: 2009-02-02
Posts: 937

Re: Volume hot keys on Eee PC

echerrst wrote:

Is it possible for someone to explain how to determine what key "code" each keystroke performs?

I think you want:

sudo showkey

Offline

#5 2009-07-31 09:51:42

barc
Member
Registered: 2009-03-17
Posts: 19

Re: Volume hot keys on Eee PC

Thanks a lot! This works great with my MSI Wind U100. Now my u100 is fully supported running arch linux. Horray!

Offline

#6 2009-08-20 22:25:19

general_uproar
New Member
Registered: 2009-08-20
Posts: 2

Re: Volume hot keys on Eee PC

so, i'm a newby what exactly am i adding this to?

Offline

#7 2009-08-20 22:38:19

anonymous
The Mystery Member
From: Arch Linux Forums
Registered: 2008-11-29
Posts: 9,418

Re: Volume hot keys on Eee PC

The rc.xml file.

Openbox menu > Preferences > Openbox Config > Edit rc.xml, save your changes then > Openbox menu > Preferences > Openbox Config > Reconfigure.

Offline

#8 2009-08-27 16:19:16

jmbarnes
#! Junkie
Registered: 2009-05-04
Posts: 250

Re: Volume hot keys on Eee PC

Just wanted to confirm that this works brilliantly on a 900a eeepc (and in conjunction with elmurato's scripts.) Much simpler fix than trying to mess with acpi / kernel modules to get these hotkeys working.

Thanks


IRC: PizzaAndWine     Script bits: Incremental Backup | Sleep Timer

Offline

#9 2009-09-04 16:09:30

orlok
Member
Registered: 2009-08-30
Posts: 23

Re: Volume hot keys on Eee PC

So much win on a eeepc 901!
Thanks a bunch, got really frustrated a couple of months ago trying to dick around with that malarky and was just using the volume control.

Not sure if this matters, but I think it has to be pasted under <keyboard> and before </keyboard> in your config file.

Last edited by orlok (2009-09-04 16:10:26)


black eeepc 901 running #! kernel 2.6.27-8-eeepc-lean

Offline

#10 2009-10-06 08:10:39

Xecuter
New Member
Registered: 2009-10-06
Posts: 1

Re: Volume hot keys on Eee PC

I got a better solution. big_smile

<keybind key="XF86AudioLowerVolume">
      <action name="Execute">
      <execute>amixer -q set Master 10-</execute>
      </action>
    </keybind>
    <keybind key="XF86AudioRaiseVolume">
      <action name="Execute">
      <execute>amixer -q set Master 10+/execute>
      </action>
    </keybind>
    <keybind key="XF86AudioMute">
      <action name="Execute">
      <execute>amixer -q set Master toggle</execute>
      </action>
    </keybind>

Then toggling mute works.

Offline

#11 2009-10-06 12:13:10

saneks
#! Die Hard
Registered: 2009-10-01
Posts: 999

Re: Volume hot keys on Eee PC

Xecutor, your code does not work on my eee 701, I just get an Syntax Error message when restarting after editing the rc.xml,  I just pasted your stuff between the other keybinds in that file. Tried twice, restoring the rc.xml file inbetween.

EDIT: strange, I tried the code from the initial post, which worked, but as written volume toggle isn't toggling but muting. Then I just copied your line for toggling (the 3rd last) over the other one and everything is cool now!:D

Thanks!

Last edited by saneks (2009-10-06 12:34:21)


eee701 user & other lap/desktops

Offline

#12 2009-12-13 19:03:26

Vox
New Member
From: Trondheim, Norway
Registered: 2009-12-13
Posts: 2
Website

Re: Volume hot keys on Eee PC

I noticed that there's no channel called Master when I tried this fix. Here's the code I pasted into rc.xml

Super+space -> Preferences -> Openbox Config -> Edit rc.xml

Place the marker at the end of the last </keybind> (Right above the </Keyboard> line). Hit Enter and paste the code:

<keybind key="XF86AudioLowerVolume">
      <action name="Execute">
      <execute>amixer -q set PCM 10- unmute</execute>
      </action>
    </keybind>
    <keybind key="XF86AudioRaiseVolume">
      <action name="Execute">
      <execute>amixer -q set PCM 10+ unmute</execute>
      </action>
    </keybind>
    <keybind key="XF86AudioMute">
      <action name="Execute">
      <execute>amixer -q set LineOut toggle</execute>
      </action>
    </keybind>

Save and close.

Super+space -> Preferences -> Openbox Config -> Restart.

The VolWheel in the system tray didn't work eighter, so I right-clicked the "Volume Icon" -> Preferences -> Default channel: PCM
Default mixer: gnome-volume-control

Super+v to set the preferred level for the LineOut channel with PCM channel maxed out. WARNING!: Be careful when you start adjusting the LineOut.. better start out at a fairly low volume setting when the PCM is at 100%.
When you have found your preferred max volume setting you are good to go smile

Offline

#13 2009-12-13 19:23:43

pvsage
Internal Affairs
From: North Carolina
Registered: 2009-10-18
Posts: 12,490

Re: Volume hot keys on Eee PC

@Vox - What hardware do you have that doesn't have a Master channel?


I'm a moderator here.  How are we doing?  Feedback is encouraged.

Offline

#14 2009-12-13 20:58:14

Vox
New Member
From: Trondheim, Norway
Registered: 2009-12-13
Posts: 2
Website

Re: Volume hot keys on Eee PC

EeePC 901

Guess the LineOut is the same as Master(??).

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo