SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2009-06-28 18:32:42

Toolz
#! Die Hard
From: Asia
Registered: 2009-02-02
Posts: 937

[solved] Mouse scroll to change desktops - turning off

I don't arrange my work into desktops, but I do have a sort of nervous habit of scrolling my mouse wheel while thinking. If the pointer moves slightly and is positioned over the visible desktop then the other desktops will fly by. How do I turn off this behaviour?

Last edited by Toolz (2009-06-28 19:27:58)

Offline

Help fund CrunchBang, donate to the project!

#2 2009-06-28 19:10:30

anonymous
The Mystery Member
From: Arch Linux Forums
Registered: 2008-11-29
Posts: 9,372

Re: [solved] Mouse scroll to change desktops - turning off

The setting is controlled by your rc.xml file (Openbox menu > Preferences > Openbox Config > Edit rc.xml). I *think* the section you have to remove is:

    <mousebind button="Up" action="Click">
      <action name="DesktopPrevious"/>
    </mousebind>
    <mousebind button="Down" action="Click">
      <action name="DesktopNext"/>
    </mousebind>

But I am not sure!!

Offline

#3 2009-06-28 19:26:49

Toolz
#! Die Hard
From: Asia
Registered: 2009-02-02
Posts: 937

Re: [solved] Mouse scroll to change desktops - turning off

That seems to have done the trick, thanks!

Offline

#4 2009-07-12 16:17:19

diablomarcus
Member
Registered: 2009-07-06
Posts: 26

Re: [solved] Mouse scroll to change desktops - turning off

I would assume this was true in 8.10 as well, but in 9.04, you shouldn't delete the

  <context name="Desktop">

as that will break that part of the code.  This was probably assumed, but for first time non-Windows users (like myself) it will clear up some confusion.

Sorry about the necromancing sad

Offline

#5 2009-07-13 02:38:58

Toolz
#! Die Hard
From: Asia
Registered: 2009-02-02
Posts: 937

Re: [solved] Mouse scroll to change desktops - turning off

^^ Definitely. Just remove the two <mousebind*> blocks.

Anyone just happen to know the equiv config file in Mint, before I go looking?

Offline

#6 2011-03-24 20:04:36

alaskan-hippie
Member
Registered: 2011-03-24
Posts: 24

Re: [solved] Mouse scroll to change desktops - turning off

just want to say real quick, I'm mostly new to the whole linux thing. I've been learning little bits here and there for a little while but still don't know as much as I should. anyway, i tried anonymous's suggestion but it didn't work. still happening with my latpop. im running an hp compaq presario c500. this is the code i pulled out, i tried what was suggested, then pulled all of it:

  <mousebind button="Up" action="Click">
        <action name="DesktopPrevious"/>
      </mousebind>
      <mousebind button="Down" action="Click">
        <action name="DesktopNext"/>
      </mousebind>
       <mousebind button="A-Up" action="Click">
        <action name="DesktopPrevious"/>
      </mousebind>
      <mousebind button="A-Down" action="Click">
        <action name="DesktopNext"/>
      </mousebind>
      <mousebind button="C-A-Up" action="Click">
        <action name="DesktopPrevious"/>
      </mousebind>
      <mousebind button="C-A-Down" action="Click">
        <action name="DesktopNext"/>
      </mousebind>

i don't necessarily want to completely disable this feature now that I think about it, when i scrol a milimeter on my touchpad it flies through the desktops multiple times. is there a way where i can set the length of the scroll before the desktop change?

Offline

#7 2011-03-24 20:17:57

bobrossw
#! Die Hard
Registered: 2011-02-08
Posts: 521

Re: [solved] Mouse scroll to change desktops - turning off

@alaskan-hippie - don't know about limiting the amount you scroll, but you could set it to go to desktop 1 if you scroll up and desktop 2 if you scroll down.
check this guide for more details: http://openbox.org/wiki/Help:Configuration and http://openbox.org/wiki/Help:Bindings#Mouse_bindings and http://openbox.org/wiki/Help:Actions

Here's the code you'd need to change:
Wherever it says:

<action name="DesktopNext"/>

change it to:

 <action name="Desktop"><desktop>2</desktop></action>

Where it says DesktopPrevious change it to this:

 <action name="Desktop"><desktop>1</desktop></action>

that should make it easy to switch between two desktops at least, you could add extra bindings for other desktops I suppose.

You can also change the binding for the mouse at the edge of the screen and give it a certain amount of time after the mouse touches the edge of the screen before switching desktops.  Hope that helps.

Offline

#8 2012-03-18 01:00:19

wuxmedia
wookiee madclaw
From: Back in Blighty
Registered: 2012-03-09
Posts: 1,447
Website

Re: [solved] Mouse scroll to change desktops - turning off

+1 ace idea - thats been bothering me for ages. I changed the taskbar (?) scrolling as well, trackpad mayhem is calmed

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo