SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2012-10-05 08:45:18

Probe34
Member
Registered: 2012-09-25
Posts: 42

iceweasel unstable

Hello all,

I have moved to #! only recently and everything is fine except for iceweasel. It is unstable as hell.

I have used firefox since the start. And it is my favorite browser. But I cannot work with a browser that is as unstable as iceweasel. On certain pages, it just crashes. Some websites claim that I have an obsolete webbrowser and that it may hinder my browserquality (or something like that) and it does.

Should I switch to the unstable Debian version (that is maybe more up to date)?
What is your experience with this unstable Debian version?

I hate the idea that I have to switch to google-chrome or opera.

Offline

Be excellent to each other!

#2 2012-10-05 09:12:10

dura
Bloated Gimp
From: interzone
Registered: 2012-09-15
Posts: 2,107

Re: iceweasel unstable

I updated my repositories through synaptic (just refresh it) and upgraded iceweasel to 15.10 (I think thats what corenominal put in the repositories). It works great. An idea might also be to use the addon 'adblock plus' as a lot of the crashes may be due to poorly built advertising widgets. I experience that since using waldorf. Using adblock plus makes a massive difference to certain websites.

There is also a long list of modifications you can make to iceweasel, if you search this forum for iceweasel, and go to the section on 'applications'. Here, I'm talking about such things as http-pipelining, which I like!!!

smile

Offline

#3 2012-10-05 19:17:49

Probe34
Member
Registered: 2012-09-25
Posts: 42

Re: iceweasel unstable

Thank you for your answer, d! Most useful. smile

Last edited by Probe34 (2012-10-05 19:18:05)

Offline

#4 2012-10-06 02:02:53

KrunchTime
#! Die Hard
From: not where I belong
Registered: 2012-03-02
Posts: 2,200

Re: iceweasel unstable

d! wrote:

I updated my repositories through synaptic (just refresh it) and upgraded iceweasel to 15.10 (I think thats what corenominal put in the repositories).

You must be using a different repository than I.  I just updated the repositories a few minutes ago, and there was no new version of Ice Weasel available.  I'm still running 11.0, which is from Core Papa's repository.

Offline

#5 2012-10-06 02:05:52

KrunchTime
#! Die Hard
From: not where I belong
Registered: 2012-03-02
Posts: 2,200

Re: iceweasel unstable

Probe34 wrote:

But I cannot work with a browser that is as unstable as iceweasel. On certain pages, it just crashes. Some websites claim that I have an obsolete webbrowser and that it may hinder my browserquality (or something like that) and it does.

What version of Ice Weasel do you have?  I'm using v11.00 and I'm not experiencing any problems.  Are you sure you haven't done something that has made Ice Weasel unstable?  Additionally, I run Opera and I think it's a great browser, even if it is proprietary.

Offline

#6 2012-10-06 05:08:53

tlinsley
#! Member
From: Austin, TX
Registered: 2012-04-10
Posts: 68

Re: iceweasel unstable

To get Iceweasel 15, go to this site (Debian Mozilla Team APT Archive):

http://mozilla.debian.net/

Choose the version of Debian you are running in the first drop-down.
  (Hint: Crunchbang Statler = Squeeze  Crunchbang Waldorf = Wheezy)

Choose "Iceweasel" for the second drop-down.

Choose "Release" for the third drop-down.

Then follow the brief instructions.


I've been running Iceweasel 15 on Waldorf with zero issues.  Ymmv.

I second the suggestion to run Adblock Plus, just please don't forget to
whitelist "crunchbanglinux.org".  Failure to do so robs a mighty fine distro
of well deserved ad revenue.

Hope 15 works well for you!

Offline

#7 2012-10-06 07:19:48

Erinsfan
#! CrunchBanger
From: At a terminal
Registered: 2011-01-28
Posts: 148

Re: iceweasel unstable

15 in Waldorf seems fine for me too. Am running Ad-Block, Flash, Ghosery, No-Script and Flash Video Downloader too.


Enjoying a good !#

Offline

#8 2012-10-06 07:27:51

Probe34
Member
Registered: 2012-09-25
Posts: 42

Re: iceweasel unstable

I am confused. You are talking about different versions here. I am using 3.5.16. I suppose that when you say that you are using 15, you mean 3.5.15 and when you say 11.00, you mean you are using 3.5.11.

Tell me if you are not.

Offline

#9 2012-10-06 07:38:57

mariannemarlow
#! Die Hard
From: My flat, London, England
Registered: 2012-06-03
Posts: 2,209
Website

Re: iceweasel unstable

Mine is 11.00

See linky for pic.

http://i.imgur.com/7XgVR.png

It runs fine, just takes up too much systems resources at times..


Between two evils, I always pick the one I never tried before ~ Mae West

Offline

#10 2012-10-06 08:08:37

Probe34
Member
Registered: 2012-09-25
Posts: 42

Re: iceweasel unstable

How is that possible?? yikes

I have 3.5.15 and you have 11.00. I am dumbfounded.

Offline

#11 2012-10-06 08:12:01

pvsage
Internal Affairs
From: North Carolina
Registered: 2009-10-18
Posts: 12,776

Re: iceweasel unstable

^ Backports.


I'm a moderator here.  How are we doing?  Feedback is encouraged.

Offline

#12 2012-10-06 08:14:41

mariannemarlow
#! Die Hard
From: My flat, London, England
Registered: 2012-06-03
Posts: 2,209
Website

Re: iceweasel unstable

@pvsage

Ah yes, xaos52 made me enable the backports in the early days.. lol


Between two evils, I always pick the one I never tried before ~ Mae West

Offline

#13 2012-10-07 06:13:33

Probe34
Member
Registered: 2012-09-25
Posts: 42

Re: iceweasel unstable

Okay, backports. Thank you, I know what to do now. smile

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo