SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2008-12-05 23:11:24

Anaconda
crypto-anarchist
From: Vancouver Canada
Registered: 2008-12-04
Posts: 246

(solved) US keyboard map

Living in Canada so using a US keyboard and didn't know how to change the (incorrect for me) default settings for that when I first booted.
Didn't see it in the forum anywhere but since I figured it out I thought I'd post it here for others with the same problem.

Bring up a terminal and type "setxkbmap us"

Funny thing is #! came out as with a British pound sign until I changed it.   I thought "pound bang" was what you did if you were stuck using that other infamous OS.   tongue

Last edited by Anaconda (2008-12-05 23:12:57)


“The university is well structured, well tooled, to turn out people with all the sharp edges worn off...." Mario Savio
"Protections for anonymous speech are vital to democratic discourse". Help enforce our right to free and anonymous speech by taking the Tor challenge.

Offline

Be excellent to each other!

#2 2008-12-06 00:05:12

marf
Member
Registered: 2008-12-03
Posts: 24

Re: (solved) US keyboard map

alternatively in terminal you can type

gedit ~/.config/openbox/autostart.sh

and then uncomment the respective line.

Offline

#3 2008-12-06 21:13:43

Anaconda
crypto-anarchist
From: Vancouver Canada
Registered: 2008-12-04
Posts: 246

Re: (solved) US keyboard map

Thanks marf.

I was too hasty in my posting to mention that the "setxkbmap us" thing is just a quick way to get this done if you are running from the live CD.

Anyone who has installed to hard drive should use marf's method. All should be fine on reboot.


“The university is well structured, well tooled, to turn out people with all the sharp edges worn off...." Mario Savio
"Protections for anonymous speech are vital to democratic discourse". Help enforce our right to free and anonymous speech by taking the Tor challenge.

Offline

#4 2012-09-21 11:48:45

pheaneasphreak
New Member
From: germany
Registered: 2011-02-24
Posts: 5

Re: (solved) US keyboard map

marf wrote:

alternatively in terminal you can type

gedit ~/.config/openbox/autostart.sh

and then uncomment the respective line.

Hi marf i have just installed Waldorf and it's great i really like it.But i also have a prblem with the keyboard layout after installing graphics driver (Radeon Mobility HD 5x).After installing the driver my keyboard layout was all messed up.i am from germany i might add.

After launhcing the command Anaconda suggested it worked well until reboot.I did not understand what you meant by "uncommenting the respective line".Can you give me a nudge on how to get my de keyboard layout to work at boot promt (I was glad the de layout worked in recovery mode to set a simple password without special characters otherwise i would be lost).

Here is my autostart.sh

xfce4-volumed &

## Enable power management
xfce4-power-manager &

## Start Thunar Daemon
thunar --daemon &

## Detect and configure touchpad. See 'man synclient' for more info.
if egrep -iq 'touchpad' /proc/bus/input/devices; then
    synclient VertEdgeScroll=1 &
    synclient TapButton1=1 &
fi

## Start xscreensaver
xscreensaver -no-splash &

## Start Clipboard manager
(sleep 3s && clipit) &

## Set keyboard settings - 250 ms delay and 25 cps (characters per second) repeat rate.
## Adjust the values according to your preferances.
xset r rate 250 25 &

## The following command runs hacks and fixes for #! LiveCD sessions.
## Safe to delete after installation.
cb-cowpowers &

## cb-welcome - post-installation script, will not run in a live session and
## only runs once. Safe to remove.
(sleep 10s && cb-welcome --firstrun) &

## cb-fortune - have Waldorf say a little adage
#(sleep 120s && cb-fortune) &

## GNOME PolicyKit and Keyring
(\
/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1 && \
/usr/bin/gnome-keyring-daemon --start --components=ssh && \
/usr/bin/gnome-keyring-daemon --start --components=secrets && \
/usr/bin/gnome-keyring-daemon --start --components=pkcs11 && \
/usr/bin/gnome-keyring-daemon --start --components=gpg \
) &

Thank you smile

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo