SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2012-02-20 20:50:52

Upanishad
Member
Registered: 2010-08-28
Posts: 48

making #! archaic [SOLVED]

I know, I have some archaic habits. I love #!, still need your help to undo few things.

Due to a hard disk failure I had to reinstall #!, which as always so streamlined and neat. During the "after install script" I said yes to liquorix kernel and regreted it. It crashed regularly (on this lenovo x201). That tuned kernel is in reality not necessary in this fast laptop but uninstalling was not easy. "apt-get remove" ran ok but the liquorix stuff remained in the / directory as a result grub menu didn't change. Even after remove I could boot that kernel. I then manually deleted the stuff in / edited /etc/default/grub and managed to eliminate them from grub menu too. I don't think that is the prescribed method but it works.

The next problem is the flash screen during kernel boot - I want to see the kernel messages. Again there was advice to remove some flash package but it didn't help. By deleting the image displayed I managed to get at least a part of the messages. Right at the beginning the messages come in vga resolution, then it changes to a higer VESA? resolution and continue with the messages. So gar so good. Then it switches to the #! flash image. First I though it comes from gdm and removed /etc/rc2.d/S06gdm, in vain. How can I stop the second flash screen?

Next comes gdm. I prefer if the machine does not start a graphical login, but present me with the console login. If I need X, I will go "startx" later. How can I get that behaviour. Removing /etc/rc2.d/S06gdm presented me the console all right, but startx didn't start Xorg, there was an error about Synaptic touch pad, which doesn't happen if I go through gdm. Can somebody explain me how I should get the terminal first and Xorg later?

Last edited by Upanishad (2012-02-22 11:26:18)

Offline

Help fund CrunchBang, donate to the project!

#2 2012-02-20 21:07:04

el_koraco
#!/loony/bun
From: inside Ed
Registered: 2011-07-25
Posts: 4,747

Re: making #! archaic [SOLVED]

I'm not sure what you mean by flash screen during boot. Do you mean the #1 logo?

As for nr 3.

sudo update-rc.d gdm remove
touch .xinitrc
geany .xinitrc

Paste this in

#!/bin/sh
eval `dbus-launch --sh-syntax --exit-with-session`
exec ck-launch-session openbox-session

Reboot.

Offline

#3 2012-02-20 23:04:59

Upanishad
Member
Registered: 2010-08-28
Posts: 48

Re: making #! archaic [SOLVED]

Hi Die-hard

You are my hero. Your recipe solved my third problem, though I don't understand half of it. I didn't realize there is such a thick layer of distribution specific tools.

Anyway, thanks a lot!

Yes, the second problem is the blinking #! logo, which hides the final part of the boot messages and the output of the init scripts. Would be happy to raise that curtain too.

Offline

#4 2012-02-20 23:58:39

nablacksax
#! Member
From: Houghton, MI
Registered: 2011-08-26
Posts: 58

Re: making #! archaic [SOLVED]

While this doesn't really fix your 2nd problem, the flashing "#!" (A Plymouth Script, if I'm not mistaken) has not been around since the 20110207 release. It was deemed unnecessary eye candy in the latest releases. You might want to download the newest version of CrunchBang and use that instead. Not only are there some nice improvements, but the flashing #! is gone.

Offline

#5 2012-02-21 11:58:31

orionthehunter
#! Constellation
From: Japan
Registered: 2011-04-09
Posts: 899
Website

Re: making #! archaic [SOLVED]

you could also just sudo apt-get remove plymouth

Offline

#6 2012-02-21 15:03:13

rhowaldt
#!*$%:)
Registered: 2011-03-09
Posts: 4,396

Re: making #! archaic [SOLVED]

^ i think that leaves some of the init-scripts in though, not 100% sure... not a huge issue but you'll maybe see a message in the boot log that it is searching for plymouth. i could be wrong, was some time ago i removed it myself and seem currently unable to find a good forum post which goes into this stuff.

Offline

#7 2012-02-21 15:24:14

mynis01
#! Die Hard
From: 127.0.0.1
Registered: 2010-07-02
Posts: 1,929

Re: making #! archaic [SOLVED]

Or you can just hit F1 when the blinky #! appears to make it go away. You can switch to tty2 instead of logging into X by hitting ctrl+alt+f2. You can verify which kernel is currently running with the command

uname -a

Last edited by mynis01 (2012-02-21 15:34:38)

Offline

#8 2012-02-21 18:44:48

Upanishad
Member
Registered: 2010-08-28
Posts: 48

Re: making #! archaic [SOLVED]

Hi Guys

Thanks for all the hints.

First I ran "apt-get remove plymouth", which successfully removed a bunch of packages. But, the flashing #! remains, and won't give my tty1 free ! unless hit F1 early enough.
;-(

I can continue in tty2 but that is a nuisance for this laptop, which I switch on and off very often. I need a clean solution. Statler 20120207 is the best way for me. I need a longer break for that. Will report here.

Offline

#9 2012-02-22 01:46:35

tmillic
#! CrunchBanger
From: Fayetteville - Tucson
Registered: 2011-04-25
Posts: 213

Re: making #! archaic [SOLVED]

Is it still crashing? If it's a new install anyway, it might not hurt to just try again and not add the liquorix kernel.
So I'm not the only one with a Lenovo laptop avoiding Liquorix after experiencing crashes.

Offline

#10 2012-02-22 08:22:55

Upanishad
Member
Registered: 2010-08-28
Posts: 48

Re: making #! archaic [SOLVED]

Hi timillic

Are you talking about the liquorix kernel? I removed it before starting this discussion (see para one of my original post).

Offline

#11 2012-02-22 11:34:05

Upanishad
Member
Registered: 2010-08-28
Posts: 48

Re: making #! archaic [SOLVED]

Hi all

Yes, I'm writing this from a shiny Statler 20120207, it solved all the annoyances I had!

Backing up data was not a big deal. I always have three partitions, two systems and one home, one of the systems is always testing. The new installation went to the previous test. If I need to, I can still boot the old statler or just mount it, for comparison.

As always #! is clean and snappy. And I the first time install script is ingenious. I took the opportunity to move to LibreOffice, get the development tools, packaging tools, LAMP environment, etc.

Thanks a lot to all, especially to the developers!

BTW, isn't it ironical that the latest release is more archaic than the previous.

Offline

#12 2012-03-06 17:10:41

SabreWolfy
#! Die Hard
Registered: 2009-03-09
Posts: 1,285

Re: making #! archaic [SOLVED]

el_koraco wrote:

<snip>

sudo update-rc.d gdm remove
touch .xinitrc
geany .xinitrc

Paste this in

#!/bin/sh
eval `dbus-launch --sh-syntax --exit-with-session`
exec ck-launch-session openbox-session

Reboot.

Can this be considered as the minimum requirement for setting up before starting X? What do these lines do?


Support #!Waldorf • Debian sid • Xubuntu • siduction • Peppermint • OpenBox • Xfce • LXDE •

Offline

#13 2012-03-06 17:34:26

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,595

Re: making #! archaic [SOLVED]

First line starts session bus and exports a 'shared secret' available in all subprocesses.
The second line makes sure that all processes started in X have a common ancestor, and share the same 'secret' so that they can communicate via the session bus, and can gain system privileges within the limits outlined in the console-kit session.

Offline

#14 2012-03-06 19:41:56

SabreWolfy
#! Die Hard
Registered: 2009-03-09
Posts: 1,285

Re: making #! archaic [SOLVED]

Thanks smile


Support #!Waldorf • Debian sid • Xubuntu • siduction • Peppermint • OpenBox • Xfce • LXDE •

Offline

#15 2012-03-07 06:51:54

SabreWolfy
#! Die Hard
Registered: 2009-03-09
Posts: 1,285

Re: making #! archaic [SOLVED]

@Upanishad: You boot and login at a console and work on whatever you're doing, that doesn't require X, and at a later point when you need a GUI, you start X? You browse from the console? GMail, Twitter, these forums smile etc. from the console?

Last edited by SabreWolfy (2012-03-07 06:52:50)


Support #!Waldorf • Debian sid • Xubuntu • siduction • Peppermint • OpenBox • Xfce • LXDE •

Offline

#16 2012-03-07 07:07:37

pvsage
Internal Affairs
From: North Carolina
Registered: 2009-10-18
Posts: 11,443

Re: making #! archaic [SOLVED]

^ Actually, I'm trying this from Lynx on tty2 for the first time right now.  Feels really funky, but in a cool, geeky way.

I really don't care for the fact that the entry field doesn't wrap though. tongue


Yes; as a matter of fact, I am a cop.  Why do you ask? cool
I'm a moderator here.  How are we doing?  Feedback is encouraged.

Offline

#17 2012-03-07 07:13:23

SabreWolfy
#! Die Hard
Registered: 2009-03-09
Posts: 1,285

Re: making #! archaic [SOLVED]

elinks? w3m? links? links2? conkeror?

Last edited by SabreWolfy (2012-03-07 07:14:34)


Support #!Waldorf • Debian sid • Xubuntu • siduction • Peppermint • OpenBox • Xfce • LXDE •

Offline

#18 2012-03-07 07:35:08

pvsage
Internal Affairs
From: North Carolina
Registered: 2009-10-18
Posts: 11,443

Re: making #! archaic [SOLVED]

Tried w3m; hated it.  Will have to try some of the others, but Lynx does get the job done.


Yes; as a matter of fact, I am a cop.  Why do you ask? cool
I'm a moderator here.  How are we doing?  Feedback is encouraged.

Offline

#19 2012-03-07 08:08:12

Tunafish
#! Die Hard
From: the Netherlands
Registered: 2010-03-07
Posts: 1,204

Re: making #! archaic [SOLVED]

Upanishad wrote:

First I ran "apt-get remove plymouth", which successfully removed a bunch of packages. But, the flashing #! remains, and won't give my tty1 free ! unless hit F1 early enough.

Did you run

sudo update-initramfs -u

after removing plymouth?


sed 's/stress/relaxation/g'
Privacy & Security on #!

Offline

#20 2012-03-07 08:55:36

SabreWolfy
#! Die Hard
Registered: 2009-03-09
Posts: 1,285

Re: making #! archaic [SOLVED]

pvsage wrote:

Tried w3m; hated it.  Will have to try some of the others, but Lynx does get the job done.

Yeah, I forget which ones support JavaScript and which don't. How about Flash? big_smile


Support #!Waldorf • Debian sid • Xubuntu • siduction • Peppermint • OpenBox • Xfce • LXDE •

Offline

#21 2012-03-07 15:39:26

pvsage
Internal Affairs
From: North Carolina
Registered: 2009-10-18
Posts: 11,443

Re: making #! archaic [SOLVED]

^ Live Studio Ostrich: "Ha-HAhhh!"


Yes; as a matter of fact, I am a cop.  Why do you ask? cool
I'm a moderator here.  How are we doing?  Feedback is encouraged.

Offline

#22 2012-03-07 15:45:48

2ManyDogs
dv#!
From: elsewhere
Registered: 2011-11-22
Posts: 1,346

Re: making #! archaic [SOLVED]

SabreWolfy wrote:

@Upanishad: You boot and login at a console and work on whatever you're doing, that doesn't require X, and at a later point when you need a GUI, you start X?

This is what I do on my arch box. I've been trying to do as much as I can from the console on that machine -- I'm learning tmux and vim and tried a bunch of console browsers. I have now also removed the login managers from my testing and sid installs and may do it soon on  my main machine. Unlike pvsage, I really like w3m -- it uses the frame buffer so you can see screenshots in the console, and it drops into vim for editing posts. It does not seem to understand gpm (the console mouse) but neither does lynx -- elinks does though. They all have their pluses and minuses.

Last edited by 2ManyDogs (2012-03-07 15:46:08)


Be eggsalad to each other.

Offline

#23 2013-01-24 20:03:29

starvolf
New Member
Registered: 2013-01-24
Posts: 1

Re: making #! archaic [SOLVED]

Hello everyone! Here's my wish was to install crunchbang and not knowing what happened to flashpluginon, simply does not work in the following browsers: Iceweacel, Google Chrome and Opera.I would ask for help if you can! thanks a lot!

Offline

#24 2013-01-24 20:05:49

SabreWolfy
#! Die Hard
Registered: 2009-03-09
Posts: 1,285

Re: making #! archaic [SOLVED]

starvolf wrote:

Hello everyone! Here's my wish was to install crunchbang and not knowing what happened to flashpluginon, simply does not work in the following browsers: Iceweacel, Google Chrome and Opera.I would ask for help if you can! thanks a lot!

Welcome to the #! forums. Your question will stand a better chance of a response if you make a new thread in the appropriate forum (stable or testing), rather than replying to an unrelated thread.


Support #!Waldorf • Debian sid • Xubuntu • siduction • Peppermint • OpenBox • Xfce • LXDE •

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo