SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2008-12-04 08:19:44

omns
#! wanderer
From: ~/
Registered: 2008-11-25
Posts: 5,131

Howto: lxpanel menu applet logout fix

OK, first things first, this howto is just a reproduction of the problem and solution presented in this thread by corenominal. I thought it would make a nice howto for this tips and tricks forum

If you have the menu applet installed and are using it with lxpanel you will notice that the logout entry doesn't work properly, generating a "Failed to execute child process "lxsession-logout" (No such file or directory)" error.

lxsession is not installed by default so to solve this problem you ned to create a new symbolic link in my your personal bin directory named "lxsession-logout" and have it pointed to the existing openbox-logout script/command.

A personal bin directory should have been created by default, if you have deleted it, you will need to recreate it and restart your session. Next, run the following command to create the symbolic link

ln -s /usr/bin/openbox-logout ~/bin/lxsession-logout

Any call to lxsession-logout should now invoke the default openbox-logout script/command.

Note: If you do not want a personal bin directory, you could always create the link directly in the /usr/bin directory

sudo ln -s /usr/bin/openbox-logout /usr/bin/lxsession-logout

Offline

Be excellent to each other!

#2 2008-12-04 18:47:40

corenominal
WRONG
From: Lincoln, UK
Registered: 2008-11-20
Posts: 5,054
Website

Re: Howto: lxpanel menu applet logout fix

Thanks for recreating this topic. This issue could probably do with being fixed by default smile

Offline

#3 2008-12-06 07:11:48

ghoti
#! Member
From: Twilight Zone
Registered: 2008-11-30
Posts: 61

Re: Howto: lxpanel menu applet logout fix

I solved this issue simply by replacing lxsession-logout by openbox-logout in the panel file located in ~/.config/lxpanel/default/panels/panel:

Plugin {
    type = menu
    Config {
        image=/usr/share/lxpanel/images/my-computer.png
        system {
        }
        separator {
        }
        item {
            command=run
        }
        separator {
        }
        item {
            name=Logout
            image=gnome-logout
            action=/usr/bin/openbox-logout
        }
    }
}

It's the same idea as the symbolic link, except that the change is more direct. Again, there is more than one way to skin a cat. wink

Please note though that it is not recommended to change the content of this file:

# lxpanel <profile> config file. Manually editing is not recommended.
# Use preference dialog in lxpanel to adjust config when you can.

.

I still do it anyway. wink

Ghoti cool


Many of life's failures are people who did not realize how close they were to success when they gave up.
Our greatest weakness lies in giving up. The most certain way to succeed is always to try just one more time.

                                                                                                                                              Thomas A. Edison

Offline

#4 2009-08-08 22:44:22

nabilalk
#! Die Hard
From: U.S.A.
Registered: 2009-01-28
Posts: 531

Re: Howto: lxpanel menu applet logout fix

ghoti wrote:

I solved this issue simply by replacing lxsession-logout by openbox-logout in the panel file located in ~/.config/lxpanel/default/panels/panel:

Plugin {
    type = menu
    Config {
        image=/usr/share/lxpanel/images/my-computer.png
        system {
        }
        separator {
        }
        item {
            command=run
        }
        separator {
        }
        item {
            name=Logout
            image=gnome-logout
            action=/usr/bin/openbox-logout
        }
    }
}

It's the same idea as the symbolic link, except that the change is more direct. Again, there is more than one way to skin a cat. wink

Please note though that it is not recommended to change the content of this file:

# lxpanel <profile> config file. Manually editing is not recommended.
# Use preference dialog in lxpanel to adjust config when you can.

.

I still do it anyway. wink

Ghoti cool

I'm digging the direct fix, thanks ghoti


#! 10 “Statler” r20110207 32-bit & Openbox

Offline

#5 2012-01-03 00:33:22

anthony
Member
From: Brisbane, Australia
Registered: 2010-04-05
Posts: 13
Website

Re: Howto: lxpanel menu applet logout fix

ghoti wrote:

Please note though that it is not recommended to change the content of this file:

# lxpanel <profile> config file. Manually editing is not recommended.
# Use preference dialog in lxpanel to adjust config when you can.

.

I still do it anyway. wink

Ghoti cool

The GUI control for the panel sucks.  It does not allow you to modify icons or add 'special' things.
As such I find editing the panel manually with a text editor (after using the GUI to add the appropriate items to be modified) a must in many cases.

However after editing the file run the command

lxpanelctl restart

What ever you do, DO NOT mix the GUI and text edit of configs at the same time.



Does anyone know where you can get 'syntax' or 'format' information for the configuration files?

Last edited by anthony (2012-01-03 00:34:54)


Anthony Thyssen   -- Webmaster for ImageMagick Example Pages
                  http://www.imagemagick.org/Usage/

Offline

#6 2012-01-03 10:57:23

Kuno
#! Die Hard
From: Osnabrück - DE
Registered: 2009-01-09
Posts: 626

Re: Howto: lxpanel menu applet logout fix

anthony wrote:

The GUI control for the panel sucks.  It does not allow you to modify icons or add 'special' things.

Do you have lxshortcut installed ??
If not - do so, and then rightclick on a menu item...

Offline

#7 2012-01-04 00:25:54

anthony
Member
From: Brisbane, Australia
Registered: 2010-04-05
Posts: 13
Website

Re: Howto: lxpanel menu applet logout fix

Kuno wrote:
anthony wrote:

The GUI control for the panel sucks.  It does not allow you to modify icons or add 'special' things.

Do you have lxshortcut installed ??
If not - do so, and then rightclick on a menu item...

No I didn't but it looks like just what I needed.

I have now installed it and restarted the panel, but I can see any difference!

No extra GUI options, buttons, menus are visible, and running lxshortcut direct just exits without anything visible changling!  Man pages just re-iterate basic info and does not say exactly what it does.

Never mind I found it... It only appears in the 'Menu' Entries as 'Properities'.
And how to use only appears in its "--help" option output.

It can not be currently directly used with LaunchBar items, which is where I need it!
Command line use is good for creating personal desktop items, but dore not provide access to other desktop options (whcih could have been added to 'advanced'.

Thanks for this info. It pointed me toward a lot of extra information I did not have before.

Last edited by anthony (2012-01-04 02:35:07)


Anthony Thyssen   -- Webmaster for ImageMagick Example Pages
                  http://www.imagemagick.org/Usage/

Offline

#8 2013-05-25 07:28:46

jon#!
Member
Registered: 2013-05-20
Posts: 36

Re: Howto: lxpanel menu applet logout fix

I've been trying to fix this every which way. I installed just the lxpanel and lxshortcut. Does anyone have any new info on this? The above didn't work for me. Before you ask, I remembered to lxpanelctl restart.

The error: Failed to execute child process "/bin/lxsession-logout" (No such file or directory).

Any help would be appreciated.


"I would site regulation, but I know you would simply ignore it" - Spock

Offline

#9 2013-05-25 22:43:42

Kuno
#! Die Hard
From: Osnabrück - DE
Registered: 2009-01-09
Posts: 626

Re: Howto: lxpanel menu applet logout fix

jon#! wrote:

I've been trying to fix this every which way. I installed just the lxpanel and lxshortcut. Does anyone have any new info on this? The above didn't work for me. Before you ask, I remembered to lxpanelctl restart.

The error: Failed to execute child process "/bin/lxsession-logout" (No such file or directory).

Any help would be appreciated.

Rightclick the panel and under preferences in the advanced tab, change lxsession-logout to "cb-exit".

Offline

#10 2013-05-28 15:26:18

jon#!
Member
Registered: 2013-05-20
Posts: 36

Re: Howto: lxpanel menu applet logout fix

Kuno wrote:

Rightclick the panel and under preferences in the advanced tab, change lxsession-logout to "cb-exit".

Thanks! Unable to test though, since I found xfce4-panel buried in the base install.


"I would site regulation, but I know you would simply ignore it" - Spock

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo