SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2011-05-18 20:55:23

GrouchyGaijin
#! Member
From: Sweden
Registered: 2011-04-03
Posts: 67
Website

Change time zone of the system time [SOLVED]

Hi Guys,

When I installed #! (with Xfce) I chose the wrong timezone.  I now have the correct zone showing on the clock, but I think the system is still set to the wrong zone and only displaying my correct time on the clock.

(I hope that makes sense.)

The problem is that the conkyForecast script shows the last time data was fetched using the incorrect time.  It's showing the time for the timezone I selected when I installed #! not the time on my clock.

Is there a way I can change the timezone for the machine and not simply which zone is displayed on the clock?

Last edited by GrouchyGaijin (2011-05-18 21:11:12)


Thank you,

GG
Dell Inspiron 1520 - EeePC 1000H both single boot 100% Linux

Offline

Help fund CrunchBang, donate to the project!

#2 2011-05-18 21:00:32

Awebb
The Singularity
Registered: 2009-07-23
Posts: 2,812

Re: Change time zone of the system time [SOLVED]


I'm so meta, even this acronym

Offline

#3 2011-05-18 21:10:27

GrouchyGaijin
#! Member
From: Sweden
Registered: 2011-04-03
Posts: 67
Website

Re: Change time zone of the system time [SOLVED]

Thank you!

dpkg-reconfigure tzdata

Did the trick.


Thank you,

GG
Dell Inspiron 1520 - EeePC 1000H both single boot 100% Linux

Offline

#4 2012-08-12 08:20:57

boomclart
#! Member
Registered: 2011-11-17
Posts: 83

Re: Change time zone of the system time [SOLVED]

My system clock appeared to be right... showing BST but websites were behind by 5 hours (I could of sworn I'd setup some UK NTP servers previously)

david@crunchbang:~$ date
Sun Aug 12 09:11:34 EDT 2012
david@crunchbang:~$ ps ax | grep ntp
 6254 pts/0    S+     0:00 grep ntp

So I have tried running

david@crunchbang:~$ sudo dpkg-reconfigure tzdata
[sudo] password for david: 

Current default time zone: 'Europe/London'
Local time is now:      Sun Aug 12 14:14:19 BST 2012.
Universal Time is now:  Sun Aug 12 13:14:19 UTC 2012.

Now websites show the correct time but the system clock and output from date shows 5 hours ahead

david@crunchbang:~$ date
Sun Aug 12 14:14:42 BST 2012

Any ideas?

Last edited by boomclart (2012-08-12 08:23:02)


FB | G+ | T

Offline

#5 2012-08-12 20:18:37

ivanovnegro
Ivan #000000
From: unstable madness
Registered: 2011-06-02
Posts: 5,429

Re: Change time zone of the system time [SOLVED]

Man, this thread is old and solved. You have luck I noticed your post. smile It would be better to open a new thread.

Anyway, have you rebooted your machine or logged out/logged in?

Is the ntp server running:

sudo /etc/init.d/ntp status

Maybe you have just to restart it:

sudo /etc/init.d/ntp restart

Offline

#6 2012-08-13 10:51:24

boomclart
#! Member
Registered: 2011-11-17
Posts: 83

Re: Change time zone of the system time [SOLVED]

ivanovnegro wrote:

Man, this thread is old and solved. You have luck I noticed your post. smile It would be better to open a new thread.

Anyway, have you rebooted your machine or logged out/logged in?

Is the ntp server running:

sudo /etc/init.d/ntp status

Maybe you have just to restart it:

sudo /etc/init.d/ntp restart

Looks like I may of setup NTP on the Sammy netbook and not this laptop as it's not present on here.


david@crunchbang:~$ sudo /etc/init.d/ntp status
[sudo] password for david: 
sudo: /etc/init.d/ntp: command not found
david@crunchbang:~$ sudo /etc/init.d/ntp restart
sudo: /etc/init.d/ntp: command not found

So do I have to go through setting up NTP on this laptop or can I not just adjust these times/zones manually so they just work?

The only thing I can think which is thowing this laptop into a time warp is it is a US laptop with US keyboard and I use a US locale/keyboard map so the keys match instead of using UK.

So may it be somehow thinking it is a US machine, hence why it displays times originally in EDT?

Last edited by boomclart (2012-08-13 10:54:03)


FB | G+ | T

Offline

#7 2012-08-13 19:01:46

ivanovnegro
Ivan #000000
From: unstable madness
Registered: 2011-06-02
Posts: 5,429

Re: Change time zone of the system time [SOLVED]

You would just have to install NTP IMO, Debian will automatically care of it.

Offline

#8 2012-08-13 19:12:33

pidsley
Window Mangler
Registered: 2012-05-23
Posts: 1,752

Re: Change time zone of the system time [SOLVED]

boomclart, what does this command return

cat /etc/adjtime

and this one:

sudo hwclock

does this command return the correct local time or UTC time?

Last edited by pidsley (2012-08-13 19:15:43)

Offline

#9 2012-08-13 23:45:53

boomclart
#! Member
Registered: 2011-11-17
Posts: 83

Re: Change time zone of the system time [SOLVED]

david@crunchbang:~$ cat /etc/adjtime
2352.831385 1344903692 0.000000
1344903692
LOCAL
david@crunchbang:~$ sudo hwclock
[sudo] password for david: 
Tue 14 Aug 2012 05:45:04 AM BST  -0.047586 seconds

FB | G+ | T

Offline

#10 2012-08-14 00:15:54

pidsley
Window Mangler
Registered: 2012-05-23
Posts: 1,752

Re: Change time zone of the system time [SOLVED]

Is that the correct local time?

What does

date

return?

I think we're close to fixing this.

Last edited by pidsley (2012-08-14 00:16:49)

Offline

#11 2012-08-14 10:18:45

boomclart
#! Member
Registered: 2011-11-17
Posts: 83

Re: Change time zone of the system time [SOLVED]

Installing NTP fixed it automatically... cheers anyway Pidsley.


FB | G+ | T

Offline

#12 2012-08-14 10:23:26

ivanovnegro
Ivan #000000
From: unstable madness
Registered: 2011-06-02
Posts: 5,429

Re: Change time zone of the system time [SOLVED]

^ And I said so. wink But nobody believes me. roll

Offline

#13 2012-08-14 10:43:18

boomclart
#! Member
Registered: 2011-11-17
Posts: 83

Re: Change time zone of the system time [SOLVED]

Correctomundo fella!


FB | G+ | T

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo