SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2011-01-20 19:35:30

Criminal
#! Member
Registered: 2010-02-26
Posts: 62

[SOLVED] No login to #!-forums -> a cookie has not been set

Hi!

I set up a fresh Install of #! (Statler, recent iso) onto my Thinkpad R61 and just finished installing the software I need all the time. The configuration is very close to my desktop, I only did some minor changes to conky and menu.rc.

On both systems I use Iron while still having chromium installed. Iceweasel is installed on the desktop as well, because this used to be my browser of choice before Iron. Another difference is that I use the liquorix-kernel on my laptop.

What happens:
When I try to login at #! forums with Chromium or Iron from my laptop I get following message:
You appear to have logged in successfully, however a cookie has not been set. Please check your settings and if applicable, enable cookies for this website.

This happens only on #! forums. Every other website works fine and keeps me logged in. I checked for accepted cookies and found crunchbanglinux.org right on top. However there seems to be a part missing: when comparing it with the cookie on my desktop there are two entries missing: forum_cookie_ee42b2 and forum_cookie_ee42b2_track

First I thought I messed up the configuration of Iron, but since I copied it over from my desktop it should be allright. However i switched back to default settings with no change. Even deleting the chromium folder in .config/ didn't change anything. I also reinstalled chromium and iron without any success.

This failure happens with both kernels, liquorix and default.

Any suggestions?

Ragards,

Last edited by Criminal (2011-01-28 15:05:14)

Offline

Be excellent to each other!

#2 2011-01-20 19:50:20

Criminal
#! Member
Registered: 2010-02-26
Posts: 62

Re: [SOLVED] No login to #!-forums -> a cookie has not been set

Just found a topic that covers the same here.

corenominal, could you please clear the logs once again?

Seems like I got too many systems using #! which all use the same router.

Offline

#3 2011-01-21 21:53:39

corenominal
WRONG
From: Lincoln, UK
Registered: 2008-11-20
Posts: 5,057
Website

Re: [SOLVED] No login to #!-forums -> a cookie has not been set

Criminal wrote:

corenominal, could you please clear the logs once again?

Done.

Please try again and let me know how you get on. smile

Offline

#4 2011-01-22 00:45:30

Criminal
#! Member
Registered: 2010-02-26
Posts: 62

Re: [SOLVED] No login to #!-forums -> a cookie has not been set

Hmm, didn't work for me.

I've tried different things up to now:

- removed chromium config folder -> default settings 
- copied over the chromium folder from this machine (desktop) which is working fine
- only copied over the cookies with working login cookie from crunchbang.org
- used different browser (Midori)

Nothing worked. I don't think the IP is the problem as well, because both machines show the same IP to the internet. Both use the same router.

I don't get it... let's see if can login using a liveCD.

Edit: No problem with Ubuntu 10.10 LiveCD. Firefox and Iron work fine.
Seems to be a problem with my #! installation.

Edit 2: Installed another user and tried to login from that -> no chance. Midori and Iron didn't work.
Will give it another try tomorrow.

Last edited by Criminal (2011-01-22 01:18:05)

Offline

#5 2011-01-22 02:25:57

corenominal
WRONG
From: Lincoln, UK
Registered: 2008-11-20
Posts: 5,057
Website

Re: [SOLVED] No login to #!-forums -> a cookie has not been set

Hmm, strange. The only thing I can think of at the moment is that it might be related to your system's time configuration -- cookies are time sensitive, so it might be worth checking the time and date on your system to make sure they are correct.

^ is a long-shot!

Offline

#6 2011-01-22 17:09:25

Criminal
#! Member
Registered: 2010-02-26
Posts: 62

Re: [SOLVED] No login to #!-forums -> a cookie has not been set

Then you're a real sniper! My laptop time is one hour ahead.
But unfortunatelly I couldn't solve it .
date and date -u both tell me I use UTC time for local and universal time on my laptop. Seems like I messed that up during installation. Desktop shows CET for local time and UTC universal time.

I tried different thing to change localtime to CET (several reboots not listed):
- changed /etc/default/rcS from UTC=yes to UCT=no
- ntpdate pool.ntp.org
- dpkg-reconfigure tzdata

Still there is UTC used for both, local and universal time. (after dpkg-reconfigure tzdata)
Am I missing something? I thought UTC=no would change that during reboot.

BIOS time is local, by the way.

Offline

#7 2011-01-22 18:13:31

nathwill
#! CrunchBanger
From: Portland, OR USA
Registered: 2010-11-05
Posts: 215
Website

Re: [SOLVED] No login to #!-forums -> a cookie has not been set

that could be part of the problem. all my systems run with BIOS time as UTC, and tzdata basically lets the OS know how much to correct, with occasional nudges from ntpdate...


NOTICE: alloc: /dev/null: filesystem full

Offline

#8 2011-01-23 11:28:11

Criminal
#! Member
Registered: 2010-02-26
Posts: 62

Re: [SOLVED] No login to #!-forums -> a cookie has not been set

That did it, thanks.
I would have prefered using local time in BIOS and switching #! to use that as well. I have Windos XP installed as dualboot and now time is messed up over there. But since I don't use it that often I don't care.

Thanks for the support!

Offline

#9 2011-01-23 19:45:58

Criminal
#! Member
Registered: 2010-02-26
Posts: 62

Re: [SOLVED] No login to #!-forums -> a cookie has not been set

Well, I marked this thread as solved too fast.

I can login to the forums , but the system time is one hour behind now. As soon as I use ntpdate (every startup I think) my local time is set to utc time again. I can change that by date --set hh:mm:ss, but I don't want to do that every startup. I could make a script, but i don't think that's how it should be like either. I read about the option in /etc/default/ntpdate as well, but I would like to keep ntp support for syncing my clock.

What does the install script do, when it asks whether I want to use UTC or local time as system time? Or where can I find its code, then I'll check myself. Seems like it does some more than setting the UTC-option in /etc/default/rcS.

Offline

#10 2011-01-28 15:04:43

Criminal
#! Member
Registered: 2010-02-26
Posts: 62

Re: [SOLVED] No login to #!-forums -> a cookie has not been set

Finally I found the solution.

At the beginning of this thread I manually altered /etc/localtime setting a systemlink to my timezone. Somehow I must have messed that up. I compared the files with a running live-CD and learned that I have linked localtime to the timezone folder.

I copied over localtime from the Live-CD and rebooted. Voila: time is set correctly and ntpdate as well as dpkg-reconfigure tzdata result in the correct time. Timezone is local now.

Thanks for ur support!

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo