SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#3 Re: Help & Support (Testing/Unstable) » [SOLVED] /dev/dvd keeps being removed. » 2014-05-01 14:11:51

Thanks for the replies. I'm on unstable but not using systemd. Yes, /dev/dvd is a symlink to /dev/sr0 which does remain when I reboot, it's just /dev/dvd and /dev/cdrom which get removed and I have to replace them as various programs expect them to be there.

EDIT: I just enabled udev logging, as you suggested twoion, and when I rebooted /dev/dvd and /dev/cdrom were there! There was a kernel update today so maybe that's got something to do with it - perhaps I'm losing it, I don't know - I'll mark the thread as solved and see what happens in future.

#4 Help & Support (Testing/Unstable) » [SOLVED] /dev/dvd keeps being removed. » 2014-05-01 10:39:30

Lord Stranger
Replies: 4

I don't reboot my laptop very often but when I do the link /dev/dvd gets removed, last time /dev/cdrom was removed too but I can't remember if that always happens. Does anyone know why this is and any way of stopping it happening? Cheers.

#6 Re: Tips, Tricks & Scripts » [SOLVED] any snippet manager available for #! ? » 2014-03-01 00:32:23

I don't know if this is of any use, but you can keep a list of frequently used snippets in clipit - if you open the 'manage history' window you can use the edit option to save an entry as a static item in a permanent list below the 'live' one.

#8 Re: Help & Support (Testing/Unstable) » Some GTK applications only run as root. » 2013-09-10 14:13:21

Thanks ew, it seems I may be the only person having this particular problem hmm  .I have actually considered upgrading to sid to see if the problem would be solved - it seems a bit of a drastic measure, especially as there's no guarantee of success, but I have been thinking about moving over to sid at some point anyway.

#9 Re: Help & Support (Testing/Unstable) » Some GTK applications only run as root. » 2013-09-10 11:58:39

Yes, I can run other gtk apps as user, I haven't compiled an exhaustive list of applications which won't work, but they seem to be many of the ones others have had trouble with - file-roller, evince, shotwell, synaptic, transmission-gtk, gnome-mplayer, pavucontrol, galculator.

#10 Re: Help & Support (Testing/Unstable) » Some GTK applications only run as root. » 2013-09-10 11:36:03

Thanks ew, I tried the zukitwo theme and it was the same - I could run the affected apps as root but not as user. BTW I was wrong about the crunchy-darkness theme, I can run the apps as root using it but still not as user...

#11 Re: Help & Support (Testing/Unstable) » Some GTK applications only run as root. » 2013-09-10 10:23:28

Thanks for the replies.

Ew, yes I did change theme as user and root - I forgot to metion it. I tried your updated Crunchy themes and my gtk3 apps wouldn't run at all, even as root...

Pvsage, I have looked at that thread previously, I had another read through it - people mostly seemed to be suggesting changing themes again or downgrading libgtk-3-0. I've tried quite a lot of themes now and I'm not keen to start downgrading things. What's baffling me is why these applications will run as root but not as a normal user?!

#12 Help & Support (Testing/Unstable) » Some GTK applications only run as root. » 2013-09-09 20:50:56

Lord Stranger
Replies: 13

Some of my GTK applications stopped working a few weeks ago, when run from the terminal I had gtk warnings, GLib-GObject warnings and a segmentation fault. It seemed to be the same problem others were having which could be resolved by changing themes, so I tried a load of other themes but to no avail. I've since discovered that these applications will run using ew's modified waldorf theme (from this post) but only as root.
This is the terminal output when I try to run evince:

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:56:16: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:72:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:168:18: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:169:12: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:172:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:202:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:205:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:256:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:289:11: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:291:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:369:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:449:16: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:458:16: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:483:16: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:494:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:499:18: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:618:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:663:16: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:663:20: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:663:22: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:678:16: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:678:18: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:678:20: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:678:22: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:704:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:744:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:763:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:775:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:777:16: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:797:16: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:808:16: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:826:16: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:844:16: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:862:16: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:902:16: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:916:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:920:20: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:931:16: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:939:16: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:941:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:954:11: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:956:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:981:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1048:18: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1057:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1058:11: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1068:11: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1068:13: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1068:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1116:16: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1128:16: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1150:16: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1173:16: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1188:16: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1200:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1210:16: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1211:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1255:22: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1269:16: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1285:16: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1309:16: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1420:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1492:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1509:18: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1525:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1571:20: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1572:11: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1575:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1583:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1592:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1596:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1618:16: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1651:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1717:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1733:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1756:16: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1768:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1828:16: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1829:11: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1829:13: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1829:15: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1829:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1836:18: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1836:20: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1836:22: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1845:16: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1845:20: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1845:22: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1846:11: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1848:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1882:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1882:23: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1889:19: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1889:21: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1890:16: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gnome-panel.css:54:18: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gnome-panel.css:54:22: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gnome-panel.css:65:18: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gnome-panel.css:65:22: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gnome-panel.css:91:18: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gnome-panel.css:91:22: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gnome-panel.css:107:18: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: gnome-panel.css:107:22: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: nautilus.css:8:15: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: nautilus.css:8:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: nautilus.css:14:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: nautilus.css:22:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: nautilus.css:42:18: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: nautilus.css:42:20: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: nautilus.css:42:22: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: nautilus.css:60:17: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: nautilus.css:60:19: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: nautilus.css:62:16: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: nautilus.css:86:18: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: nautilus.css:86:22: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: unity.css:8:16: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: unity.css:20:16: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: unity.css:20:18: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: unity.css:20:22: Not using units is deprecated. Assuming 'px'.

(evince:11770): Gtk-WARNING **: Theme parsing error: unity.css:21:18: Not using units is deprecated. Assuming 'px'.

** (evince:11770): WARNING **: Can't load fallback CSS resource: Failed to import: The resource at '/org/gnome/adwaita/gtk-fallback.css' does not exist

** (evince:11770): WARNING **: Can't load fallback CSS resource: Failed to import: The resource at '/org/gnome/adwaita/gtk-fallback.css' does not exist

(evince:11770): Gtk-WARNING **: Style property "border-top-left-radius" is not gettable

(evince:11770): GLib-GObject-WARNING **: /tmp/buildd/glib2.0-2.36.4/./gobject/gtype.c:4239: type id `0' is invalid

(evince:11770): GLib-GObject-WARNING **: can't peek value table for type `<invalid>' which is not currently referenced
Segmentation fault

Anyone know what's going on here?
I'm on Testing BTW.

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo